Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How can I keep using LXQt on Gentoo?
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3257
Location: Gainesville, Florida

PostPosted: Sat Aug 11, 2018 4:47 pm    Post subject: Reply with quote

Hmmm. Good news, as I have used and liked LXQT in the past.
However, I just emerged lxqt-meta-0.13 and all went well, it shows up in my sddm login list, but when selected I still get kde even after a reboot,. :?
I still have lxde installed and in the list- could that be a problem? Or does lxqt need lightdm? Do I need to create a .desktop file?

OK, /usr/share/xsessions/ does have the normal lxqt.desktop file, just created with today's install. Also have a normal /usr/bin/startlxqt file, from today.

Curious. For many years whenever I installed a DE (kde, gnome, xfce, lxde, lxqt, or whatever) it always showed up and launched fine, no matter if I was using kdm, gdm, lightdm, or sddm as my display manager.

I must be missing something. :roll: qt version problem? re-merge sddm?

EDIT: Hmmm. In addition to lxqt, sddm no longer will launch either lxde, xfce4, or even xsession, but only plasma. Even after rebuilding sddm. Does this mean I'll need to use lightdm if I want anything but plasma?

Downgrade sddm (currently x11-misc/sddm-0.15.)?

Any clue here? my installed sddm-kcm version is 5.13.4, available versions only go to 5.13.3
Code:
gentoo-main ~ # eix sddm
[?] kde-plasma/sddm-kcm
     Available versions:  (5) 5.12.5 (~)5.12.6 (~)5.13.3
       {debug}
     Installed versions:  5.13.4(5)(06:25:09 AM 08/07/2018)(-debug)
     Homepage:            https://cgit.kde.org/sddm-kcm.git
     Description:         KDE Plasma control module for SDDM

[I] x11-misc/sddm
     Available versions:  0.15.0 [m]0.17.0-r4 [m]0.18.0 {consolekit elogind +pam systemd test}
     Installed versions:  0.15.0(01:01:53 PM 08/11/2018)(consolekit pam -elogind -systemd)
     Homepage:            https://github.com/sddm/sddm
     Description:         Simple Desktop Display Manager

Found 2 matches
gentoo-main ~ # equery l sddm-kcm
 * Searching for sddm-kcm ...
[IP-] [  ] kde-plasma/sddm-kcm-5.13.4:5
gentoo-main ~ # eix sddm-kcm
[?] kde-plasma/sddm-kcm
     Available versions:  (5) 5.12.5 (~)5.12.6 (~)5.13.3
       {debug}
     Installed versions:  5.13.4(5)(06:25:09 AM 08/07/2018)(-debug)
     Homepage:            https://cgit.kde.org/sddm-kcm.git
     Description:         KDE Plasma control module for SDDM

gentoo-main ~ #

_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.3.6-gentoo-r1 USE=experimental
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3257
Location: Gainesville, Florida

PostPosted: Sat Aug 11, 2018 5:50 pm    Post subject: Reply with quote

OK, in kde plasma DE, as user i ran startlxqt and it launched:
Code:
wrc@gentoo-main ~ $ startlxqt
Your existing configuration for openbox '/home/wrc/.config/openbox/lxde-rc.xml' was used to
fill the LXQt's openbox configuration '/home/wrc/.config/openbox/lxqt-rc.xml'.
If you want to use the predefined LXQt's openbox configuration, run:
  cp '/etc/xdg/openbox/lxqt-rc.xml' '/home/wrc/.config/openbox'
Warning: Missing charsets in String to FontSet conversion
m: -c: line 0: unexpected EOF while looking for matching `''
m: -c: line 1: syntax error: unexpected end of file
2018/08/11 13:26:55 socat[9614] E connect(5, AF=1 "/tmp/kwallet5_wrc.socket", 26): Connection refused
Failure: Module initialization failed
log_kgpg: checking version of GnuPG executable "gpg"
/usr/share/system-config-printer/applet.py:44: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
  from gi.repository import Notify
system-config-printer-applet: failed to start NewPrinterNotification service
system-config-printer-applet: failed to start PrinterDriversInstaller service: org.freedesktop.DBus.Error.AccessDenied: Connection ":1.320" is not allowed to own the service "com.redhat.PrinterDriversInstaller" due to security policies in the configuration file
log_kgpg: version is "2.2.9" 131593
log_kgpg: checking version of GnuPG executable "/usr/bin/gpg2"
log_kgpg: version is "2.2.9" 131593
log_kgpg: checking version of GnuPG executable "gpg"
log_kgpg: version is "2.2.9" 131593
 (0x7fffffffda20) Warning: dbusCall: QDBusInterface is invalid "org.freedesktop.login1" "/org/freedesktop/login1" "org.freedesktop.login1.Manager" "CanReboot"
 (0x7fffffffda20) Debug: systemd: "CanReboot" = "yes"
 (0x7fffffffda20) Warning: dbusCall: QDBusInterface is invalid "org.freedesktop.login1" "/org/freedesktop/login1" "org.freedesktop.login1.Manager" "CanPowerOff"
 (0x7fffffffda20) Debug: systemd: "CanPowerOff" = "yes"

A lxqt-rc.xlm file was already there, as well as an lxde-rc.xml file. I did the suggested:
Quote:
If you want to use the predefined LXQt's openbox configuration, run:
cp '/etc/xdg/openbox/lxqt-rc.xml' '/home/wrc/.config/openbox'
anyway, and it replaced the lxqt-rc.xml file (size was slightly larger).
Unsure of what this actually means, but but apparently lxqt-0.13 is running (launched from and on top of plasma?) guess I'll remove all of lxde, and logout and see if sddm will work on lxqt, unless there's a better idea. :roll:
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.3.6-gentoo-r1 USE=experimental
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sat Aug 11, 2018 5:53 pm    Post subject: Reply with quote

wrc1944 wrote:
Downgrade sddm (currently x11-misc/sddm-0.15.)?

How about upgrade? There is nothing for you to downgrade to.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3257
Location: Gainesville, Florida

PostPosted: Sat Aug 11, 2018 6:34 pm    Post subject: Reply with quote

Yeah- I simply forgot I had masked >=x11-misc/sddm-0.16 in /etc/portage/package.mask. Just updated tp sddm-0.18.0 and all is back to normal. :oops:

Thanks astrum.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.3.6-gentoo-r1 USE=experimental
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8075
Location: ~Brussels - Belgique

PostPosted: Sun Aug 12, 2018 8:04 pm    Post subject: Reply with quote

Hmm, it pushes consolekit/policykit. Is it really required?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1828
Location: Here and Away Again

PostPosted: Mon Aug 13, 2018 3:25 am    Post subject: Reply with quote

xaviermiller wrote:
Hmm, it pushes consolekit/policykit. Is it really required?

Yes and no... depending whom you ask. :]

I don't have/need it, but upstream is not interested in making it optional.

See: https://github.com/lxqt/liblxqt/pull/143
_________________
Kind Regards,
The Noob Unlimited


You might remember me from Gentoo projects such as Forums, LXQt, Qt, and Wine.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8075
Location: ~Brussels - Belgique

PostPosted: Mon Aug 13, 2018 6:18 am    Post subject: Reply with quote

I see in the CMake file that *kit is required...

Sigh... I will take a look at an other light DM... or use your live patches?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1828
Location: Here and Away Again

PostPosted: Mon Aug 13, 2018 6:51 am    Post subject: Reply with quote

Patching it out works for me, though it's not exactly complete, and some things might behave weird-like though I haven't noticed anything yet.
_________________
Kind Regards,
The Noob Unlimited


You might remember me from Gentoo projects such as Forums, LXQt, Qt, and Wine.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8075
Location: ~Brussels - Belgique

PostPosted: Mon Aug 13, 2018 7:01 am    Post subject: Reply with quote

I will take a look at this live version. Time to jump to the qt overlay :)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum