Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Errore su aggiornamento world
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 503
Location: Italia

PostPosted: Sun Jul 29, 2018 8:55 am    Post subject: Errore su aggiornamento world Reply with quote

Ciao a tutti,
ho un problema quando aggiorno il sistema... le ho provate tutte ma senza risultato.
L'errore è questo:

Code:
!!! The ebuild selected to satisfy ">=kde-apps/lokalize-17.12.3" has unmet requirements.
- kde-apps/lokalize-17.12.3::gentoo USE="handbook -debug" ABI_X86="(64)" PYTHON_SINGLE_TARGET="-python2_7 -python3_4 -python3_5" PYTHON_TARGETS="python2_7 -python3_4 -python3_5"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python2_7 python_single_target_python3_4 python_single_target_python3_5 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python2_7 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python2_7? ( python_targets_python2_7 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )

(dependency required by "kde-apps/kdesdk-meta-17.12.3::gentoo" [installed])
(dependency required by "kde-apps/kde-apps-meta-17.12.3::gentoo[sdk]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19606
Location: here

PostPosted: Sun Jul 29, 2018 9:44 am    Post subject: Reply with quote

Puoi fare in 2 modi:
  • ho aggiungi la use flag python_targets_python3_5 al pacchetto kde-apps/lokalize
  • oppure rifai il sync e aggiorni le kde-apps alla versione 18.04.3 (appena stabilizzata)

Questo succede perche' sono appena cambiati i python_targets (hanno stabilizzato python 3.6 a discapito della versione 3.5). Comunque come detto la versione 18.04.3 di kde-apps risolve il problema perche' hanno aggiunto la use python_targets_python3_6 al pacchetto in questione
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 503
Location: Italia

PostPosted: Sun Jul 29, 2018 10:49 am    Post subject: Reply with quote

Grazie mille, ora provo
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 503
Location: Italia

PostPosted: Sun Jul 29, 2018 11:20 am    Post subject: Reply with quote

ok, ora sta emergendo 280 pacchetti... mi sembrano un pò tanti visto che l'ultimo aggiornamento risale a martedi scorso

Grazie di nuovo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum