Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to remove X11
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Tue Apr 26, 2011 6:58 pm    Post subject: How to remove X11 Reply with quote

A while back, I decided I might want to actually have web access on the server (don't ask me why I was being stupid that day) and now I'd like to get rid of all X11 type stuff on the server.

emerge --unmerge ... apparently will not do it correctly because (I think) other packages are now including it and suck it back in (correct me if I'm wrong).

So how do I get rid of it?

(How did I get to Guru setting) ;)
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 851
Location: Germany

PostPosted: Tue Apr 26, 2011 7:06 pm    Post subject: Reply with quote

Hi,

if applications suck X11 back in, you probably have X somewhere in your useflags. Go to /etc/make.conf and check if this is the case.
You could also try "eselect profile list" and check if you've chosen one of the desktop profiles.

To really get rid of all X11 stuff you could try
Code:

emerge --unmerge $(qlist -IC x11-*)


PS: You can become a Guru just by asking questions. Look at me. My questions to answers ratio is, I think, 100:1 or something.
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5647

PostPosted: Tue Apr 26, 2011 11:46 pm    Post subject: Reply with quote

Remove all GUI-related useflags and world file entries, emerge -DNatuv world, emerge --depclean.
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Wed Apr 27, 2011 1:57 am    Post subject: Reply with quote

Besides X, what else would be GUI related, normally?
Back to top
View user's profile Send private message
Chris W
l33t
l33t


Joined: 25 Jun 2002
Posts: 972
Location: Brisbane, Australia

PostPosted: Wed Apr 27, 2011 5:09 am    Post subject: Reply with quote

Anything that depends on X11.

For starters, anything in these lists:
Code:

equery hasuse X
equery hasuse gtk
equery hasuse qt4

could have been built to depend on X11. Anything depending on anything in this list:
Code:

equery list | grep x11

could be a culprit.
_________________
Cheers,
Chris W
"Common sense: The collection of prejudices acquired by age 18." -- Einstein
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Thu Apr 28, 2011 5:09 am    Post subject: Reply with quote

Is there anything I shouldn't unmerge?

csmn2 ~ # equery list | grep x11
x11-apps/mkfontdir-1.0.6
x11-apps/mkfontscale-1.0.8
x11-apps/xauth-1.0.5
x11-apps/xprop-1.2.0
x11-apps/xset-1.2.1-r1
x11-libs/gtk+-2.20.1-r1
x11-libs/libICE-1.0.7
x11-libs/libSM-1.2.0
x11-libs/libX11-1.4.1
x11-libs/libXau-1.0.6
x11-libs/libXaw-1.0.9
x11-libs/libXcomposite-0.4.3
x11-libs/libXcursor-1.1.11
x11-libs/libXdamage-1.1.3
x11-libs/libXdmcp-1.1.0
x11-libs/libXext-1.2.0
x11-libs/libXfixes-5.0
x11-libs/libXfont-1.4.3
x11-libs/libXft-2.2.0
x11-libs/libXi-1.4.1
x11-libs/libXmu-1.1.0
x11-libs/libXpm-3.5.9
x11-libs/libXrandr-1.3.1
x11-libs/libXrender-0.9.6
x11-libs/libXt-1.1.1
x11-libs/libXtst-1.2.0
x11-libs/libfontenc-1.1.0
x11-libs/libxcb-1.7
x11-libs/pango-1.28.3
x11-libs/pixman-0.20.2
x11-libs/qt-core-4.6.3-r1
x11-libs/qt-gui-4.6.3-r2
x11-libs/qt-script-4.6.3
x11-libs/xtrans-1.2.6
x11-misc/shared-mime-info-0.80
x11-misc/xbitmaps-1.1.1
x11-misc/xdg-utils-1.1.0_rc1-r1
x11-proto/compositeproto-0.4.2
x11-proto/damageproto-1.2.1
x11-proto/fixesproto-5.0
x11-proto/fontsproto-2.1.1
x11-proto/inputproto-2.0.1
x11-proto/kbproto-1.0.5
x11-proto/randrproto-1.3.2
x11-proto/recordproto-1.14.1
x11-proto/renderproto-0.11.1
x11-proto/xcb-proto-1.6-r1
x11-proto/xextproto-7.2.0
x11-proto/xf86bigfontproto-1.2.0
x11-proto/xproto-7.0.20

csmn2 ~ # equery hasuse X
[ Searching for USE flag X in all categories among: ]
* installed packages
[I--] [ ] sys-apps/groff-1.20.1-r3 (0)
[I--] [ ] app-editors/emacs-23.2-r2 (23)
[I--] [ ] app-editors/vim-7.3.50 (0) <===== my son uses VI
[I--] [ ] net-misc/openssh-5.8_p1-r1 (0) <===== probably shouldn't take this out.
[I--] [ ] dev-python/imaging-1.1.7 (0)
[I--] [ ] app-text/ghostscript-gpl-8.71-r6 (0)
[I--] [ ] media-gfx/imagemagick-6.6.5.6 (0) <==== need for Coppermine Photo Gallery
[I--] [ ] x11-libs/pango-1.28.3 (0)
[I--] [ ] app-emacs/emacs-common-gentoo-1.2-r2 (0)
[I--] [M ] dev-java/icedtea6-bin-1.9.4 (0)
[I--] [ ] media-fonts/urw-fonts-2.4.9 (0)
[I--] [ ] media-fonts/corefonts-1-r4 (0)
[I--] [ ] media-libs/freetype-2.4.4 (2)
[I--] [ ] media-libs/giflib-4.1.6-r1 (0)
[I--] [ ] media-libs/t1lib-5.1.2 (5)
[I--] [ ] sys-process/psmisc-22.12 (0)

csmn2 ~ # equery hasuse gtk
[ Searching for USE flag gtk in all categories among: ]
* installed packages
[I--] [ ] app-editors/emacs-23.2-r2 (23)
[I--] [ ] app-text/ghostscript-gpl-8.71-r6 (0)
[I--] [ ] sys-devel/gcc-4.4.4-r2 (4.4)
[I--] [ ] dev-vcs/git-1.7.3.4-r1 (0)
[I--] [ ] x11-libs/qt-gui-4.6.3-r2 (4)
[I--] [ ] net-analyzer/nmap-5.21-r1 (0)
[I--] [M ] gnome-extra/libgsf-1.14.18 (0)

csmn2 ~ # equery hasuse qt4
[ Searching for USE flag qt4 in all categories among: ]
* installed packages
[I--] [M ] app-text/poppler-0.14.5 (0)
[I--] [ ] dev-util/cmake-2.8.1-r2 (0)
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Thu Apr 28, 2011 5:15 am    Post subject: Reply with quote

I guess my next question is if I need, for example, openssh. How do I emerge it so it doesn't require 'X' use flag?

Do I re-emerge it with a "-X"?
Back to top
View user's profile Send private message
XQYZ
Apprentice
Apprentice


Joined: 19 Jul 2009
Posts: 231
Location: Europe

PostPosted: Thu Apr 28, 2011 6:24 am    Post subject: Reply with quote

CurtE wrote:
I guess my next question is if I need, for example, openssh. How do I emerge it so it doesn't require 'X' use flag?

Do I re-emerge it with a "-X"?


Put "-X -gtk -qt4" in your use flags and tell it to update your system via "emerge -uDN world". Then try an "emerge --depclean" to clean out any old dependencies and check again what's left from X.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Thu Apr 28, 2011 6:46 am    Post subject: Reply with quote

Do as suggested above, then, if there are leftovers from X post here the contents of /var/lib/portage/world
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Fri Apr 29, 2011 3:16 am    Post subject: Reply with quote

I had used this earlier and it removed all x11-??? emerge --unmerge $(qlist -IC x11-*)


This is what I'm getting now.

csmn2 ~ # emerge -uDN world
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "x11-libs/gdk-pixbuf:2[X,introspection?,jpeg?,jpeg2k?,tiff?]".
!!! One of the following packages is required to complete your request:
- x11-libs/gdk-pixbuf-2.22.1 (Change USE: +X)
(dependency required by "x11-libs/gtk+-2.22.1-r1" [ebuild])
(dependency required by "dev-java/icedtea6-bin-1.9.7[nsplugin]" [ebuild])
(dependency required by "virtual/jdk-1.6.0[-sparc-solaris,-sparc64-solaris,-x86-linux,-amd64-linux,-x86-solaris,-x64-solaris]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
Veldrin
Veteran
Veteran


Joined: 27 Jul 2004
Posts: 1945
Location: Zurich, Switzerland

PostPosted: Fri Apr 29, 2011 7:52 am    Post subject: Reply with quote

You were a bit over-zealous... :D

echo "dev-java/icedtea6-bin -nsplugin" >> /etc/portage/package.use should fix the problem.
Or you might want to disable nsplugin globally by setting -nsplugin in make.conf

What profile are you using? eselect profile list


V.
_________________
read the portage output!
If my answer is too concise, ask for an explanation.
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Fri Apr 29, 2011 1:22 pm    Post subject: Reply with quote

csmn2 ~ # eselect profile list
Available profile symlink targets:
[1] default/linux/x86/10.0
[2] default/linux/x86/10.0/desktop
[3] default/linux/x86/10.0/desktop/gnome
[4] default/linux/x86/10.0/desktop/kde
[5] default/linux/x86/10.0/developer
[6] default/linux/x86/10.0/server *
[7] hardened/linux/x86
[8] selinux/2007.0/x86
[9] selinux/2007.0/x86/hardened
[10] selinux/v2refpolicy/x86
[11] selinux/v2refpolicy/x86/desktop
[12] selinux/v2refpolicy/x86/developer
[13] selinux/v2refpolicy/x86/hardened
[14] selinux/v2refpolicy/x86/server

csmn2 ~ # echo "dev-java/icetea6-bin -nsplugin" >> /etc/portage/package.use
-bash: /etc/portage/package.use: Is a directory
Back to top
View user's profile Send private message
aidanjt
Veteran
Veteran


Joined: 20 Feb 2005
Posts: 1104
Location: Rep. of Ireland

PostPosted: Fri Apr 29, 2011 1:36 pm    Post subject: Reply with quote

Just `echo "dev-java/icetea6-bin -nsplugin" >> /etc/portage/package.use/dev-java`, then. package.use can be either a file or a directory of files.
_________________
juniper wrote:
you experience political reality dilation when travelling at american political speeds. it's in einstein's formulas. it's not their fault.
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Fri Apr 29, 2011 2:05 pm    Post subject: Reply with quote

Okay, what didn't I do?

csmn2 package.use # echo "dev-java/icetea6-bin -nsplugin" >> /etc/portage/package.use/dev-java
csmn2 package.use # emerge -uDN world
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "x11-libs/gdk-pixbuf:2[X,introspection?,jpeg?,jpeg2k?,tiff?]".
!!! One of the following packages is required to complete your request:
- x11-libs/gdk-pixbuf-2.22.1 (Change USE: +X)
(dependency required by "x11-libs/gtk+-2.22.1-r1" [ebuild])
(dependency required by "dev-java/icedtea6-bin-1.9.7[nsplugin]" [ebuild])
(dependency required by "virtual/jdk-1.6.0[-sparc-solaris,-sparc64-solaris,-x86-linux,-amd64-linux,-x86-solaris,-x64-solaris]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Add-on:
I changed make.conf to -nsplugin, now it's going.
Back to top
View user's profile Send private message
CurtE
Guru
Guru


Joined: 17 Apr 2004
Posts: 364
Location: Minneapolis, MN

PostPosted: Sat Apr 30, 2011 2:24 am    Post subject: Reply with quote

I unemerged:
X11-libs/cairo-1.10.2-r1
X11-libs/pango-1.28.3-r1
X11-libs/gdk-pixbuf-2.22.1

emerge -uDN world
again and this is what I have. How dod I get it to not bring in the X!! programs.

csmn2 package.use # equery hasuse X
[ Searching for USE flag X in all categories among: ]
* installed packages
[I--] [ ] sys-apps/groff-1.20.1-r3 (0)
[I--] [ ] app-editors/emacs-23.3 (23)
[I--] [ ] app-editors/vim-7.3.50 (0)
[I--] [ ] net-misc/openssh-5.8_p1-r1 (0)
[I--] [ ] dev-python/imaging-1.1.7 (0)
[I--] [ ] app-text/ghostscript-gpl-8.71-r6 (0)
[I--] [ ] media-gfx/imagemagick-6.6.5.6 (0)
[I--] [ ] x11-libs/cairo-1.10.2-r1 (0)
[I--] [ ] x11-libs/pango-1.28.3-r1 (0)
[I--] [ ] x11-libs/gdk-pixbuf-2.22.1 (2)
[I--] [ ] app-emacs/emacs-common-gentoo-1.2-r2 (0)
[I--] [ ] net-analyzer/net-snmp-5.4.2.1-r4 (0)
[I--] [ ] dev-java/icedtea6-bin-1.9.7 (0)
[I--] [ ] media-fonts/urw-fonts-2.4.9 (0)
[I--] [ ] media-fonts/corefonts-1-r4 (0)
[I--] [ ] media-libs/freetype-2.4.4 (2)
[I--] [ ] media-libs/giflib-4.1.6-r1 (0)
[I--] [ ] media-libs/t1lib-5.1.2 (5)
[I--] [ ] sys-process/psmisc-22.12 (0)

csmn2 package.use # equery hasuse gtk
[ Searching for USE flag gtk in all categories among: ]
* installed packages
[I--] [ ] app-editors/emacs-23.3 (23)
[I--] [ ] app-text/ghostscript-gpl-8.71-r6 (0)
[I--] [ ] sys-devel/gcc-4.4.5 (4.4)
[I--] [ ] dev-vcs/git-1.7.3.4-r1 (0)
[I--] [ ] gnome-base/librsvg-2.32.1 (2)
[I--] [ ] net-analyzer/nmap-5.21-r1 (0)
[I--] [M ] gnome-extra/libgsf-1.14.18 (0)

csmn2 package.use # equery hasuse qt4
[ Searching for USE flag qt4 in all categories among: ]
* installed packages
[I--] [M ] app-text/poppler-0.14.5 (0)
[I--] [ ] x11-libs/cairo-1.10.2-r1 (0)
[I--] [ ] dev-util/cmake-2.8.1-r2 (0)
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 851
Location: Germany

PostPosted: Sat Apr 30, 2011 6:40 am    Post subject: Reply with quote

Try using emerge --depclean -pv on the offending packages. This should show you what pulls in these.
For example, I just ran emerge --depclean -pv poppler and got:

Calculating dependencies... done!
app-text/poppler-0.14.5-r1 pulled in by:
app-office/libreoffice-3.3.2
app-text/evince-2.32.0-r2
media-gfx/gimp-2.6.11-r1
media-gfx/inkscape-0.48.0
net-print/cups-1.3.11-r4

So, if I were to remove poppler I would get it again via emerge -uDN as long as I have any of the listed packages installed. So you should get rid of anything that depends on any of the X11 packages or their dependencies. Either by depcleaning them or by adjusting their useflags to, for example, not depend on poppler/ cairo etc.
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
ccgllc
n00b
n00b


Joined: 21 Jul 2018
Posts: 18
Location: NE Missouri

PostPosted: Sun Jul 22, 2018 5:22 am    Post subject: 7 year later... same problem Reply with quote

Made the mistake of emerging xorg and cinnamon. Once I changed plans and realized I didn't need X, I tried to back out:

1) I removed xorg and cinnamon and removed X and Gnome from my make.conf USE=
2) I changed my profile back to a base, non-desktop selection
3) I emerged --update --newuse --deep @world
4) I emerged --depclean and saw a lot of packages go away
5) I emerged -pe @world to see what was left and discovered a lot of media and X11 stuff remaining
6) I spent hours doing equery d <package> and drilling down until I could emerge -C <package dependencies> <package>

Output from "emerge -pet @world", "cat /etc/portage/make.conf", and "eselect profile list" below:

Code:
rackserv /usr/portage/profiles # emerge -pet @world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R   ~] app-emulation/snapd-2.15.2
[ebuild   R    ] sys-apps/iproute2-4.14.1-r2
[ebuild   R    ] virtual/libc-1
[nomerge       ] sys-apps/portage-2.3.40-r1
[ebuild   R    ]  app-portage/gemato-13.0-r1
[ebuild   R    ]   app-crypt/gnupg-2.2.8
[ebuild  N     ]    app-crypt/pinentry-1.0.0-r2  USE="gnome-keyring ncurses -caps -emacs -gtk -qt5 -static"
[nomerge       ] app-crypt/pinentry-1.0.0-r2  USE="gnome-keyring ncurses -caps -emacs -gtk -qt5 -static"
[nomerge       ]  app-crypt/libsecret-0.18.6-r1  USE="crypt -introspection {-test} -vala" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]   gnome-base/gnome-keyring-3.20.1  USE="caps filecaps pam ssh-agent (-selinux) {-test}"
[ebuild  N     ]    app-crypt/gcr-3.20.0  USE="gtk -debug -introspection {-test} -vala"
[nomerge       ] gnome-base/gnome-keyring-3.20.1  USE="caps filecaps pam ssh-agent (-selinux) {-test}"
[nomerge       ]  app-crypt/pinentry-1.0.0-r2  USE="gnome-keyring ncurses -caps -emacs -gtk -qt5 -static"
[nomerge       ]   app-crypt/gcr-3.20.0  USE="gtk -debug -introspection {-test} -vala"
[nomerge       ]    x11-libs/gtk+-3.22.30  USE="X (-aqua) -broadway -cloudprint -colord -cups -examples -introspection {-test} -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]     x11-themes/adwaita-icon-theme-3.24.0  USE="-branding"
[ebuild  N     ]      x11-libs/gtk+-3.22.30  USE="X (-aqua) -broadway -cloudprint -colord -cups -examples -introspection {-test} -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[nomerge       ] app-emulation/snapd-2.15.2
[ebuild   R   ~]  sys-apps/snap-confine-1.0.43
[nomerge       ] x11-libs/gtk+-3.22.30  USE="X (-aqua) -broadway -cloudprint -colord -cups -examples -introspection {-test} -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  media-libs/libepoxy-1.5.1  USE="X {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]   media-libs/mesa-17.3.9  USE="classic dri3 egl gallium gbm llvm nptl -bindist -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -unwind -vaapi -valgrind -vdpau -vulkan -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="intel nouveau radeon radeonsi (-freedreno) -i915 -i965 (-imx) -r100 -r200 -r300 -r600 (-vc4) -virgl (-vivante) -vmware"
[ebuild   R    ]    sys-devel/llvm-5.0.2
[nomerge       ] virtual/libc-1
[ebuild   R    ]  sys-libs/glibc-2.26-r7
[ebuild   R    ]   sys-devel/gcc-7.3.0-r3
[ebuild  N     ] app-crypt/libsecret-0.18.6-r1  USE="crypt -introspection {-test} -vala" ABI_X86="(64) -32 (-x32)"
[ebuild     U ~] sci-misc/boinc-7.9.3 [7.6.33-r1] CURL_SSL="-gnutls%"
[nomerge       ] x11-libs/gtk+-3.22.30  USE="X (-aqua) -broadway -cloudprint -colord -cups -examples -introspection {-test} -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  app-accessibility/at-spi2-atk-2.24.1  USE="{-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]   app-accessibility/at-spi2-core-2.24.1  USE="-X -introspection" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  dev-util/gtk-update-icon-cache-3.22.19
[ebuild  N     ]  gnome-base/librsvg-2.40.18  USE="-introspection -tools -vala" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]   x11-libs/gdk-pixbuf-2.36.12  USE="-X -debug -introspection -jpeg -jpeg2k {-test} -tiff" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ]    sys-devel/gettext-0.19.8.1
[ebuild  N     ]     dev-vcs/git-2.16.4  USE="blksha1 curl gpg iconv pcre pcre-jit perl python subversion threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental -nls (-ppcsha1) {-test} -tk -xinetd" PYTHON_TARGETS="python2_7"
[nomerge       ] sys-apps/snap-confine-1.0.43
[nomerge       ]  virtual/libudev-232
[ebuild   R    ]   sys-fs/eudev-3.2.5
[ebuild   R    ]    dev-util/intltool-0.51.0-r2
[ebuild   R    ] app-benchmarks/sysbench-1.0.10
[ebuild   R    ] net-dns/bind-9.11.2_p1
[ebuild   R    ] dev-vcs/mercurial-4.6.2
[ebuild   R    ] dev-lang/php-7.1.18
[ebuild   R    ] net-misc/ntp-4.2.8_p11
[ebuild   R    ] app-forensics/rkhunter-1.4.6
[ebuild   R    ] dev-lang/python-3.4.8
[ebuild   R    ] app-admin/sudo-1.8.22-r2
[ebuild   R    ] net-dns/bind-tools-9.11.2_p1
[ebuild   R    ] sys-boot/lilo-24.0-r1
[ebuild   R    ] sys-apps/lm_sensors-3.4.0_p20170901
[ebuild   R    ] net-libs/nodejs-8.11.1
[ebuild   R    ] sys-process/htop-2.0.2
[ebuild   R    ] net-firewall/psad-2.2.5
[ebuild   R    ] sys-process/audit-2.7.1
[ebuild   R    ] sys-fs/btrfs-progs-4.10.2
[ebuild   R    ] sys-fs/zfs-0.7.9
[ebuild   R    ] sys-apps/logwatch-7.4.3
[ebuild   R    ] net-analyzer/bmon-4.0
[ebuild   R    ] sys-libs/gpm-1.20.7-r2
[ebuild   R    ] sys-apps/smartmontools-6.6
[ebuild   R    ] net-analyzer/fail2ban-0.10.3.1
[ebuild   R    ] net-libs/libmicrohttpd-0.9.55
[ebuild   R    ] net-ftp/ncftp-3.2.6
[nomerge       ] app-emulation/snapd-2.15.2
[nomerge       ]  dev-vcs/git-2.16.4  USE="blksha1 curl gpg iconv pcre pcre-jit perl python subversion threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental -nls (-ppcsha1) {-test} -tk -xinetd" PYTHON_TARGETS="python2_7"
[nomerge       ]   dev-perl/Error-0.170.240
[nomerge       ]    dev-perl/Module-Build-0.422.400
[nomerge       ]     virtual/perl-CPAN-Meta-2.150.5-r1
[ebuild   R    ]      virtual/perl-JSON-PP-2.273.0.100_rc-r6
[nomerge       ] dev-vcs/git-2.16.4  USE="blksha1 curl gpg iconv pcre pcre-jit perl python subversion threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental -nls (-ppcsha1) {-test} -tk -xinetd" PYTHON_TARGETS="python2_7"
[nomerge       ]  dev-perl/libwww-perl-6.150.0
[nomerge       ]   dev-perl/LWP-Protocol-https-6.70.0
[nomerge       ]    dev-perl/Net-HTTP-6.90.0
[nomerge       ]     virtual/perl-IO-Compress-2.69.1_rc-r4
[ebuild   R    ]      virtual/perl-Compress-Raw-Bzip2-2.69.0-r1
[nomerge       ] app-emulation/snapd-2.15.2
[nomerge       ]  dev-vcs/bzr-2.7.0
[ebuild   R    ]   dev-python/paramiko-2.4.1
[ebuild   R    ] dev-perl/LWP-Protocol-https-6.70.0
[nomerge       ] app-benchmarks/sysbench-1.0.10
[nomerge       ]  app-editors/vim-core-8.0.1298
[ebuild   R    ]   app-vim/gentoo-syntax-20170225
[ebuild   R    ] sys-process/cronie-1.5.1-r1
[ebuild   R    ] mail-client/mailx-8.1.2.20160123
[ebuild   R    ] sys-kernel/gentoo-sources-4.14.52
[ebuild   R    ] app-admin/syslog-ng-3.13.2
[ebuild   R    ] perl-core/File-Path-2.130.0
[ebuild   R    ] perl-core/File-Temp-0.230.400-r1
[ebuild   R    ] virtual/ssh-0
[ebuild   R    ] virtual/service-manager-0
[nomerge       ] virtual/man-0-r1
[ebuild   R    ]  sys-apps/man-db-2.7.6.1-r2
[nomerge       ] virtual/shadow-0
[ebuild   R    ]  sys-apps/shadow-4.6
[ebuild   R    ] dev-python/certifi-2018.4.16
[ebuild   R    ] mail-mta/ssmtp-2.64-r3
[nomerge       ] dev-perl/LWP-Protocol-https-6.70.0
[ebuild   R    ]  dev-perl/libwww-perl-6.150.0
[ebuild   R    ] app-editors/vim-8.0.1298
[ebuild   R    ]  app-editors/vim-core-8.0.1298
[nomerge       ] virtual/ssh-0
[ebuild   R    ]  net-misc/openssh-7.7_p1-r6
[ebuild   R    ] sys-apps/openrc-0.34.11
[ebuild   R    ]  sys-auth/pambase-20150213-r1
[ebuild   R    ]   sys-libs/pam-1.2.1-r2
[nomerge       ] x11-themes/adwaita-icon-theme-3.24.0  USE="-branding"
[nomerge       ]  gnome-base/librsvg-2.40.18  USE="-introspection -tools -vala" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]   x11-libs/pango-1.40.14-r1  USE="-X -introspection {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]    media-libs/harfbuzz-1.8.1  USE="cairo glib graphite icu truetype -debug -fontconfig -introspection -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]     x11-libs/cairo-1.14.12  USE="X glib svg (-aqua) -debug (-gles2) -opengl -static-libs -valgrind -xcb" ABI_X86="(64) -32 (-x32)"
[nomerge       ] x11-libs/gtk+-3.22.30  USE="X (-aqua) -broadway -cloudprint -colord -cups -examples -introspection {-test} -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[nomerge       ]  media-libs/fontconfig-2.12.6  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]   app-eselect/eselect-fontconfig-1.1
[ebuild  N     ]    media-libs/fontconfig-2.12.6  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ] media-libs/mesa-17.3.9  USE="classic dri3 egl gallium gbm llvm nptl -bindist -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -unwind -vaapi -valgrind -vdpau -vulkan -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="intel nouveau radeon radeonsi (-freedreno) -i915 -i965 (-imx) -r100 -r200 -r300 -r600 (-vc4) -virgl (-vivante) -vmware"
[ebuild  N     ]  x11-libs/libXxf86vm-1.1.4-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ] app-accessibility/at-spi2-core-2.24.1  USE="-X -introspection" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  x11-libs/libXtst-1.2.3-r1  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ] x11-libs/gtk+-3.22.30  USE="X (-aqua) -broadway -cloudprint -colord -cups -examples -introspection {-test} -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  x11-libs/libXcomposite-0.4.4-r2  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  x11-libs/libXrandr-1.5.1-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  x11-libs/libXcursor-1.1.15  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  x11-libs/libXdamage-1.1.4-r2  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ] x11-libs/libXcursor-1.1.15  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  x11-libs/libXrender-0.9.10-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ] x11-libs/gtk+-3.22.30  USE="X (-aqua) -broadway -cloudprint -colord -cups -examples -introspection {-test} -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  x11-libs/libXi-1.7.9-r1  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]   x11-libs/libXfixes-5.0.3-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]   x11-libs/libXext-1.3.3-r1  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild  N     ]    x11-libs/libX11-1.6.5-r1  USE="ipv6 -doc -static-libs {-test}" ABI_X86="32 (64) (-x32)"
[ebuild  N     ]     x11-libs/libxcb-1.13  USE="-doc (-selinux) -static-libs {-test} -xkb" ABI_X86="32 (64) (-x32)"
[ebuild  N     ]      x11-base/xcb-proto-1.13  ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_5 python3_6 -python3_4"
[ebuild   R    ] dev-vcs/subversion-1.9.7-r1
[ebuild   R    ]  net-libs/serf-1.3.8
[ebuild   R    ]  dev-db/sqlite-3.23.1
[nomerge       ] net-analyzer/bmon-4.0
[ebuild   R    ]  dev-libs/confuse-3.0
[nomerge       ] dev-python/paramiko-2.4.1
[ebuild   R    ]  dev-python/pynacl-1.1.2
[ebuild   R    ]   dev-libs/libsodium-1.0.11
[nomerge       ] sys-apps/logwatch-7.4.3
[ebuild   R    ]  dev-perl/Tie-IxHash-1.230.0
[ebuild   R    ]  dev-perl/Date-Manip-6.600.0
[ebuild   R    ]  dev-perl/Sys-CPU-0.610.0
[ebuild   R    ]  dev-perl/Sys-MemInfo-0.980.0
[nomerge       ] sys-fs/btrfs-progs-4.10.2
[ebuild   R    ]  app-text/asciidoc-8.6.10
[nomerge       ] sci-misc/boinc-7.9.3 [7.6.33-r1] CURL_SSL="-gnutls%"
[ebuild   R    ]  app-text/docbook2X-0.8.8-r4
[ebuild   R    ]   dev-perl/XML-LibXML-2.13.200
[nomerge       ] dev-lang/perl-5.24.3-r1
[nomerge       ]  app-admin/perl-cleaner-2.25
[ebuild   R    ]   app-portage/portage-utils-0.64
[ebuild   R    ]    dev-libs/iniparser-3.1-r1
[nomerge       ] mail-client/mailx-8.1.2.20160123
[ebuild   R    ]  net-libs/liblockfile-1.09
[nomerge       ] net-firewall/psad-2.2.5
[ebuild   R    ]  dev-perl/NetAddr-IP-4.78.0
[ebuild   R    ]   dev-perl/Socket6-0.270.0
[ebuild   R    ]  dev-perl/Unix-Syslog-1.100.0-r1
[nomerge       ] net-libs/nodejs-8.11.1
[ebuild   R    ]  dev-libs/libuv-1.20.0
[ebuild   R    ] sys-fs/lvm2-2.02.145-r2
[ebuild   R    ]  sys-block/thin-provisioning-tools-0.7.0
[nomerge       ] media-libs/harfbuzz-1.8.1  USE="cairo glib graphite icu truetype -debug -fontconfig -introspection -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  media-gfx/graphite2-1.3.10  USE="-perl {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ]   dev-util/cmake-3.9.6
[ebuild   R    ]    app-arch/libarchive-3.3.1
[nomerge       ] net-misc/ntp-4.2.8_p11
[ebuild   R    ]  dev-libs/libevent-2.1.8
[nomerge       ] x11-libs/libXcomposite-0.4.4-r2  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ]  x11-libs/libX11-1.6.5-r1  USE="ipv6 -doc -static-libs {-test}" ABI_X86="32 (64) (-x32)"
[ebuild  N     ]   media-fonts/font-util-1.3.1
[ebuild  N     ]   x11-misc/util-macros-1.19.2
[nomerge       ] media-libs/mesa-17.3.9  USE="classic dri3 egl gallium gbm llvm nptl -bindist -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -unwind -vaapi -valgrind -vdpau -vulkan -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="intel nouveau radeon radeonsi (-freedreno) -i915 -i965 (-imx) -r100 -r200 -r300 -r600 (-vc4) -virgl (-vivante) -vmware"
[ebuild  N     ]  x11-libs/libdrm-2.4.91  USE="-libkms -valgrind" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="amdgpu intel nouveau radeon (-exynos) (-freedreno) (-omap) (-tegra) (-vc4) (-vivante) -vmware"
[ebuild  N     ]   x11-libs/libpciaccess-0.14  USE="zlib -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  x11-libs/libxshmfence-1.3-r1  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ] gnome-base/gnome-keyring-3.20.1  USE="caps filecaps pam ssh-agent (-selinux) {-test}"
[nomerge       ]  dev-util/intltool-0.51.0-r2
[ebuild   R    ]   dev-perl/XML-Parser-2.440.0
[nomerge       ] dev-perl/libwww-perl-6.150.0
[ebuild   R    ]  dev-perl/HTML-Parser-3.720.0
[ebuild   R    ]   dev-perl/HTML-Tagset-3.200.0-r1
[ebuild   R    ]  dev-perl/HTTP-Daemon-6.10.0-r2
[ebuild   R    ]  dev-perl/HTTP-Cookies-6.40.0
[ebuild   R    ]  dev-perl/HTTP-Negotiate-6.10.0-r1
[ebuild   R    ]   dev-perl/HTTP-Message-6.130.0
[ebuild   R    ]    dev-perl/IO-HTML-1.1.0
[ebuild   R    ]  dev-perl/File-Listing-6.40.0-r1
[ebuild   R    ]  dev-perl/WWW-RobotRules-6.20.0
[nomerge       ] dev-vcs/git-2.16.4  USE="blksha1 curl gpg iconv pcre pcre-jit perl python subversion threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental -nls (-ppcsha1) {-test} -tk -xinetd" PYTHON_TARGETS="python2_7"
[ebuild   R    ]  dev-perl/Authen-SASL-2.160.0-r1
[ebuild   R    ]   dev-perl/Digest-HMAC-1.30.0-r1
[ebuild   R    ]  dev-perl/Net-SMTP-SSL-1.30.0
[nomerge       ] dev-perl/libwww-perl-6.150.0
[ebuild   R    ]  dev-perl/Net-HTTP-6.90.0
[ebuild   R    ]   dev-perl/IO-Socket-SSL-2.48.0
[ebuild   R    ]    dev-perl/Net-SSLeay-1.820.0
[ebuild   R    ] dev-perl/Error-0.170.240
[nomerge       ] dev-vcs/git-2.16.4  USE="blksha1 curl gpg iconv pcre pcre-jit perl python subversion threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental -nls (-ppcsha1) {-test} -tk -xinetd" PYTHON_TARGETS="python2_7"
[ebuild   R    ]  dev-perl/TermReadKey-2.330.0
[nomerge       ] dev-lang/php-7.1.18
[ebuild   R    ]  dev-libs/libmcrypt-2.5.8-r4
[nomerge       ] gnome-base/librsvg-2.40.18  USE="-introspection -tools -vala" ABI_X86="(64) -32 (-x32)"
[nomerge       ]  x11-libs/cairo-1.14.12  USE="X glib svg (-aqua) -debug (-gles2) -opengl -static-libs -valgrind -xcb" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ]   sys-libs/binutils-libs-2.30-r2
[ebuild   R    ] sys-fs/e2fsprogs-1.43.9
[ebuild   R    ]  sys-apps/texinfo-6.3
[ebuild   R    ]   dev-perl/Unicode-EastAsianWidth-1.330.0-r1
[ebuild   R    ]   dev-perl/libintl-perl-1.280.0
[ebuild   R    ]   dev-perl/Text-Unidecode-1.270.0
[ebuild   R    ] sys-fs/zfs-kmod-0.7.9
[ebuild   R    ] sys-process/lsof-4.89
[ebuild   R    ] sys-kernel/spl-0.7.9
[nomerge       ] net-libs/serf-1.3.8
[ebuild   R    ]  dev-libs/apr-util-1.5.4
[ebuild   R    ] sys-apps/dbus-1.10.24
[ebuild   R    ]  app-text/xmlto-0.0.26-r1
[nomerge       ] app-text/docbook2X-0.8.8-r4
[ebuild   R    ]  dev-perl/XML-SAX-0.990.0-r1
[ebuild   R    ]   dev-perl/XML-SAX-Base-1.90.0
[nomerge       ] net-firewall/psad-2.2.5
[ebuild   R    ]  dev-perl/Date-Calc-6.400.0
[ebuild   R    ]   dev-perl/Bit-Vector-7.400.0
[ebuild   R    ]    dev-perl/Carp-Clan-6.60.0
[ebuild   R    ]  net-misc/whois-5.2.20
[nomerge       ] dev-perl/libwww-perl-6.150.0
[ebuild   R    ]  dev-perl/Encode-Locale-1.50.0
[nomerge       ] dev-perl/Tie-IxHash-1.230.0
[ebuild   R    ]  dev-perl/Module-Build-0.422.400
[nomerge       ] sys-fs/zfs-0.7.9
[ebuild   R    ]  net-libs/libtirpc-1.0.2-r1
[nomerge       ] net-libs/serf-1.3.8
[ebuild   R    ]  dev-libs/apr-1.5.2
[nomerge       ] app-text/docbook2X-0.8.8-r4
[ebuild   R    ]  dev-perl/XML-NamespaceSupport-1.120.0
[nomerge       ] dev-perl/HTTP-Daemon-6.10.0-r2
[ebuild   R    ]  dev-perl/LWP-MediaTypes-6.20.0-r1
[nomerge       ] x11-libs/libdrm-2.4.91  USE="-libkms -valgrind" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="amdgpu intel nouveau radeon (-exynos) (-freedreno) (-omap) (-tegra) (-vc4) (-vivante) -vmware"
[ebuild   R    ]  dev-util/ninja-1.8.2
[nomerge       ] app-crypt/gcr-3.20.0  USE="gtk -debug -introspection {-test} -vala"
[ebuild   R    ]  app-crypt/p11-kit-0.23.9
[ebuild   R    ]   app-misc/ca-certificates-20170717.3.36.1
[ebuild   R    ]    dev-lang/python-3.6.5
[ebuild   R    ]  dev-libs/libxslt-1.1.32
[nomerge       ] sys-apps/man-db-2.7.6.1-r2
[ebuild   R    ]  sys-apps/groff-1.22.2
[nomerge       ] sys-apps/portage-2.3.40-r1
[nomerge       ]  app-crypt/gnupg-2.2.8
[ebuild   R    ]   net-libs/gnutls-3.5.18
[ebuild   R    ]    dev-libs/nettle-3.4
[nomerge       ] x11-libs/gtk+-3.22.30  USE="X (-aqua) -broadway -cloudprint -colord -cups -examples -introspection {-test} -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[nomerge       ]  x11-libs/cairo-1.14.12  USE="X glib svg (-aqua) -debug (-gles2) -opengl -static-libs -valgrind -xcb" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]   x11-libs/pixman-0.34.0  USE="(-altivec) (-iwmmxt) (-loongson2f) (-neon) -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmxext sse2 ssse3"
[nomerge       ] app-accessibility/at-spi2-core-2.24.1  USE="-X -introspection" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  x11-libs/libSM-1.2.2-r2  USE="ipv6 uuid -doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]   x11-libs/libICE-1.0.9-r2  USE="ipv6 -doc -static-libs" ABI_X86="(64) -32 (-x32)"
[nomerge       ] media-libs/harfbuzz-1.8.1  USE="cairo glib graphite icu truetype -debug -fontconfig -introspection -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ]  dev-libs/icu-60.2
[nomerge       ] media-libs/mesa-17.3.9  USE="classic dri3 egl gallium gbm llvm nptl -bindist -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -unwind -vaapi -valgrind -vdpau -vulkan -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="intel nouveau radeon radeonsi (-freedreno) -i915 -i965 (-imx) -r100 -r200 -r300 -r600 (-vc4) -virgl (-vivante) -vmware"
[nomerge       ]  x11-libs/libxcb-1.13  USE="-doc (-selinux) -static-libs {-test} -xkb" ABI_X86="32 (64) (-x32)"
[ebuild  N     ]   x11-libs/libXdmcp-1.1.2-r2  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)"
[ebuild   R    ]   dev-libs/libpthread-stubs-0.4
[ebuild  N     ]   x11-libs/libXau-1.0.8-r1  USE="-static-libs" ABI_X86="32 (64) (-x32)"
[nomerge       ] gnome-base/gnome-keyring-3.20.1  USE="caps filecaps pam ssh-agent (-selinux) {-test}"
[ebuild   R    ]  sys-libs/libcap-ng-0.7.8
[ebuild   R    ] sys-process/psmisc-23.1-r1
[nomerge       ] x11-libs/libSM-1.2.2-r2  USE="ipv6 uuid -doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  x11-libs/xtrans-1.3.5  USE="-doc"
[nomerge       ] gnome-base/gnome-keyring-3.20.1  USE="caps filecaps pam ssh-agent (-selinux) {-test}"
[nomerge       ]  app-crypt/gnupg-2.2.8
[ebuild   R    ]   net-misc/curl-7.61.0
[ebuild   R    ]   dev-libs/libgcrypt-1.8.3
[ebuild   R    ]    sys-devel/libtool-2.4.6-r3
[ebuild   R    ]     sys-devel/automake-1.15.1-r2
[nomerge       ] net-libs/libmicrohttpd-0.9.55
[nomerge       ]  net-libs/gnutls-3.5.18
[ebuild   R    ]   net-dns/libidn2-2.0.4
[ebuild   R    ]   dev-libs/libtasn1-4.13
[ebuild   R    ]    sys-apps/help2man-1.47.4
[nomerge       ] dev-perl/HTTP-Daemon-6.10.0-r2
[nomerge       ]  dev-perl/HTTP-Message-6.130.0
[ebuild   R    ]   dev-perl/URI-1.710.0
[ebuild   R    ]   dev-perl/HTTP-Date-6.20.0-r1
[nomerge       ] gnome-base/librsvg-2.40.18  USE="-introspection -tools -vala" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  dev-libs/libcroco-0.6.12-r1  USE="{-test}" ABI_X86="(64) -32 (-x32)"
[nomerge       ] app-accessibility/at-spi2-atk-2.24.1  USE="{-test}" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ]  dev-libs/atk-2.24.0  USE="-introspection*"
[ebuild   R    ]   dev-util/gtk-doc-am-1.25-r1
[nomerge       ] app-editors/vim-8.0.1298
[ebuild   R    ]  sys-devel/autoconf-2.69-r4
[ebuild   R    ]   dev-lang/perl-5.24.3-r1
[ebuild   R    ]    sys-libs/db-5.3.28-r2
[ebuild   R    ] app-portage/gentoolkit-0.4.2-r1
[ebuild   R    ] virtual/package-manager-1
[ebuild   R    ]  sys-apps/portage-2.3.40-r1
[ebuild   R    ] dev-python/pip-9.0.1-r1
[ebuild   R    ] sys-process/iotop-0.6
[ebuild   R    ] dev-python/json-rpc-1.10.1
[ebuild   R    ] dev-python/werkzeug-0.12.2
[ebuild   R    ] net-analyzer/speedtest-cli-1.0.7
[nomerge       ] dev-python/werkzeug-0.12.2
[ebuild   R    ]  dev-python/simplejson-3.13.2
[nomerge       ] dev-python/paramiko-2.4.1
[ebuild   R    ]  dev-python/bcrypt-3.1.3
[nomerge       ] app-editors/vim-8.0.1298
[ebuild   R    ]  dev-util/ctags-20161028
[ebuild   R    ] dev-python/cryptography-2.1.4-r2
[ebuild   R    ]  dev-python/cffi-1.11.4
[ebuild   R    ]   dev-python/pycparser-2.14
[ebuild   R    ]    dev-python/ply-3.9
[ebuild   R    ]  dev-python/asn1crypto-0.22.0
[ebuild   R    ] dev-python/pyasn1-0.2.3
[nomerge       ] sys-apps/snap-confine-1.0.43
[ebuild   R    ]  dev-python/docutils-0.13.1
[ebuild   R    ]   dev-python/pygments-2.2.0
[ebuild   R    ] dev-python/idna-2.5
[nomerge       ] x11-libs/libdrm-2.4.91  USE="-libkms -valgrind" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="amdgpu intel nouveau radeon (-exynos) (-freedreno) (-omap) (-tegra) (-vc4) (-vivante) -vmware"
[ebuild   R    ]  dev-util/meson-0.46.1
[nomerge       ] x11-libs/gtk+-3.22.30  USE="X (-aqua) -broadway -cloudprint -colord -cups -examples -introspection {-test} -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ]  dev-util/gdbus-codegen-2.52.3
[ebuild   R    ] dev-python/six-1.11.0  PYTHON_TARGETS="(-python3_7)"
[nomerge       ] sys-apps/portage-2.3.40-r1
[ebuild   R    ]  dev-python/pyxattr-0.6.0-r1  PYTHON_TARGETS="(-python3_7)"
[ebuild   R    ]  dev-python/pyblake2-1.1.2  PYTHON_TARGETS="(-python3_7)"
[ebuild   R    ]   dev-lang/python-3.5.5
[ebuild   R    ] dev-vcs/bzr-2.7.0
[nomerge       ] dev-python/cryptography-2.1.4-r2
[nomerge       ]  virtual/python-ipaddress-1.0-r1  PYTHON_TARGETS="(-python3_7)"
[ebuild   R    ]   dev-python/ipaddress-1.0.19
[nomerge       ] net-libs/serf-1.3.8
[ebuild   R    ]  dev-util/scons-2.5.1
[nomerge       ] dev-python/cryptography-2.1.4-r2
[ebuild   R    ]  dev-python/enum34-1.1.6
[nomerge       ] app-portage/gemato-13.0-r1
[ebuild   R    ]  dev-python/bz2file-0.98
[ebuild   R    ]   dev-lang/python-2.7.14-r1
[ebuild   R    ]    sys-libs/gdbm-1.13-r2
[ebuild   R    ] sys-apps/busybox-1.28.0
[nomerge       ] sys-apps/openrc-0.34.11
[nomerge       ]  virtual/pam-0-r1
[nomerge       ]   sys-libs/pam-1.2.1-r2
[ebuild   R    ]    sys-libs/libcap-2.25
[nomerge       ] sys-apps/portage-2.3.40-r1
[ebuild   R    ]  sys-apps/sandbox-2.13
[ebuild   R    ]   app-misc/pax-utils-1.2.3
[ebuild   R    ]    sys-libs/libseccomp-2.3.3
[nomerge       ] x11-libs/libICE-1.0.9-r2  USE="ipv6 -doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ]  dev-libs/libbsd-0.8.6
[ebuild   R    ] net-firewall/iptables-1.6.1-r3
[ebuild   R    ]  sys-kernel/linux-headers-4.13
[nomerge       ] app-crypt/pinentry-1.0.0-r2  USE="gnome-keyring ncurses -caps -emacs -gtk -qt5 -static"
[nomerge       ]  app-eselect/eselect-pinentry-0.7
[ebuild   R    ]   app-eselect/eselect-lib-bin-symlink-0.1.1
[ebuild   R    ] sys-fs/squashfs-tools-4.3-r2
[ebuild   R    ] app-arch/tar-1.30
[ebuild   R    ] net-misc/rsync-3.1.3
[ebuild   R    ] sys-devel/patch-2.7.6-r1
[nomerge       ] sys-apps/portage-2.3.40-r1
[ebuild   R    ]  app-admin/eselect-1.4.12
[ebuild   R    ]   sys-apps/coreutils-8.29-r1
[ebuild   R    ]    sys-apps/acl-2.2.52-r1
[ebuild   R    ]     sys-apps/attr-2.4.47-r2
[nomerge       ] app-text/asciidoc-8.6.10
[ebuild   R    ]  app-text/docbook-xml-dtd-4.5-r1
[ebuild   R    ]   dev-libs/libxml2-2.9.8
[ebuild   R    ] sys-fs/mdadm-3.4
[ebuild   R    ]  sys-apps/util-linux-2.32-r4
[nomerge       ] dev-util/gtk-update-icon-cache-3.22.19
[ebuild  N     ]  x11-misc/shared-mime-info-1.9  USE="{-test}"
[nomerge       ] dev-util/cmake-3.9.6
[ebuild   R    ]  dev-libs/expat-2.2.5
[nomerge       ] x11-libs/libXcomposite-0.4.4-r2  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  x11-base/xorg-proto-2018.4
[nomerge       ] dev-util/cmake-3.9.6
[nomerge       ]  virtual/pkgconfig-0-r1
[ebuild   R    ]   dev-util/pkgconfig-0.29.2
[nomerge       ] dev-util/gtk-update-icon-cache-3.22.19
[ebuild   R    ]  dev-util/desktop-file-utils-0.23
[ebuild   R    ]   dev-libs/glib-2.52.3  USE="-mime*"
[ebuild   R    ] net-misc/iputils-20171016_pre
[ebuild   R    ] net-misc/wget-1.19.5
[nomerge       ] net-libs/nodejs-8.11.1
[ebuild   R    ]  net-libs/nghttp2-1.31.1
[nomerge       ] dev-util/cmake-3.9.6
[ebuild   R    ]  app-crypt/rhash-1.3.5
[ebuild   R    ]   dev-libs/openssl-1.0.2o-r3
[ebuild   R    ] dev-python/setuptools-36.7.2
[nomerge       ] media-libs/mesa-17.3.9  USE="classic dri3 egl gallium gbm llvm nptl -bindist -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -unwind -vaapi -valgrind -vdpau -vulkan -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="intel nouveau radeon radeonsi (-freedreno) -i915 -i965 (-imx) -r100 -r200 -r300 -r600 (-vc4) -virgl (-vivante) -vmware"
[ebuild   R    ]  app-eselect/eselect-opengl-1.3.1-r4
[ebuild   R    ] app-admin/logrotate-3.14.0
[ebuild   R    ] sys-apps/net-tools-1.60_p20161110235919
[ebuild   R    ] sys-apps/diffutils-3.5
[ebuild   R    ] sys-apps/grep-3.0
[ebuild   R    ] virtual/pager-0
[nomerge       ] sys-kernel/gentoo-sources-4.14.52
[nomerge       ]  virtual/libelf-3
[ebuild   R    ]   dev-libs/elfutils-0.170-r1
[ebuild   R    ] app-editors/nano-2.8.7
[nomerge       ] net-analyzer/bmon-4.0
[ebuild   R    ]  dev-libs/libnl-3.4.0
[nomerge       ] sys-kernel/gentoo-sources-4.14.52
[ebuild   R    ]  sys-devel/bc-1.06.95-r2
[nomerge       ] dev-vcs/git-2.16.4  USE="blksha1 curl gpg iconv pcre pcre-jit perl python subversion threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental -nls (-ppcsha1) {-test} -tk -xinetd" PYTHON_TARGETS="python2_7"
[ebuild   R    ]  dev-libs/libpcre2-10.30
[nomerge       ] dev-libs/confuse-3.0
[nomerge       ]  sys-devel/libtool-2.4.6-r3
[ebuild   R    ]   dev-libs/libltdl-2.4.6
[nomerge       ] gnome-base/librsvg-2.40.18  USE="-introspection -tools -vala" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ]  dev-libs/vala-common-0.36.13
[ebuild   R    ] dev-libs/boost-1.65.0
[nomerge       ] gnome-base/librsvg-2.40.18  USE="-introspection -tools -vala" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ]  dev-libs/gobject-introspection-common-1.52.1
[nomerge       ] dev-lang/php-7.1.18
[ebuild   R    ]  sys-devel/bison-3.0.4-r1
[ebuild   R    ] sys-devel/binutils-2.30-r2
[ebuild   R    ]  sys-devel/flex-2.6.4-r1
[nomerge       ] sys-devel/gcc-7.3.0-r3
[ebuild   R    ]  dev-libs/mpc-1.0.3
[ebuild   R    ]   dev-libs/mpfr-3.1.6
[ebuild   R    ]    dev-libs/gmp-6.1.2
[ebuild   R    ]     sys-devel/m4-1.4.17
[nomerge       ] sys-apps/man-db-2.7.6.1-r2
[ebuild   R    ]  dev-libs/libpipeline-1.4.2
[nomerge       ] dev-vcs/git-2.16.4  USE="blksha1 curl gpg iconv pcre pcre-jit perl python subversion threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental -nls (-ppcsha1) {-test} -tk -xinetd" PYTHON_TARGETS="python2_7"
[nomerge       ]  app-crypt/gnupg-2.2.8
[ebuild   R    ]   dev-libs/libksba-1.3.5-r1
[ebuild   R    ]   dev-libs/npth-1.3
[ebuild   R    ] sys-apps/less-529
[nomerge       ] sys-fs/zfs-0.7.9
[nomerge       ]  virtual/udev-217
[nomerge       ]   sys-fs/eudev-3.2.5
[ebuild   R    ]    sys-apps/kmod-24
[nomerge       ] net-dns/libidn2-2.0.4
[ebuild   R    ]  dev-libs/libunistring-0.9.7
[nomerge       ] dev-util/gtk-update-icon-cache-3.22.19
[nomerge       ]  x11-libs/gdk-pixbuf-2.36.12  USE="-X -debug -introspection -jpeg -jpeg2k {-test} -tiff" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]   media-libs/libpng-1.6.34  USE="-apng (-neon) -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse"
[nomerge       ] app-crypt/p11-kit-0.23.9
[ebuild   R    ]  dev-libs/libffi-3.2.1
[nomerge       ] app-crypt/gnupg-2.2.8
[ebuild   R    ]  dev-libs/libassuan-2.5.1
[nomerge       ] app-admin/logrotate-3.14.0
[ebuild   R    ]  dev-libs/popt-1.16-r2
[nomerge       ] sys-apps/util-linux-2.32-r4
[nomerge       ]  sys-libs/pam-1.2.1-r2
[ebuild   R    ]   sys-libs/cracklib-2.9.6-r1
[ebuild   R    ] sys-apps/file-5.33-r3
[nomerge       ] media-libs/harfbuzz-1.8.1  USE="cairo glib graphite icu truetype -debug -fontconfig -introspection -static-libs {-test}" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]  media-libs/freetype-2.9.1-r3  USE="adobe-cff bzip2 cleartype_hinting -X -bindist -debug -doc -fontforge -harfbuzz -infinality -png -static-libs -utils" ABI_X86="(64) -32 (-x32)"
[nomerge       ] app-crypt/gnupg-2.2.8
[ebuild   R    ]  dev-libs/libgpg-error-1.29
[nomerge       ] dev-lang/php-7.1.18
[ebuild   R    ]  dev-libs/libpcre-8.41-r1
[ebuild   R    ]   sys-libs/zlib-1.2.11-r2
[ebuild   R    ]    app-portage/elt-patches-20170815
[nomerge       ] x11-themes/adwaita-icon-theme-3.24.0  USE="-branding"
[ebuild  N     ]  x11-themes/hicolor-icon-theme-0.17
[ebuild   R    ]   app-arch/xz-utils-5.2.3
[ebuild   R    ] virtual/python-ipaddress-1.0-r1  PYTHON_TARGETS="(-python3_7)"
[ebuild   R    ] virtual/perl-CPAN-Meta-2.150.5-r1
[nomerge       ] dev-perl/Module-Build-0.422.400
[ebuild   R    ]  virtual/perl-ExtUtils-CBuilder-0.280.225-r2
[ebuild   R    ]  virtual/perl-ExtUtils-Install-2.40.0-r3
[ebuild   R    ]  virtual/perl-ExtUtils-Manifest-1.700.0-r5
[ebuild   R    ]  virtual/perl-ExtUtils-ParseXS-3.310.0-r1
[ebuild   R    ]  virtual/perl-Getopt-Long-2.480.0-r1
[ebuild   R    ]  virtual/perl-Module-Metadata-1.0.31-r1
[ebuild   R    ]  virtual/perl-Perl-OSType-1.9.0-r1
[ebuild   R    ]  virtual/perl-Text-ParseWords-3.300.0-r4
[ebuild   R    ]  virtual/perl-podlators-4.70.0-r1
[ebuild   R    ]  virtual/perl-version-0.991.600-r1
[nomerge       ] dev-perl/Digest-HMAC-1.30.0-r1
[ebuild   R    ]  virtual/perl-Digest-SHA-5.950.100_rc-r6
[nomerge       ] dev-perl/WWW-RobotRules-6.20.0
[nomerge       ]  dev-perl/URI-1.710.0
[ebuild   R    ]   virtual/perl-parent-0.234.0-r1
[nomerge       ] dev-perl/HTML-Parser-3.720.0
[ebuild   R    ]  virtual/perl-XSLoader-0.220.0-r4
[nomerge       ] dev-lang/perl-5.24.3-r1
[ebuild   R    ]  virtual/perl-File-Path-2.130.0
[ebuild   R    ]  app-admin/perl-cleaner-2.25
[nomerge       ] media-libs/mesa-17.3.9  USE="classic dri3 egl gallium gbm llvm nptl -bindist -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -unwind -vaapi -valgrind -vdpau -vulkan -wayland -xa -xvmc" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="intel nouveau radeon radeonsi (-freedreno) -i915 -i965 (-imx) -r100 -r200 -r300 -r600 (-vc4) -virgl (-vivante) -vmware"
[ebuild   R    ]  app-eselect/eselect-mesa-0.0.10-r1
[nomerge       ] dev-lang/php-7.1.18
[ebuild   R    ]  app-eselect/eselect-php-0.9.4-r5
[nomerge       ] dev-util/ctags-20161028
[ebuild   R    ]  app-eselect/eselect-ctags-1.18
[nomerge       ] app-editors/vim-8.0.1298
[ebuild   R    ]  app-eselect/eselect-vi-1.1.9
[nomerge       ] dev-perl/Module-Build-0.422.400
[ebuild   R    ]  virtual/perl-CPAN-Meta-YAML-0.18.0-r3
[ebuild   R    ]  virtual/perl-Parse-CPAN-Meta-1.441.700.100_rc-r4
[nomerge       ] dev-perl/Digest-HMAC-1.30.0-r1
[ebuild   R    ]  virtual/perl-Digest-MD5-2.540.0-r3
[nomerge       ] dev-perl/libwww-perl-6.150.0
[ebuild   R    ]  virtual/perl-libnet-3.80.100_rc-r4
[nomerge       ] dev-perl/HTTP-Daemon-6.10.0-r2
[nomerge       ]  dev-perl/HTTP-Date-6.20.0-r1
[ebuild   R    ]   virtual/perl-Time-Local-1.230.0-r6
[nomerge       ] dev-perl/libwww-perl-6.150.0
[nomerge       ]  dev-perl/HTTP-Message-6.130.0
[ebuild   R    ]   virtual/perl-IO-Compress-2.69.1_rc-r4
[nomerge       ] dev-perl/Module-Build-0.422.400
[ebuild   R    ]  virtual/perl-File-Temp-0.230.400-r5
[ebuild   R    ]  virtual/perl-Test-Harness-3.360.100_rc-r3
[nomerge       ] sys-fs/zfs-kmod-0.7.9
[ebuild   R    ]  virtual/linux-sources-3
[nomerge       ] sys-fs/lvm2-2.02.145-r2
[ebuild   R    ]  virtual/libudev-232
[nomerge       ] net-analyzer/fail2ban-0.10.3.1
[ebuild   R    ]  virtual/logger-0
[nomerge       ] dev-perl/Net-HTTP-6.90.0
[nomerge       ]  dev-perl/URI-1.710.0
[ebuild   R    ]   virtual/perl-Exporter-5.720.0-r3
[ebuild   R    ]   virtual/perl-Scalar-List-Utils-1.420.200_rc-r1
[ebuild   R    ]  virtual/perl-Compress-Raw-Zlib-2.69.0-r1
[nomerge       ] dev-perl/HTTP-Cookies-6.40.0
[ebuild   R    ]  virtual/perl-Carp-1.400.0-r1
[nomerge       ] dev-perl/Module-Build-0.422.400
[ebuild   R    ]  virtual/perl-Data-Dumper-2.160.0-r1
[ebuild   R    ]  virtual/perl-File-Spec-3.630.100_rc-r4
[nomerge       ] dev-perl/HTTP-Daemon-6.10.0-r2
[ebuild   R    ]  virtual/perl-IO-1.360.100_rc-r4
[ebuild   R    ] app-forensics/chkrootkit-0.52
[ebuild   R    ]  virtual/cron-0-r1
[ebuild   R    ] virtual/mailx-1
[nomerge       ] dev-perl/Net-SSLeay-1.820.0
[ebuild   R    ]  virtual/perl-MIME-Base64-3.150.0-r4
[nomerge       ] dev-perl/HTTP-Cookies-6.40.0
[nomerge       ]  dev-perl/HTTP-Message-6.130.0
[nomerge       ]   dev-perl/Encode-Locale-1.50.0
[ebuild   R    ]    virtual/perl-Encode-2.800.100_rc-r4
[ebuild   R    ]   virtual/perl-Storable-2.560.100_rc-r4
[nomerge       ] sys-kernel/gentoo-sources-4.4.26
[nomerge       ]  sys-devel/bc-1.06.95-r2
[ebuild   R    ]   virtual/yacc-0
[nomerge       ] gnome-base/gnome-keyring-3.20.1  USE="caps filecaps pam ssh-agent (-selinux) {-test}"
[ebuild   R    ]  app-text/docbook-xml-dtd-4.3-r1
[nomerge       ] sys-fs/btrfs-progs-4.10.2
[nomerge       ]  app-text/xmlto-0.0.26-r1
[ebuild   R    ]   app-text/docbook-xml-dtd-4.2-r2
[nomerge       ] sci-misc/boinc-7.9.3 [7.6.33-r1] CURL_SSL="-gnutls%"
[ebuild   R    ]  app-text/docbook-xml-dtd-4.4-r2
[nomerge       ] x11-libs/gtk+-3.22.30  USE="X (-aqua) -broadway -cloudprint -colord -cups -examples -introspection {-test} -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ]  app-text/docbook-xml-dtd-4.1.2-r6
[ebuild   R    ]   app-text/build-docbook-catalog-1.21
[ebuild   R    ]   app-text/docbook-xsl-stylesheets-1.79.1-r2
[nomerge       ] dev-perl/XML-LibXML-2.13.200
[nomerge       ]  dev-perl/XML-SAX-Base-1.90.0
[ebuild   R    ]   virtual/perl-ExtUtils-MakeMaker-7.100.200_rc-r4
[nomerge       ] sys-apps/openrc-0.34.11
[ebuild   R    ]  net-misc/netifrc-0.5.1
[ebuild   R    ] app-admin/sysstat-11.4.0
[ebuild   R    ] sys-process/procps-3.3.15-r1
[ebuild   R    ] sys-apps/kbd-2.0.4
[nomerge       ] sys-fs/zfs-0.7.9
[ebuild   R    ]  virtual/awk-1
[nomerge       ] x11-libs/libpciaccess-0.14  USE="zlib -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild   R    ]  sys-apps/hwids-20171003
[nomerge       ] sys-fs/btrfs-progs-4.10.2
[ebuild   R    ]  sys-libs/e2fsprogs-libs-1.43.9
[ebuild   R    ] sys-apps/gawk-4.1.4
[ebuild   R    ] app-shells/bash-4.4_p12
[ebuild   R    ]  sys-libs/readline-7.0_p3
[ebuild   R    ]   virtual/pkgconfig-0-r1
[ebuild   R    ] virtual/editor-0-r1
[ebuild   R    ] virtual/shadow-0
[nomerge       ] gnome-base/gnome-keyring-3.20.1  USE="caps filecaps pam ssh-agent (-selinux) {-test}"
[ebuild   R    ]  app-eselect/eselect-pinentry-0.7
[ebuild   R    ] sys-apps/man-pages-4.15
[ebuild   R    ]  sys-apps/man-pages-posix-2013a
[ebuild   R    ]   virtual/man-0-r1
[ebuild   R    ] virtual/modutils-0
[ebuild   R    ] virtual/dev-manager-0-r1
[nomerge       ] sys-fs/zfs-0.7.9
[ebuild   R    ]  sys-fs/udev-init-scripts-32
[ebuild   R    ]   virtual/udev-217
[nomerge       ] dev-lang/python-2.7.14-r1
[ebuild   R    ]  app-eselect/eselect-python-20171204
[nomerge       ] sys-fs/zfs-kmod-0.7.9
[ebuild   R    ]  virtual/libelf-3
[ebuild   R    ]  sys-apps/sed-4.5
[ebuild   R    ]   virtual/acl-0-r2
[nomerge       ] net-analyzer/fail2ban-0.10.3.1
[ebuild   R    ]  virtual/mta-1
[nomerge       ] dev-lang/python-2.7.14-r1
[ebuild   R    ]  virtual/libffi-3.0.13-r1
[nomerge       ] mail-mta/ssmtp-2.64-r3
[ebuild   R    ]  net-mail/mailbase-1.1
[ebuild   R    ]   virtual/pam-0-r1
[ebuild   R    ] net-analyzer/iptraf-ng-1.1.4-r1
[nomerge       ] sys-apps/openrc-0.34.11
[ebuild   R    ]  sys-apps/sysvinit-2.88-r9
[ebuild   R    ]   virtual/os-headers-0
[ebuild     U ~] sec-policy/apparmor-profiles-2.12.0 [2.11.0]
[ebuild   R    ] sys-apps/memtester-4.3.0
[ebuild   R    ] net-analyzer/traceroute-2.0.20
[ebuild   R    ] sys-apps/hdparm-9.52
[nomerge       ] sys-fs/eudev-3.2.5
[ebuild   R    ]  dev-util/gperf-3.1
[nomerge       ] dev-libs/boost-1.65.0
[ebuild   R    ]  dev-util/boost-build-1.65.0
[nomerge       ] app-admin/syslog-ng-3.13.2
[ebuild   R    ]  dev-libs/ivykis-0.42.2
[ebuild   R    ]  sys-apps/tcp-wrappers-7.6.22-r1
[nomerge       ] sys-fs/zfs-0.7.9
[ebuild   R    ]  app-arch/cpio-2.12-r1
[nomerge       ] mail-client/mailx-8.1.2.20160123
[ebuild   R    ]  mail-client/mailx-support-20060102-r2
[nomerge       ] net-libs/nodejs-8.11.1
[ebuild   R    ]  net-libs/http-parser-2.8.1
[nomerge       ] sys-boot/lilo-24.0-r1
[ebuild   R    ]  sys-devel/bin86-0.16.21
[nomerge       ] sys-block/thin-provisioning-tools-0.7.0
[ebuild   R    ]  dev-libs/libaio-0.3.110
[nomerge       ] sys-fs/lvm2-2.02.145-r2
[ebuild   R    ]  sys-devel/autoconf-archive-2018.03.13
[nomerge       ] sys-devel/llvm-5.0.2
[ebuild   R    ]  sys-devel/llvm-common-5.0.2
[nomerge       ] sys-devel/llvm-5.0.2
[nomerge       ]  dev-util/ninja-1.8.2
[ebuild   R    ]   dev-util/re2c-0.16
[nomerge       ] dev-lang/php-7.1.18
[ebuild   R    ]  dev-libs/oniguruma-6.8.2
[nomerge       ] sys-process/cronie-1.5.1-r1
[ebuild   R    ]  sys-process/cronbase-0.3.7-r6
[nomerge       ] app-benchmarks/sysbench-1.0.10
[ebuild   R    ]  dev-libs/concurrencykit-0.6.0
[ebuild   R    ]  dev-lang/luajit-2.0.5-r1
[nomerge       ] net-dns/bind-tools-9.11.2_p1
[nomerge       ]  sys-devel/automake-1.15.1-r2
[ebuild   R    ]   sys-devel/automake-wrapper-10
[nomerge       ] net-misc/ntp-4.2.8_p11
[nomerge       ]  sys-devel/autoconf-2.69-r4
[ebuild   R    ]   sys-devel/autoconf-wrapper-13-r1
[ebuild   R    ] dev-lang/go-1.10.3
[nomerge       ] app-text/docbook2X-0.8.8-r4
[nomerge       ]  app-text/docbook-xml-dtd-4.2-r2
[ebuild   R    ]   app-text/sgml-common-0.6.3-r6
[ebuild   R    ]   app-arch/unzip-6.0_p21-r2
[nomerge       ] sys-apps/man-db-2.7.6.1-r2
[ebuild   R    ]  app-text/manpager-1
[nomerge       ] sys-apps/openrc-0.34.11
[ebuild   R    ]  virtual/tmpfiles-0
[ebuild   R    ]   sys-apps/opentmpfiles-0.1.3
[nomerge       ] x11-libs/gtk+-3.22.30  USE="X (-aqua) -broadway -cloudprint -colord -cups -examples -introspection {-test} -vim-syntax -wayland -xinerama" ABI_X86="(64) -32 (-x32)"
[nomerge       ]  x11-libs/pango-1.40.14-r1  USE="-X -introspection {-test}" ABI_X86="(64) -32 (-x32)"
[nomerge       ]   media-libs/fontconfig-2.12.6  USE="-doc -static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ]    virtual/ttf-fonts-1-r1
[ebuild  N     ]     media-fonts/liberation-fonts-2.00.1-r3  USE="-X -fontforge"
[nomerge       ] sys-devel/gcc-7.3.0-r3
[ebuild   R    ]  sys-devel/gcc-config-1.8-r1
[nomerge       ] sys-apps/portage-2.3.40-r1
[ebuild   R    ]  app-crypt/openpgp-keys-gentoo-release-20180706
[ebuild   R    ]  sys-apps/install-xattr-0.5
[nomerge       ] sys-apps/iproute2-4.14.1-r2
[ebuild   R    ]  net-libs/libmnl-1.0.4
[ebuild   R    ] sys-apps/findutils-4.6.0-r1
[ebuild   R    ] sys-apps/which-2.21
[ebuild   R    ] sys-apps/baselayout-2.4.1-r2
[ebuild   R    ] app-arch/gzip-1.8
[ebuild   R    ] sys-libs/timezone-data-2018d
[nomerge       ] sys-devel/binutils-2.30-r2
[ebuild   R    ]  sys-devel/binutils-config-5-r4
[nomerge       ] sys-fs/btrfs-progs-4.10.2
[ebuild   R    ]  dev-libs/lzo-2.10
[nomerge       ] sys-process/cronie-1.5.1-r1
[ebuild   R    ]  sys-apps/debianutils-4.8.3
[nomerge       ] dev-libs/libevent-2.1.8
[nomerge       ]  dev-libs/openssl-1.0.2o-r3
[ebuild   R    ]   app-misc/c_rehash-1.7-r1
[nomerge       ] sys-apps/less-529
[ebuild   R    ]  app-misc/editor-wrapper-4
[nomerge       ] dev-lang/python-2.7.14-r1
[ebuild   R    ]  app-misc/mime-types-9
[ebuild   R    ] sys-devel/gnuconfig-20170101
[ebuild   R    ] sys-devel/make-4.2.1
[nomerge       ] sys-libs/binutils-libs-2.30-r2
[nomerge       ]  sys-devel/binutils-config-5-r4
[ebuild   R    ]   sys-apps/gentoo-functions-0.12
[nomerge       ] dev-lang/python-2.7.14-r1
[ebuild   R    ]  virtual/libintl-0-r2
[nomerge       ] app-arch/libarchive-3.3.1
[ebuild   R    ]  virtual/libiconv-0-r2
[ebuild   R    ]  app-arch/bzip2-1.0.6-r9
[ebuild   R    ] sys-libs/ncurses-6.1-r2
[nomerge       ] dev-python/pyasn1-0.2.3
[ebuild   R    ]  dev-lang/python-exec-2.4.5  PYTHON_TARGETS="(-python3_7)"

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by @selected
# required by @world (argument)
=sci-misc/boinc-7.9.3 ~amd64
# required by @selected
# required by @world (argument)
=sec-policy/apparmor-profiles-2.12.0 ~amd64

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by app-crypt/gcr-3.20.0::gentoo[gtk]
# required by gnome-base/gnome-keyring-3.20.1::gentoo
# required by app-crypt/libsecret-0.18.6-r1::gentoo
# required by app-crypt/pinentry-1.0.0-r2::gentoo[gnome-keyring]
# required by app-crypt/gnupg-2.2.8::gentoo
# required by dev-vcs/git-2.16.4::gentoo[gpg]
# required by app-emulation/snapd-2.15.2::gentoo-snappy
# required by @selected
# required by @world (argument)
>=x11-libs/gtk+-3.22.30 X
# required by x11-libs/gtk+-3.22.30::gentoo
# required by app-crypt/gcr-3.20.0::gentoo[gtk]
# required by gnome-base/gnome-keyring-3.20.1::gentoo
# required by app-crypt/libsecret-0.18.6-r1::gentoo
# required by app-crypt/pinentry-1.0.0-r2::gentoo[gnome-keyring]
# required by app-crypt/gnupg-2.2.8::gentoo
# required by dev-vcs/git-2.16.4::gentoo[gpg]
# required by app-emulation/snapd-2.15.2::gentoo-snappy
# required by @selected
# required by @world (argument)
>=media-libs/libepoxy-1.5.1 X
# required by x11-libs/gtk+-3.22.30::gentoo
# required by app-crypt/gcr-3.20.0::gentoo[gtk]
# required by gnome-base/gnome-keyring-3.20.1::gentoo
# required by app-crypt/libsecret-0.18.6-r1::gentoo
# required by app-crypt/pinentry-1.0.0-r2::gentoo[gnome-keyring]
# required by app-crypt/gnupg-2.2.8::gentoo
# required by dev-vcs/git-2.16.4::gentoo[gpg]
# required by app-emulation/snapd-2.15.2::gentoo-snappy
# required by @selected
# required by @world (argument)
>=x11-libs/cairo-1.14.12 X

emerge: there are no ebuilds to satisfy "app-admin/python-updater".
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

emerge: there are no ebuilds to satisfy "sys-kernel/gentoo-sources:4.4.26".
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

 * IMPORTANT: 24 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

rackserv /usr/portage/profiles # cat /etc/portage/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE and USE_EXPAND flags that were used for
# buidling in addition to what is provided by the profile.
USE="-bindist -gtk -gtk2 -gtk3 -gnome -alsa -esd -pulseaudio -sdl -cups -qt -qt4 -qt5 -X -kde -apache2 -samba -sybase -xinetd -gpm -nls -mysql -cario -gnome-keyring -introspection -mime device-mapper dlz git subversion threads"

PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
MAKEOPTS="-j56 -l112"
EMERGE_DEFAULT_OPTS="--jobs=56 --load-average=112"
CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
rackserv /usr/portage/profiles # eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/13.0 (stable)
  [2]   default/linux/amd64/13.0/selinux (dev)
  [3]   default/linux/amd64/13.0/desktop (stable)
  [4]   default/linux/amd64/13.0/desktop/gnome (stable)
  [5]   default/linux/amd64/13.0/desktop/gnome/systemd (stable)
  [6]   default/linux/amd64/13.0/desktop/plasma (stable)
  [7]   default/linux/amd64/13.0/desktop/plasma/systemd (stable)
  [8]   default/linux/amd64/13.0/developer (stable)
  [9]   default/linux/amd64/13.0/no-multilib (stable)
  [10]  default/linux/amd64/13.0/systemd (stable)
  [11]  default/linux/amd64/13.0/x32 (dev)
  [12]  default/linux/amd64/17.0 (stable) *
  [13]  default/linux/amd64/17.0/selinux (stable)
  [14]  default/linux/amd64/17.0/hardened (stable)
  [15]  default/linux/amd64/17.0/hardened/selinux (stable)
  [16]  default/linux/amd64/17.0/desktop (stable)
  [17]  default/linux/amd64/17.0/desktop/gnome (stable)
  [18]  default/linux/amd64/17.0/desktop/gnome/systemd (stable)
  [19]  default/linux/amd64/17.0/desktop/plasma (stable)
  [20]  default/linux/amd64/17.0/desktop/plasma/systemd (stable)
  [21]  default/linux/amd64/17.0/developer (stable)
  [22]  default/linux/amd64/17.0/no-multilib (stable)
  [23]  default/linux/amd64/17.0/no-multilib/hardened (stable)
  [24]  default/linux/amd64/17.0/no-multilib/hardened/selinux (stable)
  [25]  default/linux/amd64/17.0/systemd (stable)
  [26]  default/linux/amd64/17.0/x32 (dev)
  [27]  default/linux/amd64/17.1 (exp)
  [28]  default/linux/amd64/17.1/selinux (exp)
  [29]  default/linux/amd64/17.1/hardened (exp)
  [30]  default/linux/amd64/17.1/hardened/selinux (exp)
  [31]  default/linux/amd64/17.1/desktop (exp)
  [32]  default/linux/amd64/17.1/desktop/gnome (exp)
  [33]  default/linux/amd64/17.1/desktop/gnome/systemd (exp)
  [34]  default/linux/amd64/17.1/desktop/plasma (exp)
  [35]  default/linux/amd64/17.1/desktop/plasma/systemd (exp)
  [36]  default/linux/amd64/17.1/developer (exp)
  [37]  default/linux/amd64/17.1/no-multilib (exp)
  [38]  default/linux/amd64/17.1/no-multilib/hardened (exp)
  [39]  default/linux/amd64/17.1/no-multilib/hardened/selinux (exp)
  [40]  default/linux/amd64/17.1/systemd (exp)
  [41]  hardened/linux/amd64 (stable)
  [42]  hardened/linux/amd64/selinux (stable)
  [43]  hardened/linux/amd64/no-multilib (stable)
  [44]  hardened/linux/amd64/no-multilib/selinux (stable)
  [45]  hardened/linux/amd64/x32 (dev)
  [46]  default/linux/musl/amd64 (exp)
  [47]  hardened/linux/musl/amd64 (exp)
  [48]  default/linux/musl/amd64/x32 (exp)
  [49]  hardened/linux/musl/amd64/x32 (exp)
  [50]  default/linux/amd64/17.0/musl (exp)
  [51]  default/linux/amd64/17.0/musl/hardened (exp)
  [52]  default/linux/amd64/17.0/musl/hardened/selinux (exp)
  [53]  default/linux/uclibc/amd64 (exp)
  [54]  hardened/linux/uclibc/amd64 (exp)
rackserv /usr/portage/profiles #


I am completely clueless why all the X11 stuff is trying to be pulled in new, from hicolor-icon-theme to gtk+ (just look for "ebuild N" for things like look x-like.

Hints please.
_________________
Linux since 0.96 kernel on a 4 floppy slackware distribution
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sun Jul 22, 2018 6:56 am    Post subject: Reply with quote

USE="-gnome-keyring -truetype" would be a good start, I guess.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21567
Location: here

PostPosted: Sun Jul 22, 2018 6:59 am    Post subject: Reply with quote

You have some gnome-keyring and gtk use flag set in /etc/portage/package.use?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ccgllc
n00b
n00b


Joined: 21 Jul 2018
Posts: 18
Location: NE Missouri

PostPosted: Sun Jul 22, 2018 3:40 pm    Post subject: Reply with quote

From above:

USE="-bindist -gtk -gtk2 -gtk3 -gnome -alsa -esd -pulseaudio -sdl -cups -qt -qt4 -qt5 -X -kde -apache2 -samba -sybase -xinetd -gpm -nls -mysql -cario -gnome-keyring -introspection -mime device-mapper dlz git subversion threads"

I'll try adding -truetype
_________________
Linux since 0.96 kernel on a 4 floppy slackware distribution
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21567
Location: here

PostPosted: Sun Jul 22, 2018 3:46 pm    Post subject: Reply with quote

Ok but if you have some entries on /etc/portage/package.use with gtk, gnome-keyring,... these overwrite those in make.conf
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13624

PostPosted: Sun Jul 22, 2018 4:10 pm    Post subject: Reply with quote

Why not just use emerge --pretend --verbose --depclean on your target list? Anything it cannot remove due to dependencies will be explained. For example:
Code:
# emerge -pv --depclean gtk+:2

Calculating dependencies... done!
  x11-libs/gtk+-2.24.31-r1 pulled in by:
    x11-misc/xscreensaver-5.38 requires x11-libs/gtk+:2

>>> No packages selected for removal by depclean
I trimmed some output, but this shows exactly why I cannot remove gtk+:2 yet: xscreensaver needs it. I would then add xscreensaver and try again.

As an alternative, if you don't mind risking a bit of temporary breakage, you can use --unmerge to remove packages without checking whether they are needed. You might use this on core X11 packages first, since you are certain you do not want those. Follow up later with a depclean to eliminate packages that were only to support X11, but did not catch your attention because they are considered general purpose libraries.
Back to top
View user's profile Send private message
ccgllc
n00b
n00b


Joined: 21 Jul 2018
Posts: 18
Location: NE Missouri

PostPosted: Sun Jul 22, 2018 9:31 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Ok but if you have some entries on /etc/portage/package.use with gtk, gnome-keyring,... these overwrite those in make.conf


AH!!! Indeed there were. Testing now to see what that fixes but that goes a long way towards explaining the current behavior I'm experiencing. Thank You!

Ok. Cleaned up the files in /etc/portage and now an "emerge -p --update --newuse --deep @world" results in:

Code:
Calculating dependencies... done!
[ebuild   R    ] sys-libs/zlib-1.2.11-r2  ABI_X86="-32*"
[ebuild  N     ] app-crypt/pinentry-1.0.0-r2  USE="ncurses -caps -emacs -gnome-keyring -gtk -qt5 -static"
[ebuild   R    ] dev-libs/glib-2.52.3  USE="-mime*"


That is SOOOOOO MUCH BETTER!!!

Thank you again. My sanity has been restored (well, at least to its previous levels).
_________________
Linux since 0.96 kernel on a 4 floppy slackware distribution
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum