Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Anyone gotten VLC to chromecast successfully?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
equaeghe
Guru
Guru


Joined: 22 Feb 2005
Posts: 437

PostPosted: Thu May 31, 2018 10:59 am    Post subject: Anyone gotten VLC to chromecast successfully? Reply with quote

The newly stabilized VLC has chromecast support. I wanted to try it, but casting does not work: the chromecast is detected and a cast icon shows on the TV, but nothing plays when I try to cast a video. When I try to cast an MP3, I see the MP3 name on the TV with a blue progress bar, but it does not progress, the progress+info bar just flickers on and off.

Did anyone successfully chromecast on Gentoo using VLC? Did you have to do anything specific to get things working?
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 199

PostPosted: Thu May 31, 2018 6:44 pm    Post subject: Reply with quote

No idea and my answer is only a guess, but are you using the TVs native chromecast support?
It seems to be that many TV vendors just hack their kinda own version so this does not always works in each combi. Can you try a more generic chromecast / miracast USB stick on the TV?
Back to top
View user's profile Send private message
equaeghe
Guru
Guru


Joined: 22 Feb 2005
Posts: 437

PostPosted: Thu May 31, 2018 7:34 pm    Post subject: Reply with quote

msst wrote:
[…], but are you using the TVs native chromecast support?[…]
No, I'm using the standard Google Chromecast dongle.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6620
Location: Austria

PostPosted: Fri Jun 01, 2018 6:05 pm    Post subject: Reply with quote

Code:
 * USE=microdns is required for Chromecast autodetection support

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
equaeghe
Guru
Guru


Joined: 22 Feb 2005
Posts: 437

PostPosted: Fri Jun 01, 2018 7:01 pm    Post subject: Reply with quote

asturm wrote:
Code:
 * USE=microdns is required for Chromecast autodetection support
I have that use flag set and autodetection works. The issue presents itself when trying to cast.
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1389
Location: Adelaide/Australia

PostPosted: Sat Jun 02, 2018 1:59 am    Post subject: Reply with quote

Doing better than me, I don't even see the TV, which has a Chromecast 1 dongle.
I just see the endless orange/grey spinner.
Chromium, on the same system does show the TV.

EDIT: Recent rebuild of VLC to 3.0.2 (Vetinari), has the new Renderer menu, in which my TV showed up.
Once I selected the TV, then opening a video from My Videos played on my TV, with sound.
Initial impressions are all good!
_________________
...Lyall
Back to top
View user's profile Send private message
equaeghe
Guru
Guru


Joined: 22 Feb 2005
Posts: 437

PostPosted: Thu Jul 19, 2018 1:29 pm    Post subject: Reply with quote

I tracked it down to a firewall issue. When I disable my firewall (on the machine I'm streaming from) when starting the video, it does work. Even if I re-enable the firewall, it keeps going. But if I do more than just pause/play, e.g., jump to another point in the video, it blocks again. Any insight about what ports to open?
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2519
Location: Near Toronto

PostPosted: Fri Jul 20, 2018 11:18 am    Post subject: Reply with quote

I got it to "work" - but for me it is very flaky with
frequent connection drops, after which the chromecast
disappears from the "renderer" tab.

I think this was reverse engineered and is little more
than a proof of concept at the moment.
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum