Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[emerge] Errores al actualizar
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 656
Location: Zaragoza (Spain)

PostPosted: Sat Jul 21, 2018 9:24 am    Post subject: [emerge] Errores al actualizar Reply with quote

Hola, buenos días:

Estoy teniendo bastentes problemas al actualizar el sistema y ya no se cómo resolverlos. Cada vez que intento actualizar me dice que cambie la USE abi_x86_32 de unos paquetes y lo voy haciendo hsata que luego me dice que de los mismos lo ponga en - y ya no se cómo hacerlo. Todo esto pasa al intentar hacer un
Code:
emerge --depclean
y me dice que haga:

Code:
emerge --update --newuse --deep --with-bdeps=y @world


emerge --info --> https://paste.pound-python.org/show/Lv0VjRURWL8rpl1QKeTz/

Gracias anticipadas y un saludo

edición (perdón)

Code:
# emerge -uvaDNq world

emerge: there are no ebuilds built with USE flags to satisfy ">=x11-libs/pango-1.36.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
!!! One of the following packages is required to complete your request:
- x11-libs/pango-1.40.14-r1::gentoo (Change USE: +abi_x86_32)
- gnome-base/librsvg-2.40.18::gentoo (Change USE: -abi_x86_32)
(dependency required by "gnome-base/librsvg-2.40.18::gentoo" [ebuild])
(dependency required by "x11-themes/adwaita-icon-theme-3.24.0::gentoo" [ebuild])
(dependency required by "x11-libs/gtk+-3.22.30::gentoo" [ebuild])
(dependency required by "xfce-base/libxfce4ui-4.13.4::gentoo" [installed])
(dependency required by "xfce-extra/xfce4-datetime-plugin-0.7.0::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1282

PostPosted: Sat Jul 21, 2018 12:10 pm    Post subject: Reply with quote

Code:
...
x11-libs/pango-1.40.14-r1::gentoo (Change USE: +abi_x86_32)
...

Parece claro, pon la use abi_x86_32 en x11-lib/pango. A ver que dice entonces...
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 656
Location: Zaragoza (Spain)

PostPosted: Sat Jul 21, 2018 3:05 pm    Post subject: Reply with quote

Estoy todo el rato cambiando las uses de abi_x86_32, cada vez me dice q las cambie a - luego a +, y así todo el rato

Code:
# emerge --update --newuse --deep --with-bdeps=y @world
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=x11-libs/cairo-1.12.14-r4:=[X?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
!!! One of the following packages is required to complete your request:
- x11-libs/cairo-1.14.12::gentoo (Change USE: +abi_x86_32)
- x11-libs/pango-1.40.14-r1::gentoo (Change USE: -abi_x86_32)
(dependency required by "x11-libs/pango-1.40.14-r1::gentoo" [ebuild])
(dependency required by "gnome-base/librsvg-2.40.18::gentoo" [ebuild])
(dependency required by "x11-libs/gtk+-2.24.32::gentoo" [ebuild])
(dependency required by "xfce-base/xfce4-panel-4.12.2::gentoo" [installed])
(dependency required by "xfce-extra/xfce4-sensors-plugin-1.2.98::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


No hay manera de no usar estas uses de abi 32?, el fichero donde las tengo es enorme, igual hay 150 lineas con diversos paquetes con estas uses.
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1282

PostPosted: Sat Jul 21, 2018 4:45 pm    Post subject: Reply with quote

Theasker wrote:
...
No hay manera de no usar estas uses de abi 32?
...

Creo que sí, construyendo tu sistema como no-multilib. La forma mas fácil sería partir de un perfil no-multilib. Puede que algún programa te deje de funcionar. En la práctica, si pasas a no-multilib, no es un cambio reversible.

Otra opción es ir desactivando las uses abi_x86_32 conforme te vayan apareciendo. En este caso:
Code:
x11-libs/pango-1.40.14-r1::gentoo (Change USE: -abi_x86_32)
gnome-base/librsvg-2.40.18::gentoo (Change USE: -abi_x86_32)


Si quieres seguir con tu sistema multilib pon:
Code:
x11-libs/cairo-1.14.12::gentoo (Change USE: +abi_x86_32)

Y sigue intentándolo.
Back to top
View user's profile Send private message
FyruX
n00b
n00b


Joined: 15 Mar 2018
Posts: 12
Location: Colombia

PostPosted: Tue Jul 31, 2018 3:39 am    Post subject: Reply with quote

No creo tener la solucion pero nos ayudaria que mostraras las saliadas de eselect profile list y cat /var/lib/portage/world

y vamos buscando.. no desesperes algun use fuera de lugar ....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum