Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Zoneminder Segfault after MariaDB-10.1.34
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
WintermuteX
n00b
n00b


Joined: 29 Apr 2006
Posts: 40
Location: Germany

PostPosted: Fri Jul 20, 2018 4:55 pm    Post subject: Zoneminder Segfault after MariaDB-10.1.34 Reply with quote

Hello :)

Unfortunately I have a problem with zoneminder 1.30.4. After the package of mariadb was updated from 10.1.31-r1 to 10.1.34 zoneminder stopped working.
I re-emerge dev-perl/DBD-mysql but the zms cgi binary is segfaulting:
Code:

2018-07-20 18:38:21.229450   zmwatch      31489   ERR   Memory map file '/dev/shm/zm.mmap.3' does not exist. zmc might not be running.   zmwatch.pl   
2018-07-20 18:38:18.388189   zms         31520   ERR   Backtrace 7: /usr/libexec/zoneminder/cgi-bin/zms(_start+0x2a) [0x561540aeeb6a]   zm_signal.cpp   102
2018-07-20 18:38:18.387407   zms         31520   ERR   Backtrace 6: /lib64/libc.so.6(__libc_start_main+0xea) [0x7fc166770faa]   zm_signal.cpp   102
2018-07-20 18:38:18.386692   zms         31520   ERR   Backtrace 5: /usr/libexec/zoneminder/cgi-bin/zms(main+0xaf2) [0x561540aedd12]   zm_signal.cpp   102
2018-07-20 18:38:18.385957   zms         31520   ERR   Backtrace 4: /usr/libexec/zoneminder/cgi-bin/zms(_ZN10StreamBase11loadMonitorEi+0x30) [0x561540b77c50]   zm_signal.cpp   102
2018-07-20 18:38:18.385274   zms         31520   ERR   Backtrace 3: /usr/libexec/zoneminder/cgi-bin/zms(_ZN7Monitor4LoadEjbNS_7PurposeE+0x77) [0x561540b2cc87]   zm_signal.cpp   102
2018-07-20 18:38:18.384543   zms         31520   ERR   Backtrace 2: /lib64/libc.so.6(+0x3b6f0) [0x7fc16678b6f0]   zm_signal.cpp   102
2018-07-20 18:38:18.382985   zms         31520   ERR   Backtrace 1: /lib64/libpthread.so.0(+0x14120) [0x7fc169c9d120]   zm_signal.cpp   102
2018-07-20 18:38:18.382161   zms         31520   ERR   Backtrace 0: /usr/libexec/zoneminder/cgi-bin/zms(_Z14zm_die_handleriP9siginfo_tPv+0x78) [0x561540b75338]   zm_signal.cpp   102
2018-07-20 18:38:18.380762   zms         31520   ERR   Signal address is (nil), from 0x7fc16678b6f0   zm_signal.cpp   81
2018-07-20 18:38:18.378759   zms         31520   ERR   Got signal 11 (Segmentation fault), crashing   zm_signal.cpp   50

2018-07-20 18:38:18.353887   web_js      30712   ERR   getStreamCmdResponse stream error: Socket /var/run/zm/zms-203526s.sock does not exist. This file is created by zms, and since it does not exist, either zms did not run, or zms exited early. Please check your zms logs and ensure that CGI is enabled in apache and check that the PATH_ZMS is set correctly. Make sure that ZM is actually recording. If you are trying to view a live stream and the capture process (zmc) is not running then zms will exit. Please go to http://zoneminder.readthedocs.io/en/latest/faq.html#why-can-t-i-see-streamed-images-when-i-can-see-stills-in-the-zone-window-etc for more information. - checkStreamForErrors()   ?view=watch   
2018-07-20 18:38:18.307742   web_php      30712   ERR   Socket /var/run/zm/zms-203526s.sock does not exist. This file is created by zms, and since it does not exist, either zms did not run, or zms exited early. Please check your zms logs and ensure that CGI is enabled in apache and check that the PATH_ZMS is set correctly. Make sure that ZM is actually recording. If you are trying to view a live stream and the capture process (zmc) is not running then zms will exit. Please go to http://zoneminder.readthedocs.io/en/latest/faq.html#why-can-t-i-see-streamed-images-when-i-can-see-stills-in-the-zone-window-etc for more information.


I really tried to find the culprit, but to no avail. Using a higher debuglevel doesn't help either:
Code:

07/20/18 16:59:12.906721 zms[18510].DB1-zm_logger.cpp/234 [LogOpts: level=DB1/DB1, screen=OFF, database=WAR, logfile=DB1->/var/log/zm/zm_debug.log.18510, syslog=ERR]
07/20/18 16:59:12.906752 zms[18510].DB1-zm_utils.cpp/266 [Detected a x86\x86-64 processor with SSSE3]
07/20/18 16:59:12.906764 zms[18510].DB1-zms.cpp/102 [Query: mode=jpeg&scale=75&maxfps=30&buffer=1000&monitor=3&auth=534c20f96e8403785e6b2e9f6dfe4ea4&connkey=355240&rand=678156]
07/20/18 16:59:12.906775 zms[18510].DB1-zm_user.cpp/172 [Attempting to authenticate user from auth string 'XXX']
07/20/18 16:59:12.906862 zms[18510].DB1-zm_user.cpp/235 [Checking auth_key 'XXX' -> auth_md5 'XXX']
07/20/18 16:59:12.906869 zms[18510].DB1-zm_user.cpp/235 [Checking auth_key 'XXX' -> auth_md5 'XXX']
07/20/18 16:59:12.906875 zms[18510].DB1-zm_user.cpp/235 [Checking auth_key 'XXX' -> auth_md5 'XXX']
07/20/18 16:59:12.906879 zms[18510].DB1-zm_user.cpp/241 [Authenticated user 'XXX']
07/20/18 16:59:12.907054 zms[18510].ERR-zm_signal.cpp/50 [Got signal 11 (Segmentation fault), crashing]
07/20/18 16:59:12.908659 zms[18510].DB1-zm_signal.cpp/61 [Signal information: number 11 code 128 errno 0 pid 0 uid 0 status 570100386]
07/20/18 16:59:12.908666 zms[18510].ERR-zm_signal.cpp/81 [Signal address is (nil), from 0x7fa21f4ae6f0]
07/20/18 16:59:12.909719 zms[18510].ERR-zm_signal.cpp/102 [Backtrace 0: /usr/libexec/zoneminder/cgi-bin/nph-zms(_Z14zm_die_handleriP9siginfo_tPv+0x78) [0x55a39c90b338]]
07/20/18 16:59:12.910401 zms[18510].ERR-zm_signal.cpp/102 [Backtrace 1: /lib64/libpthread.so.0(+0x14120) [0x7fa2229c0120]]
07/20/18 16:59:12.911049 zms[18510].ERR-zm_signal.cpp/102 [Backtrace 2: /lib64/libc.so.6(+0x3b6f0) [0x7fa21f4ae6f0]]
07/20/18 16:59:12.911686 zms[18510].ERR-zm_signal.cpp/102 [Backtrace 3: /usr/libexec/zoneminder/cgi-bin/nph-zms(_ZN7Monitor4LoadEjbNS_7PurposeE+0x77) [0x55a39c8c2c87]]
07/20/18 16:59:12.912423 zms[18510].ERR-zm_signal.cpp/102 [Backtrace 4: /usr/libexec/zoneminder/cgi-bin/nph-zms(_ZN10StreamBase11loadMonitorEi+0x30) [0x55a39c90dc50]]
07/20/18 16:59:12.913794 zms[18510].ERR-zm_signal.cpp/102 [Backtrace 5: /usr/libexec/zoneminder/cgi-bin/nph-zms(main+0xaf2) [0x55a39c883d12]]
07/20/18 16:59:12.914458 zms[18510].ERR-zm_signal.cpp/102 [Backtrace 6: /lib64/libc.so.6(__libc_start_main+0xea) [0x7fa21f493faa]]
07/20/18 16:59:12.915159 zms[18510].ERR-zm_signal.cpp/102 [Backtrace 7: /usr/libexec/zoneminder/cgi-bin/nph-zms(_start+0x2a) [0x55a39c884b6a]]
07/20/18 16:59:12.915816 zms[18510].INF-zm_signal.cpp/109 [Backtrace complete, please execute the following command for more information]
07/20/18 16:59:12.915825 zms[18510].INF-zm_signal.cpp/110 [addr2line -e /usr/libexec/zoneminder/cgi-bin/nph-zms 0x55a39c90b338 0x7fa2229c0120 0x7fa21f4ae6f0 0x55a39c8c2c87 0x55a39c90dc50 0x55a39c883d12 0x7fa21f493faa 0x55a39c884b6a]


Running "addr2line -e /usr/libexec/zoneminder/cgi-bin/nph-zms 0x55a39c90b338 0x7fa2229c0120 0x7fa21f4ae6f0 0x55a39c8c2c87 0x55a39c90dc50 0x55a39c883d12 0x7fa21f493faa 0x55a39c884b6a" results in:
Code:

addr2line -e /usr/libexec/zoneminder/cgi-bin/nph-zms 0x562ea60f7338 0x7feea4274120 0x7feea0d626f0 0x562ea60aec87 0x562ea60f9c50 0x562ea606fd12 0x7feea0d47faa 0x562ea6070b6a
??:0
??:0
??:0
??:0
??:0
??:0
??:0
??:0


I don't have any idea anymore. :(
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12937

PostPosted: Sat Jul 21, 2018 5:25 pm    Post subject: Reply with quote

You need to rebuild zoneminder (and possibly other involved packages) with debug symbols before you can use addr2line in a useful way. Generally, this means setting FEATURES=nostrip and adding -ggdb to your CFLAGS and CXXFLAGS for these packages. Once you have made these changes, reproduce the crash and try to extract a backtrace from the core file. If you need more detail about how to do any of these steps, post back.
Back to top
View user's profile Send private message
WintermuteX
n00b
n00b


Joined: 29 Apr 2006
Posts: 40
Location: Germany

PostPosted: Sat Jul 21, 2018 9:22 pm    Post subject: Reply with quote

Hu wrote:
You need to rebuild zoneminder (and possibly other involved packages) with debug symbols before you can use addr2line in a useful way. Generally, this means setting FEATURES=nostrip and adding -ggdb to your CFLAGS and CXXFLAGS for these packages. Once you have made these changes, reproduce the crash and try to extract a backtrace from the core file. If you need more detail about how to do any of these steps, post back.


Thank you, I will rebuild the packages with nostrip and -ggdb tomorrow!
Back to top
View user's profile Send private message
WintermuteX
n00b
n00b


Joined: 29 Apr 2006
Posts: 40
Location: Germany

PostPosted: Sun Jul 22, 2018 4:30 pm    Post subject: Reply with quote

I rebuild zoneminder with --emptytree and nostrip aswell as -ggdb, but my output is still:

Code:
addr2line -e /usr/libexec/zoneminder/cgi-bin/zms 0x55b140d25338 0x7f4e9e15a120 0x7f4e9ac486f0 0x55b140cdcc87 0x55b140d27c50 0x55b140c9dd12 0x7f4e9ac2dfaa 0x55b140c9eb6a
??:0
??:0
??:0
??:0
??:0
??:0
??:0
??:0


My settings in make.conf:

Code:
CFLAGS="-march=native -ggdb -ftree-vectorize -mxsavec -mxsaves -O2 -pipe"
CXXFLAGS="${CFLAGS}"
FEATURES="ccache nostrip"



Any other idea? :(
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12937

PostPosted: Sun Jul 22, 2018 6:05 pm    Post subject: Reply with quote

What is the output of file /usr/libexec/zoneminder/cgi-bin/zms?
Back to top
View user's profile Send private message
WintermuteX
n00b
n00b


Joined: 29 Apr 2006
Posts: 40
Location: Germany

PostPosted: Mon Jul 23, 2018 7:15 am    Post subject: Reply with quote

Hu wrote:
What is the output of file /usr/libexec/zoneminder/cgi-bin/zms?


In the console: nothing.
It is the streaming server component of Zoneminder: http://zoneminder.readthedocs.io/en/stable/userguide/components.html
The nph-zms version and the zms version show identical behaviour.
Back to top
View user's profile Send private message
WintermuteX
n00b
n00b


Joined: 29 Apr 2006
Posts: 40
Location: Germany

PostPosted: Mon Jul 23, 2018 9:27 am    Post subject: Reply with quote

I reverified that downgrading to mariadb-10.1.31-r1 solves the issue. If I have to take a wild guess, then the change from USE-Flag "client-libs" to "(-client-libs)" and therefore emerging dev-db/mysql-connector-c is somehow the culprit.
Did someone stumble upon a similar incompatibility and solved it?
Back to top
View user's profile Send private message
WintermuteX
n00b
n00b


Joined: 29 Apr 2006
Posts: 40
Location: Germany

PostPosted: Mon Jul 23, 2018 9:49 am    Post subject: Reply with quote

I am trying to get mariadb-connector-c up and running as replacement for mysql-connector-c, but this is tricky:

First I have to install the new mariadb with "--nodeps" as it will enforce dev-db/mysql-connector-c:
Code:
# emerge -pv mariadb

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-db/mysql-connector-c-6.1.11-r1:0/18::gentoo  USE="ssl -libressl -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] dev-db/mariadb-10.1.34:0/18::gentoo [10.1.31-r1:0/18::gentoo] USE="backup cracklib innodb-lz4 innodb-lzo innodb-snappy pam perl server tcmalloc -bindist (-client-libs) -debug -extraengine -galera -jdbc -jemalloc -kerberos -latin1 -libressl (-mroonga) -numa -odbc -oqgraph -profiling (-selinux) -sphinx -sst-mariabackup -sst-rsync -sst-xtrabackup -static -static-libs -systemd -systemtap {-test} -tokudb -xml -yassl (-embedded%) (-openssl%*)" ABI_X86="(64) -32 (-x32)" 0 KiB
[blocks b      ] dev-db/mariadb[client-libs(+)] ("dev-db/mariadb[client-libs(+)]" is blocking dev-db/mysql-connector-c-6.1.11-r1)

Total: 2 packages (1 upgrade, 1 new), Size of downloads: 0 KiB
Conflict: 1 block



I think I will need the mysqlcompat USE:
Code:
[ebuild   R   ~] dev-db/mariadb-connector-c-3.0.4:0/3::gentoo  USE="curl mysqlcompat* ssl -gnutls -kerberos -libressl -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB


But this will end up with a symlink blockage:
Code:
# emerge -qv mariadb-connector-c
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) dev-db/mariadb-connector-c-3.0.4::gentoo
>>> Installing (1 of 1) dev-db/mariadb-connector-c-3.0.4::gentoo
>>> Jobs: 1 of 1 complete                           Load avg: 1.60, 1.28, 1.04

 * Messages for package dev-db/mariadb-connector-c-3.0.4:

 *
 * Installation of a symlink is blocked by a directory:
 *   '/usr/include/mysql'
 * This symlink will be merged with a different name:
 *   '/usr/include/mysql.backup.0000'
 *

!!! existing preserved libs found


So, how to solve this mess? :)
Back to top
View user's profile Send private message
Raffi
l33t
l33t


Joined: 17 Mar 2003
Posts: 728
Location: Moscow, Id.

PostPosted: Mon Jul 23, 2018 4:52 pm    Post subject: Reply with quote

The same issue hit me on a couple of my zoneminder machines. I'm in the process of downgrading mariadb on one of them to bring my cameras back online. The other is available to try things out on until this gets figured out.

Is there anything you'd like me to try on that second machine?
Back to top
View user's profile Send private message
Raffi
l33t
l33t


Joined: 17 Mar 2003
Posts: 728
Location: Moscow, Id.

PostPosted: Mon Jul 23, 2018 6:15 pm    Post subject: Reply with quote

Doing the following stopped the segfault.

Code:

revdep-rebuild --library libmysqlclient.so.18


I missed the notice from the package mariadb-connector-c that said this was necessary.
Back to top
View user's profile Send private message
WintermuteX
n00b
n00b


Joined: 29 Apr 2006
Posts: 40
Location: Germany

PostPosted: Mon Jul 23, 2018 10:15 pm    Post subject: Reply with quote

Raffi wrote:
Doing the following stopped the segfault.

Code:

revdep-rebuild --library libmysqlclient.so.18


I missed the notice from the package mariadb-connector-c that said this was necessary.


Great! I will try this tomorrow! :) Thank you for sharing the information.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12937

PostPosted: Tue Jul 24, 2018 12:31 am    Post subject: Reply with quote

WintermuteX wrote:
Hu wrote:
What is the output of file /usr/libexec/zoneminder/cgi-bin/zms?


In the console: nothing.
It is the streaming server component of Zoneminder: http://zoneminder.readthedocs.io/en/stable/userguide/components.html
The nph-zms version and the zms version show identical behaviour.
Its purpose does not matter here. You can use file on any program, even those that cannot be run due to missing dependencies. Since you described its purpose and said there is no output, but that is not what file would do here, I think you misunderstood my post. What is the output of typing file /usr/libexec/zoneminder/cgi-bin/zms into your shell, then pressing enter?
Back to top
View user's profile Send private message
Raffi
l33t
l33t


Joined: 17 Mar 2003
Posts: 728
Location: Moscow, Id.

PostPosted: Tue Jul 24, 2018 1:23 am    Post subject: Reply with quote

Turns out that the revdep-rebuild just moved the segfault to a different program. Now zmc is segfaulting...

Still looking into it.
Back to top
View user's profile Send private message
WintermuteX
n00b
n00b


Joined: 29 Apr 2006
Posts: 40
Location: Germany

PostPosted: Tue Jul 24, 2018 5:17 am    Post subject: Reply with quote

Hu wrote:
WintermuteX wrote:
Hu wrote:
What is the output of file /usr/libexec/zoneminder/cgi-bin/zms?


In the console: nothing.
It is the streaming server component of Zoneminder: http://zoneminder.readthedocs.io/en/stable/userguide/components.html
The nph-zms version and the zms version show identical behaviour.
Its purpose does not matter here. You can use file on any program, even those that cannot be run due to missing dependencies. Since you described its purpose and said there is no output, but that is not what file would do here, I think you misunderstood my post. What is the output of typing file /usr/libexec/zoneminder/cgi-bin/zms into your shell, then pressing enter?


Oh, sorry, I didn't get the bold part of your post correct and interpreted it as running the file itself in the shell.
At the moment I ran the command it was linked against the downgraded mariadb:

Code:
/usr/libexec/zoneminder/cgi-bin/zms: ELF 64-bit LSB pie executable x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 3.2.0, stripped
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12937

PostPosted: Wed Jul 25, 2018 2:13 am    Post subject: Reply with quote

According to that output, the file is still stripped, so poor debugging results are normal. It is possible that this package incorrectly strips its own files instead of delegating that to the package manager. I don't see any open bugs to that effect, though. What is the output of head /var/db/pkg/www-misc/zoneminder*/{FEATURES,CFLAGS,CXXFLAGS}?
Back to top
View user's profile Send private message
WintermuteX
n00b
n00b


Joined: 29 Apr 2006
Posts: 40
Location: Germany

PostPosted: Wed Jul 25, 2018 7:27 am    Post subject: Reply with quote

Hu wrote:
According to that output, the file is still stripped, so poor debugging results are normal. It is possible that this package incorrectly strips its own files instead of delegating that to the package manager. I don't see any open bugs to that effect, though. What is the output of head /var/db/pkg/www-misc/zoneminder*/{FEATURES,CFLAGS,CXXFLAGS}?


I reverted back to my old settings and the old mariadb to get my camerasystem running for the meantime. I emerged zoneminder and dependencies again with the debug settings, but still the old mariadb to keep zoneminder working:

Code:
# head /var/db/pkg/www-misc/zoneminder*/{FEATURES,CFLAGS,CXXFLAGS}
==> /var/db/pkg/www-misc/zoneminder-1.30.4/FEATURES <==
assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news nostrip parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr

==> /var/db/pkg/www-misc/zoneminder-1.30.4/CFLAGS <==
-march=native -ggdb -ftree-vectorize -mxsavec -mxsaves -O2 -pipe

==> /var/db/pkg/www-misc/zoneminder-1.30.4/CXXFLAGS <==
-march=native -ggdb -ftree-vectorize -mxsavec -mxsaves -O2 -pipe -D__STDC_CONSTANT_MACROS


Code:
/usr/libexec/zoneminder/cgi-bin/zms: ELF 64-bit LSB pie executable x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 3.2.0, with debug_info, not stripped


Besides I used the new mariadb back then it is the same setting I ran when addr2line gave empty results the second time.
Back to top
View user's profile Send private message
zark
n00b
n00b


Joined: 27 Mar 2004
Posts: 73
Location: Belgium

PostPosted: Fri Jul 27, 2018 1:43 pm    Post subject: Reply with quote

Heya, i've pretty much had the same issue.

It's more general than a zoneminder problem. I've started a more general thread about the problem here : https://forums.gentoo.org/viewtopic-t-1084478-start-0.html
Back to top
View user's profile Send private message
WintermuteX
n00b
n00b


Joined: 29 Apr 2006
Posts: 40
Location: Germany

PostPosted: Fri Jul 27, 2018 2:13 pm    Post subject: Reply with quote

zark wrote:
Heya, i've pretty much had the same issue.

It's more general than a zoneminder problem. I've started a more general thread about the problem here : https://forums.gentoo.org/viewtopic-t-1084478-start-0.html


Thank you for the heads up and for the information about libcrypto.so.
I also downgraded for now to get a working system.
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1462
Location: San Jose, CA

PostPosted: Sun Jul 29, 2018 5:12 am    Post subject: Reply with quote

I'm having this problem too.

Has the zoneminder team been notified?

I masked off .34 or mariadb and am re-emerging .31-r1...
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
WintermuteX
n00b
n00b


Joined: 29 Apr 2006
Posts: 40
Location: Germany

PostPosted: Wed Aug 01, 2018 6:29 am    Post subject: Reply with quote

RayDude wrote:
I'm having this problem too.

Has the zoneminder team been notified?

I masked off .34 or mariadb and am re-emerging .31-r1...


No, they haven't been notified by me at least. But I'm not sure if this is a problem with the zoneminder package or the mariadb package. More likely the latest changes to the mariadb package are the culprit and it seems to destabilize other packages.
Back to top
View user's profile Send private message
Raffi
l33t
l33t


Joined: 17 Mar 2003
Posts: 728
Location: Moscow, Id.

PostPosted: Tue Sep 18, 2018 11:14 pm    Post subject: Reply with quote

Today, my system wanted to downgrade to dev-db/mariadb-10.0.35-r2 so I went ahead and tried. Unfortunately, this also breaks zoneminder.

In fact, it looks like the working version is no longer available. Guess I will be doing some experimenting...
Back to top
View user's profile Send private message
WintermuteX
n00b
n00b


Joined: 29 Apr 2006
Posts: 40
Location: Germany

PostPosted: Wed Sep 19, 2018 3:15 am    Post subject: Reply with quote

Raffi wrote:
Today, my system wanted to downgrade to dev-db/mariadb-10.0.35-r2 so I went ahead and tried. Unfortunately, this also breaks zoneminder.

In fact, it looks like the working version is no longer available. Guess I will be doing some experimenting...


If you find any working solution, please share it. :) I really need zoneminder and masking the update isn't a solution ...
Back to top
View user's profile Send private message
Raffi
l33t
l33t


Joined: 17 Mar 2003
Posts: 728
Location: Moscow, Id.

PostPosted: Wed Sep 19, 2018 12:42 pm    Post subject: Reply with quote

It looks like mariadb-connector-c-3.0.6 will work with zoneminder. While I do have that installed now and things are working, I now have some blocks that I'm trying to get to the bottom of. It looks like virtual/libmysqlclient does not accept mariadb-connector-c as one of the ways to resolve the libraries.

I'll continue to play around to see if I can make my system happy again.
Back to top
View user's profile Send private message
Raffi
l33t
l33t


Joined: 17 Mar 2003
Posts: 728
Location: Moscow, Id.

PostPosted: Thu Sep 20, 2018 9:44 pm    Post subject: Reply with quote

It is possible to get zoneminder working with the latest mariadb, but you will not have a "normal" system when you are done.

To get all the blocks resolved, everything compiled and not segfaulting, I had to do the following

emerge -C virtual/libmysqlclient

I then had to modify the ebuild for dev-db/mariadb to allow it to depend on mariadb-connector-c[mysqlcomap]. I then had to modify dev-perl/DBD-mysql to do the same. DBD-mysql also needed a patch to properly compaile against mariadb-connector-c.

Looks like portage is really not yet ready to have mariadb-connector-c replace mysql-connector-c without quite a bit of work.
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1462
Location: San Jose, CA

PostPosted: Sat Sep 22, 2018 10:59 pm    Post subject: Reply with quote

So mariadb just forced an upgrade...

My zoneminder is toast.

zoneminder runs for me at the moment, but zmc constantly seg faults...

Code:
Sep 22 13:13:28 server kernel: traps: zmc[13082] general protection ip:7f09d397e6d5 sp:7ffec99c5200 error:0 in libc-2.26.so[7f09d3943000+1b9000]
Sep 22 13:13:28 server kernel: traps: zmc[13088] general protection ip:7f422403b6d5 sp:7fff58e8c230 error:0 in libc-2.26.so[7f4224000000+1b9000]


I found a thread on the zoneminder forums when I searched for my libc error message and it seems like the next zoneminder version might have the libc problem fixed.

Man, the old code bases are not able to keep up with the changes in linux these days.

I'm speaking specifically of mythtv and zoneminder because they are the thorns in my side.
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum