Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Unable to emerge binary packages
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
mimosinnet
l33t
l33t


Joined: 10 Aug 2006
Posts: 655
Location: Barcelona, Spain

PostPosted: Mon Jul 16, 2018 6:10 am    Post subject: [solved] Unable to emerge binary packages Reply with quote

This message appears when emerging binary packages:

Code:
emerge -1G dev-lang/python-exec
                                                                                                                                                                                             
 * IMPORTANT: 16 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!                                                                                                                                                           
                                                                                                                                                                                             
>>> Emerging binary (1 of 1) dev-lang/python-exec-2.4.5::gentoo
 * python-exec-2.4.5.tbz2 MD5 SHA1 size ;-) ...                          [ ok ]                                                                                                             
[Errno 7] Argument list too long: b'/bin/bash':                                                                                                                                             
   /bin/bash -c /usr/lib/portage/python3.5/ebuild.sh clean
Traceback (most recent call last):
  File "/usr/lib64/python3.5/site-packages/portage/process.py", line 347, in spawn
    unshare_net, unshare_ipc, cgroup)
  File "/usr/lib64/python3.5/site-packages/portage/process.py", line 555, in _exec
    os.execve(binary, myargs, env)
  File "/usr/lib64/python3.5/site-packages/portage/__init__.py", line 250, in __call__
    rval = self._func(*wrapped_args, **wrapped_kwargs)
OSError: [Errno 7] Argument list too long: b'/bin/bash'                                                                                                                                     
[Errno 7] Argument list too long: b'/usr/bin/sandbox':                                                                                                                                       
   /usr/bin/sandbox /usr/lib/portage/python3.5/misc-functions.sh die_hooks
Traceback (most recent call last):
  File "/usr/lib64/python3.5/site-packages/portage/process.py", line 347, in spawn
    unshare_net, unshare_ipc, cgroup)
  File "/usr/lib64/python3.5/site-packages/portage/process.py", line 555, in _exec
    os.execve(binary, myargs, env)
  File "/usr/lib64/python3.5/site-packages/portage/__init__.py", line 250, in __call__
    rval = self._func(*wrapped_args, **wrapped_kwargs)
OSError: [Errno 7] Argument list too long: b'/usr/bin/sandbox'


The same package installs as a normal package. I have been using a binhost for some years to update the system, and this is the first time I have seen this error. I have found this post on the forums with the same error message. Nevertheless, it does not seem to apply to this case. Any hints appreciated.

Update: Binary packages emerge after installing "=sys-apps/portage-2.3.24-r1" :O

Thanks!
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved.
Take care of the community answering unanswered posts.


Last edited by mimosinnet on Mon Jul 16, 2018 10:46 am; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3493
Location: Germany

PostPosted: Mon Jul 16, 2018 9:37 am    Post subject: Unable to emerge binary packages Reply with quote

Hi,
this is probably Bug 657422
Please try the Patch from Comment 8 with current stable =sys-apps/portage-2.3.40-r1
Back to top
View user's profile Send private message
mimosinnet
l33t
l33t


Joined: 10 Aug 2006
Posts: 655
Location: Barcelona, Spain

PostPosted: Mon Jul 16, 2018 10:46 am    Post subject: Re: Unable to emerge binary packages Reply with quote

Josef.95 wrote:
Hi,
this is probably Bug 657422
Please try the Patch from Comment 8 with current stable =sys-apps/portage-2.3.40-r1


Many thanks for the hint! :D

I have followed this gentoo guide to apply the patch. Basically:

mkdir -p /etc/portage/patches/sys-apps/portage-2.3.40-r1

Save this patch in the directory (as, for example, portage.patch):
Code:
 pym/portage/dbapi/bintree.py | 4 +++-                                                                                                                                                       
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/pym/portage/dbapi/bintree.py b/pym/portage/dbapi/bintree.py
index 269a7b226..9c2d877e7 100644
--- a/pym/portage/dbapi/bintree.py
+++ b/pym/portage/dbapi/bintree.py
@@ -1320,7 +1320,9 @@ class binarytree(object):
                for k, v in iter_iuse_vars(src):
                        v_before = dest.get(k)
                        if v_before is not None:
-                               v = v_before + ' ' + v
+                               merged_values = set(v_before.split())
+                               merged_values.update(v.split())
+                               v = ' '.join(sorted(merged_values))
                        dest[k] = v
 
                if 'ARCH' not in dest and 'ARCH' in src:


Cheers!
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved.
Take care of the community answering unanswered posts.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum