Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde-plasma/plasma-meta-5.12.49.9999.ebuild error in update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
genterminl
Guru
Guru


Joined: 12 Feb 2005
Posts: 478
Location: Connecticut, USA

PostPosted: Sun Jul 15, 2018 5:30 pm    Post subject: kde-plasma/plasma-meta-5.12.49.9999.ebuild error in update Reply with quote

The past few times I have run eix-sync (or just eix-update) I have gotten this error:
Code:
* ERROR: kde-plasma/plasma-meta-5.12.49.9999::kde failed (depend phase):
 *   External commands disallowed while sourcing ebuild: ver_cut 1-3
 *
 * Call stack:
 *                         ebuild.sh, line 635:  Called source '/var/lib/layman/kde/kde-plasma/plasma-meta/plasma-meta-5.12.49.9999.ebuild'
 *   plasma-meta-5.12.49.9999.ebuild, line  74:  Called add_plasma_dep 'breeze'
 *             kde5-functions.eclass, line 202:  Called command_not_found_handle 'ver_cut' '1-3'
 *                         ebuild.sh, line  88:  Called die
 * The specific snippet of code:
 *              die "External commands disallowed while sourcing ebuild: ${*}"
 *
 * If you need support, post the output of `emerge --info '=kde-plasma/plasma-meta-5.12.49.9999::kde'`,
 * the complete build log and the output of `emerge -pqv '=kde-plasma/plasma-meta-5.12.49.9999::kde'`.
 * Working directory: '/usr/lib64/python3.6/site-packages'
 * S: '/plasma-meta-5.12.49.9999'

ebuild failed with status 1
Note that although I do run KDE, it is with selective ebuilds installed - I do not have plasma-meta installed. This error is not causing me any other problems, but I couldn't find any other reference to it. Is it perhaps some EAPI incconsistency in the ebuild?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19227
Location: here

PostPosted: Sun Jul 15, 2018 5:36 pm    Post subject: Reply with quote

Why you use version 5.12.49.9999 when in official portage tree there is 5.13.3?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
genterminl
Guru
Guru


Joined: 12 Feb 2005
Posts: 478
Location: Connecticut, USA

PostPosted: Sun Jul 15, 2018 6:00 pm    Post subject: Reply with quote

Please read what I wrote. I am NOT using that version, in fact I do not have plasma-meta installed at all. This error happens when I do eix-update. I am NOT trying to install plasma-meta. Also, 5.13.3 is still marked testing, but that doesn't matter to me.

Maybe the right answer is just for the KDE team to remove this version from their overlay.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 12612

PostPosted: Sun Jul 15, 2018 6:04 pm    Post subject: Re: kde-plasma/plasma-meta-5.12.49.9999.ebuild error in upda Reply with quote

genterminl wrote:
Is it perhaps some EAPI incconsistency in the ebuild?
The ebuild is just wrong. It is trying to call ver_cut, which is not found. That ebuild should be modified to remove the call or the ebuild should be removed.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6376
Location: Austria

PostPosted: Sun Jul 15, 2018 6:06 pm    Post subject: Reply with quote

Hu, check EAPI version of this ebuild and then get a read: https://dev.gentoo.org/~mgorny/articles/the-ultimate-guide-to-eapi-7.html#obtaining-version-substring-ver-cut
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2970
Location: Dallas area

PostPosted: Sun Jul 15, 2018 6:10 pm    Post subject: Re: kde-plasma/plasma-meta-5.12.49.9999.ebuild error in upda Reply with quote

genterminl wrote:
This error is not causing me any other problems, but I couldn't find any other reference to it. Is it perhaps some EAPI incconsistency in the ebuild?


It's an FYI, basically telling you the ebuild is not consistent, ie missing something in the chain.
Shouldn't affect your system, well unless you're trying to install that particular ebuild.

I would do a layman sync first to see if it resolves the problem, if not, as Hu said, just remove that ebuild.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
4.14.62 kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 4.9.4 & 7.3.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6376
Location: Austria

PostPosted: Sun Jul 15, 2018 6:49 pm    Post subject: Reply with quote

Both ebuild as well as repoman run well with this ebuild. Finally, the overlay CI (which is green) would cry foul minutes after a commit introducing such an error, so I don't really know what to make of this.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
genterminl
Guru
Guru


Joined: 12 Feb 2005
Posts: 478
Location: Connecticut, USA

PostPosted: Sun Jul 15, 2018 11:36 pm    Post subject: Reply with quote

Well, now I'm stumped too. Per Comment 10, I tried running ebuild against that ebuild, and no errors. I then tried eix-update, and no errors. I've now run another eix-sync, and no errors. I tried as both a regular user and root, with no differences.

I did see that error at least two or three times, so I'll just have to chalk it up to what I call "phase of the moon" as I don't see evidence that anything has changed since the last time I got the error.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum