Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Clamd takes 55s loading signatures
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Goverp
l33t
l33t


Joined: 07 Mar 2007
Posts: 639

PostPosted: Mon Jul 09, 2018 9:12 pm    Post subject: Clamd takes 55s loading signatures Reply with quote

My apologies if this is the wrong forum - I don't know if clamav performance counts as security.

Is my experience - that clamd takes an age to start - typical?

It's standard Gentoo setup, (OpenRc, 4-cpu AMD box running at 1.6 GHz, 6 Gb RAM, files on 4 disk RAID 5 array) showing no performance issues in general. But during startup, I get messages about waiting for clamd to start, and it times out. Looking at /var/log/clamav/clamd.log, it takes about 55 seconds to load 6568420 signatures, which seems pretty damn slow.

I can find nothing on the web, apart from some old bugs in 2007, and nothing in clamav's bugzilla.

FWIW,
app-antivirus/clamav-0.99.4-r1
USE="bzip2 iconv ipv6 -clamdtop -libressl -metadata-analysis-api -milter (-selinux) -static-libs {-test} (-uclibc)"

Perhaps there are faster alternatives.
_________________
Greybeard
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5801

PostPosted: Mon Jul 09, 2018 10:20 pm    Post subject: Reply with quote

This is from an i7 920 but confined to a single cpu.

Code:
Mon Jul  9 17:48:10 2018 -> Reading databases from /var/lib/clamav
Mon Jul  9 17:48:34 2018 -> Database correctly reloaded (6568737 signatures)


If I had to guess, your single thread speed is making it slow.
_________________
overlay | patches
Neddyseagoon wrote:
The problem with leaving is that you can only do it once and it reduces your influence.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1631
Location: United Kingdom

PostPosted: Mon Jul 09, 2018 10:43 pm    Post subject: Reply with quote

For comparison, my laptop with Intel Core i7-4810MQ (2.80GHz) 6MB and 16 GB RAM takes around 11 seconds to load the ClamAV DB:

Code:
Mon Jul  9 19:36:24 2018 -> Reading databases from /var/lib/clamav
Mon Jul  9 19:36:35 2018 -> Database correctly reloaded (6568420 signatures)

Code:
$ eix -I clamav
[I] app-antivirus/clamav
     Available versions:  0.99.4-r1 ~0.100.0 {bzip2 clamdtop doc iconv ipv6 libressl metadata-analysis-api milter selinux static-libs system-libmspack test uclibc}
     Installed versions:  0.99.4-r1(02:05:45 03/04/18)(bzip2 clamdtop iconv ipv6 -libressl -metadata-analysis-api -milter -selinux -static-libs -test -uclibc)
     Homepage:            https://www.clamav.net/
     Description:         Clam Anti-Virus Scanner

_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Goverp
l33t
l33t


Joined: 07 Mar 2007
Posts: 639

PostPosted: Thu Jul 12, 2018 4:22 pm    Post subject: Reply with quote

Thanks for the numbers. From that it looks like I just ignore it; certainly not worth upgrading my system just for clamav! I think it's only ever flagged up false-positive hits for PUAs ("Possibly Unwanted Applications").
_________________
Greybeard
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum