Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problemi installazione qutebrowser [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Tue Jul 03, 2018 7:44 pm    Post subject: problemi installazione qutebrowser [RISOLTO] Reply with quote

Salve a tutti , dopo aver (inserito come da richiesta di portage)

Code:
dev-python/PyQt5 gui declarative network printsupport sql webengine widgets


nel pakage.use mi ritrovo con questo errore :evil:

Code:
Burrows /home/marco # emerge qutebrowser
Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=dev-python/PyQt5-5.7.1[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python3_5(-),-python_single_target_python3_6(-),declarative,gui,network,opengl,printsupport,sql,webengine,widgets]" has unmet requirements.
- dev-python/PyQt5-5.10.1-r1::gentoo USE="bluetooth dbus declarative gui network opengl printsupport sql svg webengine widgets -debug -designer -examples -gles2 -help -location -multimedia -positioning -sensors -serialport -testlib -webchannel -webkit -websockets -x11extras -xmlpatterns" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6"

  The following REQUIRED_USE flag constraints are unsatisfied:
    webengine? ( widgets? ( webchannel ) )

  The above constraints are a subset of the following complete expression:
    any-of ( python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6 ) bluetooth? ( gui ) declarative? ( gui network ) designer? ( widgets ) help? ( gui widgets ) location? ( positioning ) multimedia? ( gui network ) opengl? ( gui widgets ) positioning? ( gui ) printsupport? ( gui widgets ) sensors? ( gui ) serialport? ( gui ) sql? ( widgets ) svg? ( gui widgets ) testlib? ( widgets ) webchannel? ( network ) webengine? ( network widgets? ( printsupport webchannel ) ) webkit? ( gui network printsupport widgets ) websockets? ( network ) widgets? ( gui ) xmlpatterns? ( network )

(dependency required by "www-client/qutebrowser-1.3.3::gentoo" [ebuild])
(dependency required by "qutebrowser" [argument])


sapete darmi una mano ??


Last edited by drudox on Tue Jul 03, 2018 7:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21360
Location: here

PostPosted: Tue Jul 03, 2018 7:48 pm    Post subject: Reply with quote

Ti manca da aggiungere webchannel alle use flag di dev-python/PyQt5
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Tue Jul 03, 2018 7:53 pm    Post subject: Reply with quote

sei sempre geniale ;) grazie
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Sat Jan 19, 2019 9:19 am    Post subject: Reply with quote

posso chiedere come fare a capire che debba aggiungere webchannel ? dato che da questa scritta :

Code:
 The following REQUIRED_USE flag constraints are unsatisfied:
    webengine? ( widgets? ( webchannel ) )


webengine ha punto interrogativo e poi dopo le parentesi widgest ha nuovamente punto interrogativo ..
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 671

PostPosted: Sat Jan 19, 2019 10:46 am    Post subject: Reply with quote

dal confronto visivo delle flags abilitate e quelle disabilitate

Quote:
USE="bluetooth dbus declarative gui network opengl printsupport sql svg webengine widgets -debug -designer -examples -gles2 -help -location -multimedia -positioning -sensors -serialport -testlib -webchannel -webkit -websockets -x11extras -xmlpatterns"


Portage ti mette a conoscenza delle USE necessarie (in questo caso sono a cascata , cioà l'una dipende dall'altra)

Quote:
The following REQUIRED_USE flag constraints are unsatisfied:
webengine? ( widgets? ( webchannel ) )



L'unica che manca è proprio webchannel
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21360
Location: here

PostPosted: Sat Jan 19, 2019 11:49 am    Post subject: Reply with quote

Il simbolo punto di domanda lo leggi come un 'se' e le paraentesi come 'allora', esiste anche il punto esclamativo che e' la negazione.
Quindi
Quote:
webengine? ( widgets? ( webchannel ) )
se hai webengine e se hai widgets allora devi avere webchannel

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Sun Jan 20, 2019 6:35 pm    Post subject: Reply with quote

e come faccio a sapere se ho webengine e widgets ??
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Sun Jan 20, 2019 7:04 pm    Post subject: Reply with quote

ad esempio in questo caso :

Code:
!!! The ebuild selected to satisfy ">=gnome-base/gnome-settings-daemon-3.8" has unmet requirements.
- gnome-base/gnome-settings-daemon-3.26.2-r1::gentoo USE="colord cups policykit udev -debug -elogind -networkmanager -smartcard -systemd (-test) -wayland" ABI_X86="(64)" INPUT_DEVICES="-wacom"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( elogind systemd )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( elogind systemd ) input_devices_wacom? ( udev ) smartcard? ( udev ) wayland? ( udev )

(dependency required by "sys-apps/gnome-disk-utility-3.30.2::gentoo[gnome]" [ebuild])
(dependency required by "mate-base/mate-1.18::gentoo[extras]" [ebuild])
(dependency required by "mate" [argument])


come si legge ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21360
Location: here

PostPosted: Mon Jan 21, 2019 6:59 am    Post subject: Reply with quote

Questo e' molto piu' esplicativa dell'altro perche' ti dice exactly-one-of (esattamente-uno-di).
Quindi lo leggi esattamente-uno-di elogind o systemd, tutte e due abilitati o disabilitati non e' possibile
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 671

PostPosted: Mon Jan 21, 2019 8:38 am    Post subject: Reply with quote

drudox wrote:
e come faccio a sapere se ho webengine e widgets ??

dall'output mostrato , te l'ho anche scritto , ti mostra le USE già abilitate

Quote:
!! The ebuild selected to satisfy ">=dev-python/PyQt5-5.7.1[python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python3_5(-),-python_single_target_python3_6(-),declarative,gui,network,opengl,printsupport,sql,webengine,widgets]" has unmet requirements.
- dev-python/PyQt5-5.10.1-r1::gentoo USE="bluetooth dbus declarative gui network opengl printsupport sql svg webengine widgets -debug -designer -examples -gles2 -help -location -multimedia -positioning -sensors -serialport -testlib -webchannel -webkit -websockets -x11extras -xmlpatterns" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6"


e via discorrendo
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Mon Jan 21, 2019 3:29 pm    Post subject: Reply with quote

ah scusami non avevo letto !! perfetto grazie!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum