Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg freeze on laptop. pls help
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
yagaev
n00b
n00b


Joined: 10 Jan 2017
Posts: 22

PostPosted: Sat Jun 30, 2018 5:33 am    Post subject: xorg freeze on laptop. pls help Reply with quote

X freezes on start without xorg.conf. Built with INPUT_DEVICES="synaptics libinput"
Code:

[     5.553] (II) LoadModule: "libinput"
[     5.553] (WW) Warning, couldn't open module libinput
[     5.553] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.553] (EE) No input driver matching `libinput'
[     5.553] (II) Falling back to input driver `libinput'
[     5.553] (II) LoadModule: "libinput"
[     5.553] (WW) Warning, couldn't open module libinput
[     5.553] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.554] (II) config/udev: Adding input device Video Bus (/dev/input/event5)
[     5.554] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[     5.554] (**) Video Bus: Applying InputClass "Keyboard0"
[     5.554] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[     5.554] (II) LoadModule: "libinput"
[     5.554] (WW) Warning, couldn't open module libinput
[     5.554] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.554] (EE) No input driver matching `libinput'
[     5.554] (II) Falling back to input driver `libinput'
[     5.554] (II) LoadModule: "libinput"
[     5.554] (WW) Warning, couldn't open module libinput
[     5.554] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.554] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[     5.554] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[     5.554] (**) Power Button: Applying InputClass "Keyboard0"
[     5.554] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[     5.554] (II) LoadModule: "libinput"
[     5.554] (WW) Warning, couldn't open module libinput
[     5.554] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.554] (EE) No input driver matching `libinput'
[     5.554] (II) Falling back to input driver `libinput'
[     5.554] (II) LoadModule: "libinput"
[     5.555] (WW) Warning, couldn't open module libinput
[     5.555] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.555] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
[     5.555] (II) No input driver specified, ignoring this device.
[     5.555] (II) This device may have been added with another device file.
[     5.555] (II) config/udev: Adding input device Sleep Button (/dev/input/event2)
[     5.555] (**) Sleep Button: Applying InputClass "libinput keyboard catchall"
[     5.555] (**) Sleep Button: Applying InputClass "Keyboard0"
[     5.555] (**) Sleep Button: Applying InputClass "libinput keyboard catchall"
[     5.555] (II) LoadModule: "libinput"
[     5.555] (WW) Warning, couldn't open module libinput
[     5.555] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.555] (EE) No input driver matching `libinput'
[     5.555] (II) Falling back to input driver `libinput'
[     5.555] (II) LoadModule: "libinput"
[     5.556] (WW) Warning, couldn't open module libinput
[     5.556] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.556] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[     5.556] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[     5.556] (**) Video Bus: Applying InputClass "Keyboard0"
[     5.556] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[     5.556] (II) LoadModule: "libinput"
[     5.556] (WW) Warning, couldn't open module libinput
[     5.556] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.556] (EE) No input driver matching `libinput'
[     5.556] (II) Falling back to input driver `libinput'
[     5.556] (II) LoadModule: "libinput"
[     5.556] (WW) Warning, couldn't open module libinput
[     5.556] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.557] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event9)
[     5.557] (II) No input driver specified, ignoring this device.
[     5.557] (II) This device may have been added with another device file.
[     5.557] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event7)
[     5.557] (II) No input driver specified, ignoring this device.
[     5.557] (II) This device may have been added with another device file.
[     5.557] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event8)
[     5.557] (II) No input driver specified, ignoring this device.
[     5.557] (II) This device may have been added with another device file.
[     5.557] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event6)
[     5.557] (**) AT Translated Set 2 keyboard: Applying InputClass "libinput keyboard catchall"
[     5.557] (**) AT Translated Set 2 keyboard: Applying InputClass "Keyboard0"
[     5.557] (**) AT Translated Set 2 keyboard: Applying InputClass "libinput keyboard catchall"
[     5.557] (II) LoadModule: "libinput"
[     5.558] (WW) Warning, couldn't open module libinput
[     5.558] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.558] (EE) No input driver matching `libinput'
[     5.558] (II) Falling back to input driver `libinput'
[     5.558] (II) LoadModule: "libinput"
[     5.558] (WW) Warning, couldn't open module libinput
[     5.558] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.558] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event10)
[     5.558] (**) ETPS/2 Elantech Touchpad: Applying InputClass "libinput touchpad catchall"
[     5.558] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
[     5.558] (**) ETPS/2 Elantech Touchpad: Applying InputClass "Default clickpad buttons"
[     5.558] (**) ETPS/2 Elantech Touchpad: Applying InputClass "libinput touchpad catchall"
[     5.558] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
[     5.558] (II) LoadModule: "synaptics"
[     5.558] (WW) Warning, couldn't open module synaptics
[     5.558] (EE) Failed to load module "synaptics" (module does not exist, 0)
[     5.558] (EE) No input driver matching `synaptics'
[     5.558] (II) Falling back to input driver `libinput'
[     5.558] (II) LoadModule: "libinput"
[     5.558] (WW) Warning, couldn't open module libinput
[     5.558] (EE) Failed to load module "libinput" (module does not exist, 0)
[     5.558] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse0)
[     5.559] (**) ETPS/2 Elantech Touchpad: Ignoring device from InputClass "touchpad ignore duplicates"
[     6.016] (II) modeset(0): EDID vendor "LGD", prod id 732
[     6.016] (II) modeset(0): Printing DDC gathered Modelines:
[     6.016] (II) modeset(0): Modeline "1366x768"x0.0   70.00  1366 1402 1450 1492  768 771 776 782 -hsync -vsync (46.9 kHz eP)
[   103.797] (II) Server terminated successfully (0). Closing log file.

Code:

[I] dev-libs/libinput
     Available versions:  1.10.6(0/10)^t 1.10.7(0/10)^t (~)1.11.0(0/10)^t (~)1.11.1(0/10)^t {doc test INPUT_DEVICES="wacom"}
     Installed versions:  1.11.1(0/10)^t(12:00:41 AM 06/28/2018)(-doc -test INPUT_DEVICES="-wacom")
     Homepage:            https://www.freedesktop.org/wiki/Software/libinput/
     Description:         Library to handle input devices in Wayland

[I] x11-drivers/xf86-input-libinput
     Available versions:  0.27.1
     Installed versions:  0.27.1(11:28:58 PM 06/29/2018)
     Homepage:            https://www.x.org/wiki/ https://cgit.freedesktop.org/
     Description:         X.org input driver based on libinput

* x11-misc/libinput-gestures
     Available versions:  (~)2.31 (~)2.34 (~)2.36 **9999 {test PYTHON_SINGLE_TARGET="python3_4 python3_5 python3_6" PYTHON_TARGETS="python3_4 python3_5 python3_6"}
     Homepage:            https://github.com/bulletmark/libinput-gestures
     Description:         Actions gestures on your touchpad using libinput

Found 3 matches
[I] x11-drivers/xf86-input-synaptics
     Available versions:  1.9.0 1.9.1 {KERNEL="linux"}
     Installed versions:  1.9.1(12:51:59 AM 06/29/2018)(KERNEL="linux")
     Homepage:            https://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/
     Description:         Driver for Synaptics touchpads

Code:
lspci
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
   Subsystem: Acer Incorporated [ALI] 2nd Generation Core Processor Family Integrated Graphics Controller
   Kernel driver in use: i915
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 620M/630M/635M/640M LE] (rev a1)
   Subsystem: Acer Incorporated [ALI] GF108M [GeForce GT 620M/630M/635M/640M LE]
   Kernel driver in use: nvidia
   Kernel modules: nvidia_drm, nvidia

----------------
kernel config
emerge --info
Back to top
View user's profile Send private message
yagaev
n00b
n00b


Joined: 10 Jan 2017
Posts: 22

PostPosted: Tue Jul 03, 2018 7:01 pm    Post subject: Reply with quote

Change to evdev, rebuilt xorg-drivers and input drivers. Resolved.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41405
Location: 56N 3W

PostPosted: Tue Jul 03, 2018 7:17 pm    Post subject: Reply with quote

yagaev,

Code:
[     5.553] (II) LoadModule: "libinput"
[     5.553] (WW) Warning, couldn't open module libinput


You were trying to use libinput but its not installed.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
yagaev
n00b
n00b


Joined: 10 Jan 2017
Posts: 22

PostPosted: Tue Jul 03, 2018 7:22 pm    Post subject: Reply with quote

NeddySeagoon wrote:
yagaev,

Code:
[     5.553] (II) LoadModule: "libinput"
[     5.553] (WW) Warning, couldn't open module libinput


You were trying to use libinput but its not installed.

Code:
[I] x11-drivers/xf86-input-libinput
     Available versions:  0.27.1
     Installed versions:  0.27.1(11:28:58 PM 06/29/2018)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum