Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wpa_supplicant PEAP not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Dalinar
n00b
n00b


Joined: 25 Jun 2018
Posts: 6

PostPosted: Mon Jun 25, 2018 5:30 pm    Post subject: wpa_supplicant PEAP not working Reply with quote

Hi, I'm relatively new to Gentoo, set it up on my pc at home but have since moved pc back to collage. Collage WiFi has protected EAP and I am unable to connect through nm or wpa_supplicant. Nm so far as I can tell doesn't recognise PEAP and my WPA conf isn't working. I've been stuck on this for quite a while now and would really appreciate any help, t
Thanks ^.^

Here's my config file (submitting on phone so formatting errors aren't in actual code)
Code:

network={
 ssid="SSID"
 key_mgmt=WPA-EAP
 eap=PEAP
 identity="identity"
 password="password"
}
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Mon Jun 25, 2018 8:04 pm    Post subject: Reply with quote

Dalinar ...

you're missing phases (eg, 'phase2="auth=MSCHAPV2"' if MSCHAPv2 is in use), and you probably also need a ca_cert provided by your IT dept. See the section 'WPA-RADIUS/EAP-PEAP/MSCHAPv2' in 'man wpa_supplicant.conf'. Also, here is an example for 'eduroam':

/etc/wpa_supplicant/wpa_supplicant.conf:
network={
    ssid="eduroam"
    key_mgmt=WPA-EAP
    ca_cert="/etc/eduroam/ca.cer"
    identity="user@your.domain"
    eap=PEAP
    password="test"
    phase2="auth=MSCHAPV2"
}

HTH & best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum