Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Python 3.6 stable hell
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 258
Location: Northern California

PostPosted: Sat Jun 23, 2018 4:44 pm    Post subject: Python 3.6 stable hell Reply with quote

Am I the only one suffering through this python upgrade nightmare on stable?

Carefully read the 2018-05-22-python3-6 news item. Following the news item, I added:
Code:

    PYTHON_TARGETS="python2_7 python3_5 python3_6"
    PYTHON_SINGLE_TARGET="python3_5"


to make.conf, let the upgrade continue, and resolved a number of issues (broken doc USE flags, totally borked sci-libs/scipy, broken elogviewer, etc. etc.).

Finally got portage to finish the upgrade, and then I 'emerge --depclean' the cruft as per the news item.

I then removed the lines above from make.conf, and repeated the process. Portage now rebuilt the system with python3.6. The final 'emerge --depclean' then removed python3.5. All seemed to be well with the world.

That was yesterday. Today, I 'emerge --sync' and now portage has blown up again. It wants to bring python3.5 back and rebuild everything it just finished updating yesterday:

Code:

# emerge -uDNv --with-bdeps=y --quiet-build=y --keep-going=y @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-apps/file-5.33-r2::gentoo  USE="zlib -python -static-libs" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] sys-libs/cracklib-2.9.6-r1::gentoo  USE="nls zlib -python -static-libs" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-libs/boost-1.65.0:0/1.65.0::gentoo  USE="doc icu nls threads -context -debug -mpi -python -static-libs -tools" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-libs/libnl-3.2.28:3::gentoo  USE="-python -static-libs -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_5* -python3_4" 0 KiB
[ebuild   R    ] sys-libs/libcap-ng-0.7.8::gentoo  USE="-python -static-libs" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild  NS    ] dev-lang/python-3.5.5:3.5/3.5m::gentoo [2.7.14-r1:2.7::gentoo, 3.6.5:3.6/3.6m::gentoo] USE="examples gdbm ipv6 ncurses readline sqlite ssl (threads) tk xml -build -hardened -libressl {-test} -wininst" 0 KiB
[ebuild   R    ] dev-libs/gobject-introspection-1.52.1::gentoo  USE="cairo -doctool {-test}" PYTHON_SINGLE_TARGET="python3_5* -python2_7 -python3_4 -python3_6*" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-libs/libxml2-2.9.8:2::gentoo  USE="examples icu ipv6 lzma python readline -debug -static-libs {-test}" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/backports-1.0::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-util/gdbus-codegen-2.52.3::gentoo  PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/sip-4.19.8:0/12::gentoo  USE="doc -debug" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] virtual/python-ipaddress-1.0-r1::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/snowballstemmer-1.2.1::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pycurl-7.43.0::gentoo  USE="examples ssl {-test}" CURL_SSL="openssl -gnutls -libressl -nss" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pyparsing-2.2.0::gentoo  USE="doc examples" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-db/postgresql-10.3:10::gentoo  USE="doc kerberos nls pam readline server ssl threads xml zlib -ldap -libressl -perl -python (-selinux) -static-libs -systemd -tcl -uuid" PYTHON_SINGLE_TARGET="python3_5* -python2_7 -python3_4 -python3_6*" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] x11-base/xcb-proto-1.13::gentoo  ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-libs/libgit2-glib-0.26.2::gentoo  USE="ssh vala -python" PYTHON_TARGETS="python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] app-editors/vim-8.0.1298::gentoo  USE="X acl nls -cscope -debug -gpm -lua -luajit -minimal -perl -python -racket -ruby (-selinux) -tcl -terminal -vim-pager" PYTHON_SINGLE_TARGET="python3_5* -python2_7 -python3_4 -python3_6*" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/setuptools-36.7.2::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/certifi-2018.4.16::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pyblake2-1.1.2::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-util/meson-0.46.1::gentoo  PYTHON_TARGETS="python3_5* -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pbr-3.1.1::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/idna-2.5::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pygments-2.2.0::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/extras-1.0.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/typing-3.6.2::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/alabaster-0.7.9::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/sphinx_rtd_theme-0.1.9::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/imagesize-0.7.1::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/markupsafe-0.23::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/sqlalchemy-1.2.4::gentoo  USE="doc examples sqlite {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/namespace-sphinxcontrib-1.0::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pytz-2017.2::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/chardet-3.0.4::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/PySocks-1.6.7::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/asn1crypto-0.22.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/ply-3.9:0/3.9::gentoo  USE="examples" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/mimeparse-1.6.0::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/numpy-1.10.4::gentoo  USE="doc -lapack {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/docutils-0.13.1::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/linecache2-1.0.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/Babel-2.5.3-r1::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/jinja-2.10::gentoo  USE="examples -doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pycparser-2.14::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/cffi-1.11.4:0/1.11.4::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/traceback2-1.4.0::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/dbus-python-1.2.4::gentoo  USE="doc examples {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] app-portage/gemato-13.0-r1::gentoo  USE="blake2 bzip2 gpg lzma -sha3 {-test} -tools" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pyGPG-0.2::gentoo  PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] app-crypt/gpgme-1.10.0:1/11::gentoo  USE="cxx -common-lisp -python -qt5 -static-libs" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] sys-apps/util-linux-2.30.2-r1::gentoo  USE="cramfs ncurses nls pam readline static-libs suid unicode -build -caps -fdformat -kill -python (-selinux) -slang -systemd {-test} -tty-helpers -udev" ABI_X86="(64) -32 (-x32)" PYTHON_SINGLE_TARGET="python3_5* -python2_7 -python3_4 -python3_6*" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] sys-fs/cryptsetup-1.7.5::gentoo  USE="gcrypt nls -kernel -libressl -nettle -openssl -pwquality -python -reencrypt -static -static-libs -udev -urandom" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] sys-apps/kmod-24::gentoo  USE="doc lzma tools zlib -debug -python -static-libs" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/PyQt5-5.9.2::gentoo  USE="dbus examples gui help multimedia network opengl positioning printsupport serialport sql svg testlib webchannel webkit websockets widgets x11extras xmlpatterns -bluetooth -debug -declarative -designer -gles2 -location -sensors -webengine" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/qscintilla-python-2.10.3::gentoo  USE="-debug" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] sys-apps/portage-2.3.40-r1::gentoo  USE="doc (ipc) native-extensions rsync-verify xattr -build -epydoc -gentoo-dev (-selinux)" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-java/java-config-2.2.0-r4:2::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] app-portage/gentoolkit-0.4.2-r1::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] app-admin/webapp-config-1.55-r1::gentoo  USE="portage" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] app-portage/portpeek-2.1.25::gentoo  PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/six-1.11.0::gentoo  USE="doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/cryptography-2.1.4-r1::gentoo  USE="-libressl {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/unittest2-1.1.0::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pyrsistent-0.13.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/bcrypt-3.1.3::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pynacl-1.1.2::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/iniparse-0.4-r2::gentoo  PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pyopenssl-17.5.0::gentoo  USE="examples -doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/urllib3-1.22::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/ndg-httpsclient-0.4.0::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/requests-2.18.4::gentoo  USE="ssl -socks5" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/ssl-fetch-0.4::gentoo  PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] app-portage/layman-2.4.2-r1::gentoo  USE="cvs git gpg mercurial subversion -bazaar -darcs (-g-sorcery) -sqlite -squashfs -sync-plugin-portage {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/whoosh-2.7.4::gentoo  USE="doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/sphinxcontrib-websupport-1.0.1-r1::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/sphinx-1.6.5::gentoo  USE="doc latex -net {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pyxattr-0.5.5::gentoo  USE="doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) -python3_4" 0 KiB
[ebuild   R    ] dev-python/pyasn1-0.2.3::gentoo  USE="doc" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pycairo-1.16.3-r1::gentoo  USE="doc examples {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/pygobject-3.24.1:3::gentoo  USE="cairo examples threads {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/paramiko-2.4.1::gentoo  USE="doc examples {-test}" PYTHON_TARGETS="python2_7 python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-libs/libpeas-1.20.0-r1::gentoo  USE="gtk python -glade -lua -luajit {-test}" PYTHON_SINGLE_TARGET="python3_5* -python3_4 -python3_6*" PYTHON_TARGETS="python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-util/meld-3.18.0::gentoo  PYTHON_SINGLE_TARGET="python3_5* -python3_4 -python3_6*" PYTHON_TARGETS="python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-vcs/gitg-3.26.0::gentoo  USE="python -glade" PYTHON_TARGETS="python3_5* -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/testtools-2.3.0::gentoo  USE="doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/fixtures-3.0.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB
[ebuild   R    ] dev-python/subunit-1.2.0-r1::gentoo  USE="-static-libs {-test}" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB

Total: 89 packages (1 in new slot, 88 reinstalls), Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

media-libs/freetype:2

  (media-libs/freetype-2.9.1-r3:2/2::gentoo, ebuild scheduled for merge) conflicts with
    <media-libs/freetype-2.9.1-r3 required by (app-text/texlive-core-2017-r3:0/0::gentoo, installed)
    ^                    ^^^^^^^^



No PYTHON_TARGETS or PYTHON_SINGLE_TARGET anywhere in /etc/portage. No 'python_single_target_' or 'python_targets_' USE flags anywhere in /etc/portage. A completely stable system other than for a few ruby packages and gentoo-sources-4.14.49. So whatever is causing this endless looping nightmare of build and rebuild toggling back and forth between python 3.5 and python 3.6 is coming solely from the system profile.

What's going on?

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 731
Location: S.O. France

PostPosted: Sat Jun 23, 2018 5:22 pm    Post subject: Reply with quote

Can you post your emerge --info and eselect python list.

Don't you have any python entry in your world file?
Back to top
View user's profile Send private message
Uranium
n00b
n00b


Joined: 28 Jul 2009
Posts: 10

PostPosted: Sat Jun 23, 2018 6:41 pm    Post subject: Reply with quote

I think you'll find the switch to Python 3.6 has been reverted: https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8b776b92e5db75a415a34393cc81e988dae4e545. No idea why though.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21712
Location: here

PostPosted: Sat Jun 23, 2018 7:34 pm    Post subject: Reply with quote

Pobably is a mistake because python3.6 tracker has yet some bugs
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 258
Location: Northern California

PostPosted: Sat Jun 23, 2018 10:05 pm    Post subject: Reply with quote

Well ain't that wonderful. This appears to be such a poorly conceived 'upgrade' that even some of the key devs have been bushwhacked.

FYI:
Code:

# eselect python list
Available Python interpreters, in order of preference:
  [1]   python2.7
  [2]   python3.6
  [3]   python3.5 (fallback)


Code:

# emerge --info
Portage 2.3.40 (python 2.7.14-final-0, default/linux/amd64/17.1/desktop/plasma, gcc-7.3.0, glibc-2.26-r7, 4.14.49-gentoo x86_64)
=================================================================
System uname: Linux-4.14.49-gentoo-x86_64-Intel-R-_Core-TM-_i5-3570_CPU_@_3.40GHz-with-gentoo-2.4.1
KiB Mem:    32930868 total,  11992608 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sat, 23 Jun 2018 16:45:01 +0000
Head commit of repository gentoo: 110505f0c38ba57d57a392c145ae9a17c70f49bd
sh bash 4.4_p12
ld GNU ld (Gentoo 2.30 p2) 2.30.0
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.24.3-r1::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.5::gentoo, 3.6.5::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.15.1-r2::gentoo
sys-devel/binutils:       2.30-r2::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.26-r7::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.namerica.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24

local
    location: /usr/local/portage
    masters: gentoo
    priority: 0

printer-drivers
    location: /var/lib/layman/printer-drivers
    masters: gentoo
    priority: 50

vmware
    location: /var/lib/layman/vmware
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA vmware"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.1/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa amd64 apache2 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit crypt cups curl cxx dbus declarative doc dri dts dvd dvdr emboss encode examples exif fam flac fontconfig fortran gcj gd gdbm gif glamor gtk handbook iconv icu ipv6 jack java jbig jpeg jpeg2k kde kipi kpathsea kwallet lcms ldap libnotify libtirpc lzma mad mbox mng modules mp3 mp4 mpeg multilib ncurses nls nptl odbc ogg openexr opengl openmp pam pango pcre pdf phonon plasma png policykit postgres ppds qml qt3support qt5 readline sdl seccomp semantic-desktop source spell ssl startup-notification svg t1lib tcpd threads tiff truetype udev udisks unicode upower usb vim-syntax vorbis webp widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xpm xv xvid zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_core authn_dbd authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers http2 ident imagemap include info lbmethod_byrequests log_config log_forensic logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" APACHE2_MPMS="worker" CALLIGRA_FEATURES="karbon plan sheets stage words" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev vmmouse wacom joystick" KERNEL="linux" L10N="en en-US" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver presenter-minimizer wiki-publisher" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby23" SANE_BACKENDS="epson2" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel r600 radeon radeonsi vesa vmware" XFCE_PLUGINS="clock trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Given the news item and the usual expected disaster that is the 'doc' USE flag (which is the fault of incompetent upstream devs and not the gentoo folks btw) I was expecting to hit issues moving to python3_6. There were certainly plenty of those. However, what I wasn't expecting was to have the whole thing reversed overnight with no news item, no forum post, nothing. Just another big pile of brokenness on my daily 'emerge --sync'. Now my entire system seems to be broken coming and going. Python3_6 was stable and python3_5 was gone. Now python3_5 is back and my default profile with no PYTHON_SINGLE_TARGET/PYTHON_TARGETS redefined in make.conf (which usually just causes more trouble than it fixes) wants to rebuild a few hundred packages again, and yet again I'm running into errors like:

Code:

# emerge -1v dev-python/six

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-python/six-1.11.0::gentoo  USE="doc {-test}" PYTHON_TARGETS="python2_7 python3_5* (-pypy) (-pypy3) -python3_4 -python3_6*" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/six:0

  (dev-python/six-1.11.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-python/six (Argument)

  (dev-python/six-1.11.0:0/0::gentoo, installed) pulled in by
    dev-python/six[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,
python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),
-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),
-python_single_target_python3_6(-)] required by (dev-python/pathlib2-2.3.0:0/0::gentoo, installed)

    dev-python/six[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,
python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),
-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),
-python_single_target_python3_6(-)] required by (dev-python/xcffib-0.5.1:0/0::gentoo, installed)

    dev-python/six[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/rst-linker-1.9-r1:0/0::gentoo, installed)

    >=dev-python/six-1.4[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/unittest2-1.1.0:0/0::gentoo, installed)

    dev-python/six[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/pyrsistent-0.13.0:0/0::gentoo, installed)

    >=dev-python/six-1.5[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/python-dateutil-2.6.1:0/0::gentoo, installed)

    >=dev-python/six-1.4.1[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/cryptography-2.1.4-r1:0/0::gentoo, installed)

    dev-python/six[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,
python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/protobuf-python-3.5.2-r1:0/15::gentoo, installed)

    >=dev-python/six-1.4.0[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/testtools-2.3.0:0/0::gentoo, installed)

    dev-python/six[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/bleach-1.5.0:0/0::gentoo, installed)

    dev-python/six[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,
python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (media-gfx/scour-0.36:0/0::gentoo, installed)

    dev-python/six[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,
python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/pynacl-1.2.0:0/0::gentoo, installed)

    >=dev-python/six-1.5[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/sphinxcontrib-websupport-1.0.1-r1:0/0::gentoo, installed)

    dev-python/six[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,
python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/cycler-0.10.0:0/0::gentoo, installed)

    >=dev-python/six-1.4[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/jaraco-packaging-4.1:0/0::gentoo, installed)

    dev-python/six[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/html5lib-0.9999999:0/0::gentoo, installed)

    dev-python/six[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,
python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/utidylib-0.3:0/0::gentoo, installed)

    >=dev-python/six-1.10[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,
python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/matplotlib-2.2.2-r1:0/0::gentoo, installed)

    >=dev-python/six-1.5[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/sphinx-1.6.5:0/0::gentoo, installed)

    >=dev-python/six-1.4.1[python_targets_pypy(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,
python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),
-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),
-python_single_target_python3_6(-)] required by (dev-python/bcrypt-3.1.3:0/0::gentoo, installed)

    >=dev-python/six-1.9.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,
python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/prompt_toolkit-1.0.15:0/0::gentoo, installed)

    >=dev-python/six-1.5.2[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/pyopenssl-17.5.0:0/0::gentoo, installed)

    dev-python/six[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/fixtures-3.0.0:0/0::gentoo, installed)

    >=dev-python/six-1.10.0[python_targets_python2_7(-)?,python_targets_python3_4(-)?,
python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/iniparse-0.4-r2:0/0::gentoo, installed)

    dev-python/six[python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,
python_targets_python3_6(-)?,-python_single_target_python2_7(-),-python_single_target_python3_4(-),
-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/traitlets-4.3.2:0/0::gentoo, installed)



It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


However, if I run "# emerge -uDNv --with-bdeps=y --quiet-build=y --keep-going=y @world" dev-python/six DOES rebuild. Until something else breaks and even the "--keep-going=y" parameter doesn't. More fussing with revdeps and such and that breakage clears and my system lurches forward yet again.

I applaud the gentoo devs for their hard work and effort on gentoo, but seriously, this was not one of their shining moments. At the very least i would have appreciated a news item to the effect of "Ignore that last news item; we've reverted the brokenness until further notice." That would have at least given me some clue as to what was going on before I blundered ahead trying to fix things I probably shouldn't have been trying to fix.

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout; broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
engineermdr
Apprentice
Apprentice


Joined: 08 Nov 2003
Posts: 273
Location: Altoona, WI, USA

PostPosted: Sat Jun 23, 2018 11:50 pm    Post subject: Reply with quote

Thanks for posting, I'll take this as a warning not to sync portage until python-3.6 is back. I also spent some time getting python-3.6 to install, and I don't want to revert now that it's all working.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21712
Location: here

PostPosted: Sun Jun 24, 2018 7:16 am    Post subject: Reply with quote

Having regard to the fact that my system work also with python3.6 I putted, temporarly, in my make.conf
Code:
PYTHON_SINGLE_TARGET="python3_6"
PYTHON_TARGETS="python2_7 python3_6"

So I avoid recompiling everything again
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
chl
n00b
n00b


Joined: 13 May 2003
Posts: 70
Location: Munich

PostPosted: Sun Jun 24, 2018 8:45 am    Post subject: Reply with quote

fedeliallalinea wrote:
Having regard to the fact that my system work also with python3.6 I putted, temporarly, in my make.conf
Code:
PYTHON_SINGLE_TARGET="python3_6"
PYTHON_TARGETS="python2_7 python3_6"

So I avoid recompiling everything again


I tried this too, to avoid the mess.

But for me it didn't help. On a world update several packages complain about missing python targets. The strange thing is that if I directly edit profiles/base/make.defaults and revert the changes of the commit mentioned above, it works.

Any hints?

Thanks
CHL
_________________
The difficulty in designing something completely foolproof, is not to underestimate the ingenuity of complete fools.
Back to top
View user's profile Send private message
Moonboots
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2006
Posts: 124

PostPosted: Sun Jun 24, 2018 8:58 am    Post subject: Reply with quote

fedeliallalinea wrote:
Having regard to the fact that my system work also with python3.6 I putted, temporarly, in my make.conf
Code:
PYTHON_SINGLE_TARGET="python3_6"
PYTHON_TARGETS="python2_7 python3_6"

So I avoid recompiling everything again


I did exactly the same. Plus app-text/asciidoc and gnome-base/libglade which are PYTHON_SINGLE_TARGET="python2_7" only i added to /etc/portage/package.use......
Back to top
View user's profile Send private message
tholin
Apprentice
Apprentice


Joined: 04 Oct 2008
Posts: 167

PostPosted: Sun Jun 24, 2018 9:02 am    Post subject: Reply with quote

fedeliallalinea wrote:
Having regard to the fact that my system work also with python3.6 I putted, temporarly, in my make.conf
Code:
PYTHON_SINGLE_TARGET="python3_6"
PYTHON_TARGETS="python2_7 python3_6"

So I avoid recompiling everything again

That doesn't work if there are any python-2.7 only packages installed. Then you get an unmet requirements like this:
Code:
!!! The ebuild selected to satisfy "app-text/asciidoc" has unmet requirements.
- app-text/asciidoc-8.6.10::gentoo USE="-examples -graphviz -highlight -test" ABI_X86="(64)" PYTHON_SINGLE_TARGET="(-pypy) -python2_7" PYTHON_TARGETS="python2_7 -pypy"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_pypy python_single_target_python2_7 )

https://bugs.gentoo.org/show_bug.cgi?id=658778

Even the eselect news for the python update recommended setting PYTHON_SINGLE_TARGET like this so not only was the python update botched, the information on how to update was also wrong.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6944
Location: Austria

PostPosted: Sun Jun 24, 2018 9:06 am    Post subject: Reply with quote

tholin wrote:
Even the eselect news for the python update recommended setting PYTHON_SINGLE_TARGET like this so not only was the python update botched, the information on how to update was also wrong.

That is a fundamental misunderstanding of the news. The recommendation was to not set anything yourself. "If you have not overriden..."

But as soon as *IF* you manually set these variables, you have always needed to adjust a few python2_7-only packages in package.use, and that is completely independent of this news items or any python3_x bump so far. So in context of the news text, those package.use entries have already been present on your systems.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Moonboots
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2006
Posts: 124

PostPosted: Sun Jun 24, 2018 9:08 am    Post subject: Reply with quote

@ tholin

Did you see the last line of my post ? it solved my problem with app-text/asciidoc.
Back to top
View user's profile Send private message
tholin
Apprentice
Apprentice


Joined: 04 Oct 2008
Posts: 167

PostPosted: Sun Jun 24, 2018 9:24 am    Post subject: Reply with quote

asturm wrote:
That is a fundamental misunderstanding of the news. The recommendation was to not set anything yourself. "If you have not overriden..."

I'm talking about this recommendation:
Code:
In order to improve stability of the upgrade, you may choose to
temporarily enable both targets, i.e. set in /etc/portage/make.conf
or its equivalent:

    PYTHON_TARGETS="python2_7 python3_5 python3_6"
    PYTHON_SINGLE_TARGET="python3_5"

So even if you hadn't overriden anything it was recommended to set PYTHON_SINGLE_TARGET temporarily during the update to prevent missing imports during the update. Setting PYTHON_SINGLE_TARGET like that didn't work if there were python-2.7 only packages installed.
Back to top
View user's profile Send private message
chl
n00b
n00b


Joined: 13 May 2003
Posts: 70
Location: Munich

PostPosted: Sun Jun 24, 2018 12:43 pm    Post subject: Reply with quote

Moonboots wrote:
Did you see the last line of my post ? it solved my problem with app-text/asciidoc.


Thanx, that made the difference!

CHL
_________________
The difficulty in designing something completely foolproof, is not to underestimate the ingenuity of complete fools.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3869
Location: Dallas area

PostPosted: Sun Jun 24, 2018 1:39 pm    Post subject: Reply with quote

tholin wrote:
asturm wrote:
That is a fundamental misunderstanding of the news. The recommendation was to not set anything yourself. "If you have not overriden..."

I'm talking about this recommendation:
Code:
In order to improve stability of the upgrade, you may choose to
temporarily enable both targets, i.e. set in /etc/portage/make.conf
or its equivalent:

    PYTHON_TARGETS="python2_7 python3_5 python3_6"
    PYTHON_SINGLE_TARGET="python3_5"

So even if you hadn't overriden anything it was recommended to set PYTHON_SINGLE_TARGET temporarily during the update to prevent missing imports during the update. Setting PYTHON_SINGLE_TARGET like that didn't work if there were python-2.7 only packages installed.


You can override the PYTHON_SINGLE_TARGET variable per application by setting python_single_target_python2_7 in package.use

I do the opposite, where my single target is 2.7 and I have to use python_single_target_python3_[456] for those needing python-3 only
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
radio_flyer
Apprentice
Apprentice


Joined: 04 Nov 2004
Posts: 258
Location: Northern California

PostPosted: Sun Jun 24, 2018 4:41 pm    Post subject: Reply with quote

As asturm wrote, you can fix the blockers without changing the PYTHON_* target defines by overriding the base profile settings in package.use. I made it to python3_6 (and back to python3_5) with:
Code:

=kde-apps/lokalize-17.12.3 python_single_target_python2_7 -python_single_target_python3_5 python_targets_python2_7
=dev-python/translate-toolkit-2.0.0 python_targets_python2_7 -subtitles
=sys-devel/gdb-7.12.1 python_single_target_python2_7 -python_single_target_python3_5 python_targets_python2_7
=app-text/asciidoc-8.6.10 python_single_target_python2_7

(And some '-doc' flags on a few packages for the usual recursive doc failures.)

As seen above, I found it necessary not only to define a new single target but to specifically negate the default one in some instances.

On the bright side, I see there's a sudden flurry of stabilization activity in bugzilla. gdb has already advanced, and I suspect the others aren't far behind, except for asciidoc which is perma-stuck on Python2. The devs seem to be making good progress on fixing things so hopefully the next upgrade attempt will go much smoother.
Back to top
View user's profile Send private message
rufnut
Apprentice
Apprentice


Joined: 16 May 2005
Posts: 203

PostPosted: Sun Jun 24, 2018 6:02 pm    Post subject: Reply with quote

asturm wrote:
tholin wrote:
Even the eselect news for the python update recommended setting PYTHON_SINGLE_TARGET like this so not only was the python update botched, the information on how to update was also wrong.

That is a fundamental misunderstanding of the news. The recommendation was to not set anything yourself. "If you have not overriden..."

But as soon as *IF* you manually set these variables, you have always needed to adjust a few python2_7-only packages in package.use, and that is completely independent of this news items or any python3_x bump so far. So in context of the news text, those package.use entries have already been present on your systems.


Thanks, wish I read this thread first :oops:
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 528
Location: Venice FL

PostPosted: Sun Jun 24, 2018 11:49 pm    Post subject: Reply with quote

radio_flyer wrote:
except for asciidoc which is perma-stuck on Python2.


Maybe the Gentoo developers could look into https://asciidoctor.org/ since it's "supposed" to be a drop-in replacement for asciidoc. :wink:

George
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13761

PostPosted: Mon Jun 25, 2018 12:14 am    Post subject: Reply with quote

That would introduce a hard dependency on Ruby. I'm doubtful that requiring users to install Ruby is an improvement over requiring them to keep an old Python around.
Back to top
View user's profile Send private message
thumper
Guru
Guru


Joined: 06 Dec 2002
Posts: 528
Location: Venice FL

PostPosted: Mon Jun 25, 2018 12:30 am    Post subject: Reply with quote

Hu wrote:
That would introduce a hard dependency on Ruby. I'm doubtful that requiring users to install Ruby is an improvement over requiring them to keep an old Python around.


Makes sense.

I have 3 packages that have a hard dependency on asciidoc, having thought about it, if asciidoc was the only Python 2.7, I could live without them just to loose Python 2.7, other than disk space, I'm not sure why I'm in such a hurry to burn it. :?

Thank you;

George

P.S. I should have looked around the net, seems a Python 3 port is available.
https://github.com/asciidoc3/asciidoc3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum