Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Borderlands TLP on Steam
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
tenspd1370
n00b
n00b


Joined: 14 Dec 2017
Posts: 51

PostPosted: Fri Jun 22, 2018 5:07 am    Post subject: [SOLVED] Borderlands TLP on Steam Reply with quote

Hi all -

I have a problem. To get Borderlands TLP to run I have disabled cut scenes as outlined here:

https://wiki.gentoo.org/wiki/Steam/Games_troubleshooting#Unity-based_games

Additionally the game may still crash at points during game play, when creating a new character or when traveling to one of the DLC's. To workaround this issue edit the willowengine.ini file. Find the section [FullScreenMovie] and change the value of bForceNoMovies from FALSE to TRUE. The files can be found at ~/.local/share/aspyr-media/borderlands 2/willowgame/config/willowengine.ini and ~/.local/share/aspyr-media/borderlands the pre-sequel/willowgame/config/willowengine.ini.

The problem is in the beginning of the game when your character is in the container and "moonshot", you need to enable the cut scenes to get out of the container.

Is there a way around this?

I have read here: https://forums.gentoo.org/viewtopic-t-1074698.html

That rebuilding things like glibc with -mstackrealign helped some people with something, but I don't know how to add -mstackrealign

or here: https://bugs.archlinux.org/task/49560

building libxcb with -01 helps (dmesg shows:
BorderlandsPreS[1385] general protection ip:f7251299 sp:ff885724 error:0 in libxcb.so.1.1.0[f7246000+2a000])
This could be done by altering the environment per: https://wiki.gentoo.org/wiki/Knowledge_Base:Overriding_environment_variables_per_package

Any suggestions?

*********************************
Solved - I found that by compiling libxcb and pulseaudio with -O1 in the CFLAGS altering envrionment variables on a per package basis worked. I have cut scenes now!
*********************************
Back to top
View user's profile Send private message
djdunn
l33t
l33t


Joined: 26 Dec 2004
Posts: 775
Location: Arrakis

PostPosted: Sat Jun 23, 2018 12:06 am    Post subject: Reply with quote

well i have borderlands 2

the bugs are pretty much the same since they are similar, same bugs you had there.

i do run ~amd64, radeonsi drivers

but ~amd64 with gcc-7.3 had some bugs that got fixed in gcc-8, including the bug with the mstackrealign workaround.

so when i rebuild everything with gcc-8 the bugs got ironed out and borderlands 2 started working fine, videos and all. its likely a bug with one of the flags with -O2, i heard some rumors about some of the cflags in some -march='s was causing problems too
_________________
A process cannot be understood by stopping it. Understanding must move with the flow of the process, must join it and flow with it.

-The First Law of Mentat
Back to top
View user's profile Send private message
est921
n00b
n00b


Joined: 20 Dec 2015
Posts: 22

PostPosted: Tue Nov 27, 2018 6:58 pm    Post subject: Reply with quote

I know I'm half a year late but do any of you remember how you solved this? I have rebuilt glibc (and most other things) with gcc 8 but still experince the type of bugs you describe
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum