Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Solved - x11-misc/mozo-9999 from gentoo-mate overlay failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 425
Location: Berlin

PostPosted: Fri Jun 15, 2018 10:27 pm    Post subject: Solved - x11-misc/mozo-9999 from gentoo-mate overlay failed Reply with quote

hello,

using 9999 ebuilds from gentoo-mate overlay and only mozo failed - last mozo commit from 15 days ago

Code:
checking for XML::Parser... ok
checking whether /usr/bin/python2.7 version is >= 3.5... no
configure: error: Python interpreter is too old



Code:
eselect python list
Available Python interpreters, in order of preference:
  [1]   python3.6
  [2]   python2.7
  [3]   python3.5
  [4]   python3.4


why
Code:
checking whether /usr/bin/python2.7 version is >= 3.5... no
configure: error: Python interpreter is too old


###

Code:
emerge --info
Portage 2.3.24 (python 3.6.5-final-0, funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-8.1.0, glibc-2.27-r4, 4.17.1-gentoo x86_64)
=================================================================
System uname: Linux-4.17.1-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E3-1245_v5_@_3.50GHz-with-gentoo-2.2.2
KiB Mem:    32903140 total,  28851968 free
KiB Swap:    1048572 total,   1048572 free
sh bash 4.4_p18
ld GNU ld (Gentoo 2.30 p3) 2.30.0
ccache version 3.3.4 [disabled]
app-shells/bash:          4.4_p18::core-kit
dev-lang/perl:            5.26.1::perl-kit
dev-lang/python:          2.7.14-r2::python-kit, 3.4.8-r1::layees, 3.5.5-r1::layees, 3.6.5-r1::python-kit
dev-util/ccache:          3.3.4-r1::core-kit
dev-util/cmake:           3.11.4::layees
sys-apps/baselayout:      2.2.2::core-kit
sys-apps/openrc:          0.35.5::core-kit
sys-apps/sandbox:         2.12::core-kit
sys-devel/autoconf:       2.13::core-kit, 2.69-r4::core-kit
sys-devel/automake:       1.15.1-r1::core-kit
sys-devel/binutils:       2.30-r3::layees
sys-devel/gcc:            7.3.1::core-kit, 8.1.0-r3::layees
sys-devel/gcc-config:     1.9.1::core-kit
sys-devel/libtool:        2.4.6-r4::core-kit
sys-devel/make:           4.2.1-r3::layees
sys-kernel/linux-headers: 4.16-r1::layees (virtual/os-headers)
sys-libs/glibc:           2.27-r4::layees

Installed sets: @mate_live_builds
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical --keep-going --with-bdeps=y --complete-graph --usepkg"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/ http://ftp.halifax.rwth-aachen.de/gentoo/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/"
INSTALL_MASK="/etc/systemd/ /usr/lib/systemd/ /lib/systemd/"
LANG="en_US.UTF-8"
LDFLAGS="-march=native -O2 -pipe"
LINGUAS="en_US en"
MAKEOPTS="-j9 -s"
PKGDIR="/var/cache/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
USE="# X a52 aac acl acpi alsa alsaplugins amd64 apng appindicator applet bash-completion berkdb branding bzip2 cairo caja cdda cddb cdr cleartype cleartype_hinting consolekit corefonts cracklib crypt css cxx dbus device-mapper dhcpd dts dvd dvdarchive dvdnav dvdr dvdread encode evdev exif extras faac faad fat ffmpeg flac fontconfig fonts gdbm gif gpm gtk3 ico iconv icu image-converter introspection ipod ipv6 jpeg jpeg2k lame lcms libass libburn libguess libmpeg2 libnotify mad mate matroska mjpeg mmx modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pcre pdf png postproc pulseaudio python quicktime rar readline resolvconf sndfile sse sse2 ssl startup-notification svg taglib tcpd theora tiff truetype twolame type1 udev udisks uefi unicode upower usb v4l vdpau vorbis vpx wav wavpack webp widevine win32codecs wmf x264 x265 xattr xcomposite xinerama xkb xml xrandr xscreensaver xvid xvmc zlib zvbi" ABI_X86="64" ALSA_CARDS="emu10k1 usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" L10N="en-US en en-GB" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_US en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python3_6 python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby23 ruby24" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, ENV_UNSET, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS


it' not a big deal, because everything's working - i'am just curious :roll:

thx
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - MSI N760 - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Optical Gaming Mouse G400


Last edited by CooSee on Sat Jun 16, 2018 5:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5616

PostPosted: Fri Jun 15, 2018 11:49 pm    Post subject: Reply with quote

Feel free to check out my overlay which has mate 1.20 and is updated almost daily with upstream releases
_________________
overlay | patches
Neddyseagoon wrote:
The problem with leaving is that you can only do it once and it reduces your influence.
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 425
Location: Berlin

PostPosted: Sat Jun 16, 2018 2:06 pm    Post subject: Reply with quote

bunder wrote:
Feel free to check out my overlay which has mate 1.20 and is updated almost daily with upstream releases


thx - will try.

i was curious why this weird python error message, i never saw before.
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - MSI N760 - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Optical Gaming Mouse G400
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 425
Location: Berlin

PostPosted: Sat Jun 16, 2018 5:25 pm    Post subject: Reply with quote

manual install worked - no python error message :D

everything's possible - that's why i love source based distros :roll:

thx
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - MSI N760 - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Optical Gaming Mouse G400
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum