Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cups-filters-1.20.3 fails on gdbus-codegen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1062
Location: Stuttgart, Germany

PostPosted: Tue Jun 12, 2018 8:24 am    Post subject: cups-filters-1.20.3 fails on gdbus-codegen Reply with quote

So, emerge returns this when emerging cups-filters 1.20.3:

Code:
>>> Source configured.
>>> Compiling source in /var/tmp/portage/net-print/cups-filters-1.20.3/work/cups-filters-1.20.3 ...
make -j9
gdbus-codegen \
    --interface-prefix org.cups.cupsd \
    --c-namespace Cups \
    --generate-c-code cups-notifier \
    utils/org.cups.cupsd.Notifier.xml
make: gdbus-codegen: Command not found
make: *** [Makefile:5407: cups-notifier.c] Error 127
 * ERROR: net-print/cups-filters-1.20.3::gentoo failed (compile phase):
 *   emake failed


But I already checked with:

Code:
 # emerge -1 dev-util/gdbus-codegen
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-util/gdbus-codegen-2.99::rindeal
>>> Unpacking source...
>>> Source unpacked in /var/tmp/portage/dev-util/gdbus-codegen-2.99/work
>>> Preparing source in /var/tmp/portage/dev-util/gdbus-codegen-2.99/work ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-util/gdbus-codegen-2.99/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-util/gdbus-codegen-2.99/work ...
>>> Source compiled.
>>> Test phase [not enabled]: dev-util/gdbus-codegen-2.99

>>> Install gdbus-codegen-2.99 into /var/tmp/portage/dev-util/gdbus-codegen-2.99/image/ category dev-util
>>> Completed installing gdbus-codegen-2.99 into /var/tmp/portage/dev-util/gdbus-codegen-2.99/image/

 * Final size of build directory: 4 KiB
 * Final size of installed tree:  4 KiB


>>> Installing (1 of 1) dev-util/gdbus-codegen-2.99::rindeal

 * This is a virtual package existing just to satisfy gentoo deps.
 * Make sure you use dev-util/gdbus-codegen package from 'rindeal' repo.
 * Otherwise you'll end up with no gdbus-codegen, which will cause subsequent builds to fail.


 * Messages for package dev-util/gdbus-codegen-2.99:

 * This is a virtual package existing just to satisfy gentoo deps.
 * Make sure you use dev-util/gdbus-codegen package from 'rindeal' repo.
 * Otherwise you'll end up with no gdbus-codegen, which will cause subsequent builds to fail.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: app-text/poppler-0.65.0
 *  - /usr/lib64/libpoppler.so.74
 *  - /usr/lib64/libpoppler.so.74.0.0
 *      used by /usr/bin/inkscape (media-gfx/inkscape-0.92.3)
 *      used by /usr/bin/inkview (media-gfx/inkscape-0.92.3)
 *      used by /usr/lib64/scribus/plugins/libimportpdf.so (app-office/scribus-1.5.3-r1)
 *      used by 3 other files
>>> package: dev-libs/crypto++-7.0.0-r2
 *  - /usr/lib64/libcryptopp.so.5.6
 *  - /usr/lib64/libcryptopp.so.5.6.5
 *      used by /usr/bin/amule (net-p2p/amule-2.3.2-r1)
Use emerge @preserved-rebuild to rebuild packages using these libraries
[/home]# locate gdbus-codegen
/usr/bin/gdbus-codegen
/usr/lib64/python-exec/python2.7/gdbus-codegen
/usr/lib64/python-exec/python3.5/gdbus-codegen
/usr/lib64/python-exec/python3.6/gdbus-codegen
/usr/share/gtk-doc/html/gio/gdbus-codegen.html
/usr/share/gtk-doc/html/gio/gdbus-example-gdbus-codegen.html
/usr/share/man/man1/gdbus-codegen.1.bz2
/var/db/pkg/dev-util/gdbus-codegen-2.52.3
/var/portage/repos/dev-libs/glib/files/glib-2.50.0-external-gdbus-codegen.patch
/var/portage/repos/dev-libs/glib/files/glib-2.54.3-external-gdbus-codegen.patch
/var/portage/repos/dev-util/gdbus-codegen
/var/portage/repos/dev-util/gdbus-codegen/Manifest
/var/portage/repos/dev-util/gdbus-codegen/files
/var/portage/repos/dev-util/gdbus-codegen/gdbus-codegen-2.50.3.ebuild
/var/portage/repos/dev-util/gdbus-codegen/gdbus-codegen-2.52.3.ebuild
/var/portage/repos/dev-util/gdbus-codegen/gdbus-codegen-2.54.3.ebuild
/var/portage/repos/dev-util/gdbus-codegen/metadata.xml
/var/portage/repos/dev-util/gdbus-codegen/files/gdbus-codegen-2.40.0-sitedir.patch
/var/portage/repos/dev-util/gdbus-codegen/files/gdbus-codegen-2.54.3-sitedir.patch
/var/portage/repos/dev-util/gdbus-codegen/files/setup.py-2.32.4
/var/portage/repos/metadata/md5-cache/dev-util/gdbus-codegen-2.50.3
/var/portage/repos/metadata/md5-cache/dev-util/gdbus-codegen-2.52.3
/var/portage/repos/metadata/md5-cache/dev-util/gdbus-codegen-2.54.3
/var/portage/repos/rindeal/dev-util/gdbus-codegen
/var/portage/repos/rindeal/dev-util/gdbus-codegen/gdbus-codegen-2.99.ebuild
/var/portage/repos/rindeal/dev-util/gdbus-codegen/metadata.xml

I have the gdbus-codegen package from rindeal installed, but emerge cups-filters still fails. What am I doing wrong here?

Cheers,

EE
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19441
Location: here

PostPosted: Tue Jun 12, 2018 8:29 am    Post subject: Reply with quote

And with gdbus-codegen from portage cups-filters work?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1062
Location: Stuttgart, Germany

PostPosted: Tue Jun 12, 2018 8:36 am    Post subject: Reply with quote

ah, indeed it does. I'll file an issue with the rindeal repo maintainer.

Cheers,

EE
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19441
Location: here

PostPosted: Tue Jun 12, 2018 8:46 am    Post subject: Reply with quote

Maybe a cups-filters need a minor version
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum