Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] LXDE Mouse Cursor List Empty
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
figueroa
Guru
Guru


Joined: 14 Aug 2005
Posts: 401
Location: GA-USA

PostPosted: Sun Jun 03, 2018 10:05 pm    Post subject: [SOLVED] LXDE Mouse Cursor List Empty Reply with quote

I'm running a fairly new desktop PC with LXDE where choice of xcursors is controlled with the program lxappearance, "Customize Look and Feel" under Preferences on the menu. I have a number of cursor installed which are found in /usr/share/cursors/xorg-x11/ such as Adwaita, handhelds, redglass, Silver, whiteglass.

The problem is that when running "Customize Looks and Feel" the tab "Mouse Cursor" is an empty list, with a preview that looks like Adwaita.

I have found that I can hand jam a line into ~/.config/lxsession/LXDE/default.conf in the format:
Code:
sGtk/CursorThemeName=Adwaita


and change the mouse cursor theme manually. That's neither right nor handy.

What do I have to do to help my list of mouse cursors to show up on the Mouse Cursor tab in lxappearance? My other LXDE-based computers do not have this problem.
_________________
Andy Figueroa
andy@andyfigueroa.net Working with Unix since 1983.


Last edited by figueroa on Mon Jun 04, 2018 3:41 am; edited 2 times in total
Back to top
View user's profile Send private message
figueroa
Guru
Guru


Joined: 14 Aug 2005
Posts: 401
Location: GA-USA

PostPosted: Mon Jun 04, 2018 3:40 am    Post subject: Reply with quote

I've answered my own question. I had to create symbolic links in /usr/share/icons to the cursor themes installed in /usr/share/cursors/xorg-x11 as follows:
Code:
ln -s ../cursors/xorg-x11/whiteglass .
ln -s ../cursors/xorg-x11/redglass .
ln -s ../cursors/xorg-x11/Silver .
ln -s ../cursors/xorg-x11/handhelds .
ln -s ../cursors/xorg-x11/Adwaita Adwaita2


Note that I had to name the symbolic link Adwaita2 because there is already a directory named Adwaita in /usr/share/icons. That's all. Works fine now.
_________________
Andy Figueroa
andy@andyfigueroa.net Working with Unix since 1983.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum