Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Security issues with jack audio
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1462
Location: San Jose, CA

PostPosted: Sat Jun 02, 2018 6:06 pm    Post subject: Security issues with jack audio Reply with quote

I'm trying to get jack audio to work.

I've traced the problem down to the security subsystem appearing to not read /etc/security/limits.d/40-realtime-base.conf.

Jack is producing this error message when I run it as a regular user:

Code:
JACK is running in realtime mode, but you are not allowed to use realtime scheduling.
Please check your /etc/security/limits.conf for the following line
and correct/add it if necessary:

  @audio          -       rtprio          99

After applying these changes, please re-login in order for them to take effect.

You don't appear to have a sane system configuration. It is very likely that you
encounter xruns. Please apply all the above mentioned changes and start jack again!


I'm pretty sure this is happening because the system is not using /etc/security/limits.d/40-realtime-base.conf which looks like this:

Code:
# Start of 40-realtime-base.conf from realtime-base-0.1

@realtime       -       rtprio  99
@realtime       -       memlock unlimited

# End of 40-realtime-base.conf from realtime-base-0.1




I'm not certain what to look at. Does anyone have any experience with this?
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6271
Location: /usr/lib64/lv2

PostPosted: Mon Jun 11, 2018 9:16 pm    Post subject: Reply with quote

I have two suggestions:

1. Use Gentoo Studio - it will set all this up for you.

2. If you don't want to, then check out this page. It's a WIP, but may have some info you've overlooked in your setup.

I think I see your problem, though. Replace "realtime" with "audio" in your conf file and make sure your user is in the audio group.

Hope this helps.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1986
Location: Heidelberg - Germany

PostPosted: Tue Jul 10, 2018 8:07 am    Post subject: Reply with quote

Try to copy all relevant changes into the file:
Code:

/etc/security/limits.conf

and check if it works after this is done.

I can check my system later at home. I had done a working jack configuration but do not know the details by heard.
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000 + ganz viele Modellflugzeuge, ein Tandem, Rennrad und DFXL ;)
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum