Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems going on with Font maybe causing segfault [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
LIsLinuxIsSogood
l33t
l33t


Joined: 13 Feb 2016
Posts: 892

PostPosted: Wed May 30, 2018 4:48 am    Post subject: Problems going on with Font maybe causing segfault [SOLVED] Reply with quote

Hi, I am having problems with applications seg faulting not sure why, but possibly because my system could be outdated and in need of an update. Just checking if that would be a logical conclusion to draw if the applications of Leafpad as well as the Libreoffice suite are not starting and the only sign I have is something to do with fonts or fontconfig. Here is my emerge --info for the global use flags infinality is set I don't know if it is supposed to be or not.

https://paste.pound-python.org/show/GPlRDiagE2HWNDL2uQh9/

Fontconfig list
https://paste.pound-python.org/show/RTbfnpRzEPK641yFGRP2/

Update: Current updating world set with 48 package updates, so we'll see maybe if the many x11 library updates are a cause...although still I'm not sure why an outdated library would suddenly cause applications to segfault unless those other applications were maybe updated and the libraries missing...that could actually be a problem I guess


Last edited by LIsLinuxIsSogood on Sat Jun 09, 2018 7:33 am; edited 1 time in total
Back to top
View user's profile Send private message
LIsLinuxIsSogood
l33t
l33t


Joined: 13 Feb 2016
Posts: 892

PostPosted: Fri Jun 01, 2018 12:04 am    Post subject: Probably more serious than Font Related Reply with quote

What would be causing my applications to be unable to launch as normal user (UID 1000 or whatever)? What I did was to attempt launching as root and they seem to work just fine. Also, since I think it could be the segfault data that might help, in terms of that it is some libraries having to do with gtk or gdk or something of the sorts...here:

Code:
[ 5683.807130] leafpad[17131]: segfault at 7ffdea600ff8 ip 00007f8ff73b36ac sp 00007ffdea601000 error 6 in libappmenu-gtk-module.so[7f8ff73b0000+6000]

Although with libreoffice there is no associated message, maybe I can try a trace of that if it helps to diagnose the issue?
Back to top
View user's profile Send private message
LIsLinuxIsSogood
l33t
l33t


Joined: 13 Feb 2016
Posts: 892

PostPosted: Sat Jun 09, 2018 7:32 am    Post subject: Reply with quote

Figured out what the problem was. Fixed it with a backup configuration file I had made for the GUI subsystem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum