Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[FIXED] can't emerge bino-1.6.6
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
JohnBlbec
Guru
Guru


Joined: 08 Feb 2003
Posts: 304

PostPosted: Thu Mar 15, 2018 4:49 pm    Post subject: [FIXED] can't emerge bino-1.6.6 Reply with quote

it finishes with error below:

Code:

.
.
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -DHTMLDIR=\"/usr/share/doc/bino-1.6.6/html\" -DLOCALEDIR=\"/usr/share/locale\" -I. -I..     -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/fribidi -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/AL -I/usr/include/libdrm -DGLEW_MX -I/usr/include/libdrm  -I/usr/include/qt5/QtOpenGL -I/usr/include/qt5 -I/usr/include/qt5/QtWidgets -I/usr/include/qt5 -I/usr/include/qt5/QtGui -I/usr/include/qt5 -I/usr/include/qt5/QtCore -I/usr/include/qt5 -DGLEW_MX    -pthread   -march=native -O2 -pipe -fPIC -c -o sdioutputdialog-moc.o sdioutputdialog-moc.cpp
x86_64-pc-linux-gnu-g++  -march=native -O2 -pipe -fPIC  -pthread -Wl,-O1 -Wl,--as-needed -pie -o bino media_data.o media_object.o media_input.o dispatch.o command_file.o color_matrix.o video_output.o video_output_qt.o subtitle_renderer.o audio_output.o player.o mainwindow.o inoutwidget.o controlswidget.o crosstalkdialog.o fullscreendialog.o audiodialog.o opendevicedialog.o qualitydialog.o subtitledialog.o videodialog.o zoomdialog.o colordialog.o preferences.o gui.o lib_versions.o main.o    NvSDIout.o NvSDIutils.o sdioutputdialog.o qt_resources-rcc.o colordialog-moc.o inoutwidget-moc.o controlswidget-moc.o crosstalkdialog-moc.o fullscreendialog-moc.o audiodialog-moc.o zoomdialog-moc.o opendevicedialog-moc.o qualitydialog-moc.o videodialog-moc.o subtitledialog-moc.o mainwindow-moc.o preferences-moc.o video_output_qt-moc.o sdioutputdialog-moc.o ../src/base/libbase.a   -lavformat -lavcodec -lavutil -lavdevice -lswscale -lavutil -lass -lopenal -lGL -lGLEWmx -lGLU -lGL  -lQt5OpenGL -lQt5Widgets -lQt5Gui -lQt5Core    -lXNVCtrl -lX11 -lpthread
/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/../../../../lib64/libGL.so: undefined reference to symbol 'XextAddDisplay'
/usr/lib64/libXext.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status


emerge --info
complete build log


Last edited by JohnBlbec on Wed May 30, 2018 4:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
Sonicthh
n00b
n00b


Joined: 21 Mar 2018
Posts: 1

PostPosted: Wed Mar 21, 2018 8:07 am    Post subject: Reply with quote

Adding -lXext helps:

Code:
aepinus ~ # cd /var/tmp/portage/media-video/bino-1.6.6/work/bino-1.6.6/src/
aepinus /var/tmp/portage/media-video/bino-1.6.6/work/bino-1.6.6/src # x86_64-pc-linux-gnu-g++  -O2 -pipe -march=skylake -mabm -mrtm -fPIC  -pthread -Wl,-O1 -Wl,--as-needed -pie -o bino media_data.o media_object.o media_input.o dispatch.o command_file.o color_matrix.o video_output.o video_output_qt.o subtitle_renderer.o audio_output.o player.o mainwindow.o inoutwidget.o controlswidget.o crosstalkdialog.o fullscreendialog.o audiodialog.o opendevicedialog.o qualitydialog.o subtitledialog.o videodialog.o zoomdialog.o colordialog.o preferences.o gui.o lib_versions.o main.o    NvSDIout.o NvSDIutils.o sdioutputdialog.o qt_resources-rcc.o colordialog-moc.o inoutwidget-moc.o controlswidget-moc.o crosstalkdialog-moc.o fullscreendialog-moc.o audiodialog-moc.o zoomdialog-moc.o opendevicedialog-moc.o qualitydialog-moc.o videodialog-moc.o subtitledialog-moc.o mainwindow-moc.o preferences-moc.o video_output_qt-moc.o sdioutputdialog-moc.o ../src/base/libbase.a   -lavformat -lavcodec -lavutil -lavdevice -lswscale -lavutil -lass -lopenal -lGL  -lGLEW -lGLU -lGL -lQt5OpenGL -lQt5Widgets -lQt5Gui -lQt5Core    -lXNVCtrl -lX11 -lpthread -lXext
aepinus /var/tmp/portage/media-video/bino-1.6.6/work/bino-1.6.6/src # cd ../../..
aepinus /var/tmp/portage/media-video/bino-1.6.6 # touch .compiled
aepinus /var/tmp/portage/media-video/bino-1.6.6 # ebuild /usr/portage/media-video/bino/bino-1.6.6.ebuild install
>>> Existing ${T}/environment for 'bino-1.6.6' will be sourced. Run
>>> 'clean' to start with a fresh environment.
[…]
>>> Completed installing bino-1.6.6 into /var/tmp/portage/media-video/bino-1.6.6/image/
[…]
aepinus /var/tmp/portage/media-video/bino-1.6.6 # ebuild /usr/portage/media-video/bino/bino-1.6.6.ebuild qmerge
[…]
>>> media-video/bino-1.6.6 merged.


[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
JohnBlbec
Guru
Guru


Joined: 08 Feb 2003
Posts: 304

PostPosted: Sat May 26, 2018 6:07 pm    Post subject: Reply with quote

it is not needed to add -lXext because it is a part of bino-1.6.6.ebuild so the error still persists :-(

Code:
src_configure() {
    econf \
        $(use_with video_cards_nvidia xnvctrl) \
        $(use_with lirc) \
        $(use_enable debug) \
        --without-equalizer \
        --with-qt-version=5 \
        --htmldir=/usr/share/doc/${PF}/html

    use video_cards_nvidia && append-cppflags "-I/usr/include/NVCtrl" \
        && append-ldflags "-L/usr/$(get_libdir)/opengl/nvidia/lib \
        -L/usr/$(get_libdir)" && append-libs "Xext"
    use lirc && append-cppflags "-I/usr/include/lirc" \
        && append-libs "lirc_client"

    # Fix a compilation error because of a multiple definitions in glew
    append-ldflags "-zmuldefs"
}
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 16202

PostPosted: Sat May 26, 2018 10:01 pm    Post subject: Reply with quote

I agree that the ebuild appears to add it, but based on the build log you posted, that run did not have the flag added. I see no explanation for why it was absent, but since it was absent, Sonicthh might be right.

Regardless, it looks to me like the bug is in your libGL.so, not in this package. libGL.so needs to be patched to link to Xext, rather than expect its consumers to do so on its behalf.
Back to top
View user's profile Send private message
JohnBlbec
Guru
Guru


Joined: 08 Feb 2003
Posts: 304

PostPosted: Wed May 30, 2018 3:19 pm    Post subject: Reply with quote

...so it means the ebuild is not ok because i have a flag video_cards_nvidia active :-(

Code:
$ equery uses bino
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for media-video/bino-1.6.6:
 U I
 - - debug              : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see
                          https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
 - - doc                : Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
 - - libav              : Prefer libav over ffmpeg whenever both are supported
 - - lirc               : Add support for lirc (Linux's Infra-Red Remote Control)
 + + video_cards_nvidia : VIDEO_CARDS setting to build driver for nvidia video cards
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24781
Location: here

PostPosted: Wed May 30, 2018 3:22 pm    Post subject: Reply with quote

You tried solution proposed in this bug
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
JohnBlbec
Guru
Guru


Joined: 08 Feb 2003
Posts: 304

PostPosted: Wed May 30, 2018 3:58 pm    Post subject: Reply with quote

fedeliallalinea wrote:
You tried solution proposed in this bug


yes it really helped to move the part with "use video_cards_nvidia" above "econf".
fixed bino-1.6.6.ebuild to download.

thank you :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum