Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ZSH: Root plötzlich ohne /bin und /usr/bin in PATH
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4397

PostPosted: Sun May 27, 2018 4:45 pm    Post subject: ZSH: Root plötzlich ohne /bin und /usr/bin in PATH Reply with quote

Ich habe diese zsh-config schon seit (sehr) langer Zeit am laufen. Und heute auf einmal gibt es beim su - massenweise Fehlermeldungen. "mkdir" würde nicht gefunden, ebenso git und einiges anderes.
Grund ist dass PATH nicht mehr wie früher aussieht.
zsh wurde zuletzt im April aktualisiert, was anderes ist wirklich nicht offensichtlich. Das sind die letzten updates:
Code:
     Fri May 25 17:15:30 2018 >>> sys-apps/portage-2.3.39
     Fri May 25 17:34:02 2018 >>> app-arch/bzip2-1.0.6-r9
     Fri May 25 17:34:15 2018 >>> sys-apps/baselayout-2.5-r1
     Fri May 25 17:34:46 2018 >>> dev-python/certifi-2018.4.16                                                         
     Fri May 25 17:35:55 2018 >>> dev-python/cryptography-2.1.4-r2                                                     
     Fri May 25 17:36:16 2018 >>> dev-python/pyasn1-0.4.2
     Fri May 25 17:36:48 2018 >>> x11-libs/libxshmfence-1.3-r1                                                         
     Fri May 25 17:37:17 2018 >>> app-arch/lz4-1.8.2
     Fri May 25 17:37:32 2018 >>> app-text/odt2txt-0.5
     Fri May 25 17:40:55 2018 >>> sys-apps/systemd-238-r7
     Fri May 25 17:41:32 2018 >>> media-libs/libepoxy-1.5.2
     Fri May 25 17:48:08 2018 >>> x11-libs/gtk+-3.22.30-r1
     Fri May 25 17:52:12 2018 >>> x11-libs/gtk+-2.24.32-r1
     Fri May 25 17:52:56 2018 >>> sys-process/procps-3.3.15-r1                                                         
     Fri May 25 17:53:56 2018 >>> x11-libs/gtkglext-1.2.0-r4
     Fri May 25 17:54:34 2018 >>> media-libs/libraw-0.18.11
     Sun May 27 08:36:32 2018 >>> sys-apps/portage-2.3.40
     Sun May 27 08:44:40 2018 >>> media-sound/id3-0.15-r1
     Sun May 27 08:52:33 2018 >>> sys-kernel/gentoo-sources-4.16.12

Möglichster Kandidat könnte systemd sein, das wurde von r6 auf r7 aktualisiert.

Davor ging ein su definitiv problemlos.
User-login geht immer noch.

Meine vorläufige Lösung ist, dass ich /etc/zsh/zshenv in meiner /root/.zshrc source.

Trotzdem würde mich interessieren, was für diesen break verantwortlich sein könnte. Freu mich über alle Antworten!
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3465
Location: Germany

PostPosted: Sun May 27, 2018 5:59 pm    Post subject: Reply with quote

Hallo Franz,
das klingt nach baselayout-2.5, damit scheint es zZt noch einige Probleme zu geben. Siehe zb Bug 656400
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4397

PostPosted: Sun May 27, 2018 7:07 pm    Post subject: Reply with quote

Hallo Josef, herzlichen Dank! Das scheint es zu sein. baselayout dann erstmal wieder zurück auf stable.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4397

PostPosted: Wed May 30, 2018 9:41 am    Post subject: Reply with quote

Mit baselayout-2.6 ist man jetzt auch wieder mit testing bugfrei unterwegs.

Ich weiß immer noch nicht, warum ich den bug nicht selber gefunden habe. Gesucht habe ich, zsh, root, PATH war im query, zero Ergebnisse. Vielleicht habe ich ja einfach im falschen bugzilla gesucht 8O die Hitze setzt mir doch etwas zu...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum