Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mesa-18.1.2: libtool: error: relink 'libEGL.la'
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 60

PostPosted: Mon Jun 25, 2018 5:54 am    Post subject: mesa-18.1.2: libtool: error: relink 'libEGL.la' Reply with quote

Code:
./.libs/libEGL_common.a(platform_drm.o): In function `swrast_put_image2':
platform_drm.c:(.text+0xbad): undefined reference to `gbm_bo_get_bpp'
./.libs/libEGL_common.a(platform_drm.o): In function `swrast_get_image':
platform_drm.c:(.text+0xd25): undefined reference to `gbm_bo_get_bpp'
collect2: error: ld returned 1 exit status
libtool:   error: error: relink 'libEGL.la' with the above command before installing it


Seems to be the meat of it. The pastebin is:


Seems similar to:
https://forums.gentoo.org/viewtopic-p-8154938.html?sid=3f5289b481f9bc8f8be17c295535fbfe

I deleted "/usr/lib{32,64}/libgbm.so*" and made sure egl is a useflag that didn't work

The only thing that finally worked was:

Code:
# cd /var/tmp/portage/media-libs/mesa-18.1.2/work/
# cd mesa-18.1.2-abi_x86_64.amd64/
# cd lib64/
# cp libEGL.so* libgbm.so* /usr/lib64/
# cd ../../mesa-18.1.2-abi_x86_32.x86/lib/
# cp -v libEGL.so* libgbm.so* /usr/lib32/


I'm not sure how this should be addressed or if it is something particular to my system but maybe it should be looked at?

Does a bug exist?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21326
Location: here

PostPosted: Mon Jun 25, 2018 6:05 am    Post subject: Re: mesa-18.1.2: libtool: error: relink 'libEGL.la' Reply with quote

davidsmind wrote:
I'm not sure how this should be addressed or if it is something particular to my system but maybe it should be looked at?

Does a bug exist?

You in thread you posted there is a link to bug https://bugs.gentoo.org/616398
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 60

PostPosted: Mon Jun 25, 2018 7:43 am    Post subject: Re: mesa-18.1.2: libtool: error: relink 'libEGL.la' Reply with quote

fedeliallalinea wrote:
davidsmind wrote:
I'm not sure how this should be addressed or if it is something particular to my system but maybe it should be looked at?

Does a bug exist?

You in thread you posted there is a link to bug https://bugs.gentoo.org/616398


That's for mesa-17.0.6 and the solutions in there didn't seem to work.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21326
Location: here

PostPosted: Mon Jun 25, 2018 7:50 am    Post subject: Reply with quote

You right sorry.
See this and this
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
davidsmind
n00b
n00b


Joined: 25 May 2002
Posts: 60

PostPosted: Mon Jun 25, 2018 8:26 am    Post subject: Reply with quote

Cool, it took me a really long time to find this because different people have different errors. I suppose we should close this but leave it available.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum