Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] pycodestyle merge conflicts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 531
Location: USA

PostPosted: Sun Jun 24, 2018 9:48 pm    Post subject: [SOLVED] pycodestyle merge conflicts Reply with quote

From my last emerge world:
Code:
dev-python/pycodestyle:0

  (dev-python/pycodestyle-2.4.0:0/0::gentoo, ebuild scheduled for merge) conflicts with
    <dev-python/pycodestyle-2.4.0[python_targets_python2_7(-),python_targets_python3_5(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/flake8-3.5.0:0/0::gentoo, installed)

Here are my installed pythons:
Code:
~# qlist -Iv dev-lang/python
dev-lang/python-2.7.15
dev-lang/python-3.5.5-r1
dev-lang/python-3.6.5-r1

Here are python-related flags in make.conf:
Code:
 ~# grep -i python /etc/portage/make.conf
#PYTHON_TARGETS="python2_7 python3_5 python3_6"
#PYTHON_SINGLE_TARGET="python3_5"

Any hints toward removing this conflict will be gratefully received.

[SOLVED] fedeliallalinea points out that flake8-3.5.0 requires a version of pycodestyle less than 2.4.0. Thus masking =dev-python/pycodestyle-2.4.0 allows flake8-3.5.0 to successfully emerge. Perhaps future versions of flake8 will remove that restriction. [/SOLVED]


Last edited by cfgauss on Mon Jun 25, 2018 1:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon Jun 25, 2018 6:09 am    Post subject: Reply with quote

You tried to solve manually?
Code:
# emerge -1 dev-python/pycodestyle dev-python/flake8

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 531
Location: USA

PostPosted: Mon Jun 25, 2018 12:55 pm    Post subject: Reply with quote

fedeliallalinea wrote:
You tried to solve manually?
Code:
# emerge -1 dev-python/pycodestyle dev-python/flake8

That successfully re-emerges dev-python/pycodestyle-2.3.1 and dev-python/flake8-3.50.
Code:
# emerge -1 =dev-python/pycodestyle-2.4.0 =dev-python/flake8-3.5.0
Calculating dependencies... done!
[ebuild     U  ] dev-python/pycodestyle-2.4.0 [2.3.1]
[ebuild   R    ] dev-python/flake8-3.5.0

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/pycodestyle:0

  (dev-python/pycodestyle-2.4.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-python/pycodestyle-2.4.0 (Argument)

  (dev-python/pycodestyle-2.3.1:0/0::gentoo, installed) pulled in by
    <dev-python/pycodestyle-2.4.0[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/flake8-3.5.0:0/0::gentoo, ebuild scheduled for merge)
    ^                       ^^^^^


[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21328
Location: here

PostPosted: Mon Jun 25, 2018 1:15 pm    Post subject: Reply with quote

Now the output is better for understanding.
If you want =dev-python/flake8-3.5.0 you should mask =dev-python/pycodestyle-2.4.0 because flake8 isn't compatible with >pycodestyle-2.3.1
flake8-3.5.0.ebuild:
RDEPEND="
        >=dev-python/pyflakes-1.5.0[${PYTHON_USEDEP}]
        <dev-python/pyflakes-1.7.0[${PYTHON_USEDEP}]
        >=dev-python/pycodestyle-2.0.0[${PYTHON_USEDEP}]
        <dev-python/pycodestyle-2.4.0[${PYTHON_USEDEP}] <--- this line
        $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' 'pypy*' )
        $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' 'python2*' pypy )
"

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum