Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Issue with openssl
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
The_Document
Apprentice
Apprentice


Joined: 03 Feb 2018
Posts: 234

PostPosted: Mon May 21, 2018 8:47 am    Post subject: Issue with openssl Reply with quote

I tried masking it in package.mas by adding it inseveral different ways but it didn't help, I don't know how to fix this

http://dpaste.com/0Z4VQNK
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 5753
Location: Room 101

PostPosted: Mon May 21, 2018 9:19 am    Post subject: Reply with quote

The_Document ...

I don't have dev-qt/* in my tree, so I can't look at its dependencies, but I suspect that all you need do is remove 'bindist' from make.conf, and/or 'emerge --deep --changed-use @world'. That should open the way for wpa_supplicant and qtnetwork.

HTH & best ... khay
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3554
Location: Hamburg

PostPosted: Mon May 21, 2018 9:26 am    Post subject: Re: Issue with openssl Reply with quote

The_Document wrote:
I tried masking it in package.mas by adding it inseveral different ways but it didn't help, I don't know how to fix this

http://dpaste.com/0Z4VQNK
In general, by changing USE flags, masking it won't help. And "bindist" is a very good candidate, adding "-bindist" to make.conf should.help
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18818
Location: here

PostPosted: Mon May 21, 2018 10:43 am    Post subject: Reply with quote

And use also --autounmask n when using -U option, without this portage can cause unmasking of openssl 1.1.0
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
The_Document
Apprentice
Apprentice


Joined: 03 Feb 2018
Posts: 234

PostPosted: Mon May 21, 2018 10:06 pm    Post subject: Reply with quote

cannot update @world

http://dpaste.com/3GQ2HT1

I believe incorrect pc time is causing this, but it might not be the issue.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 5753
Location: Room 101

PostPosted: Mon May 21, 2018 11:02 pm    Post subject: Reply with quote

The_Document wrote:
cannot update @world

The_Document ... which is unrelated to the original problem ... you're probably best to start a seperate thread in such cases.

The_Document wrote:
Code:
[[ ${PREFIX} ]] && die "\${PREFIX} has been removed and is a no-op now"

So, you have PREFIX set for some reason ... please provide 'emerge --info'.

best ... khay
Back to top
View user's profile Send private message
The_Document
Apprentice
Apprentice


Joined: 03 Feb 2018
Posts: 234

PostPosted: Tue May 22, 2018 12:07 am    Post subject: Reply with quote

khayyam wrote:
...please provide 'emerge --info'...


http://dpaste.com/2V6W86D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum