Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problemi nell upgrade
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
Guru
Guru


Joined: 28 Jan 2016
Posts: 426

PostPosted: Wed May 09, 2018 4:04 pm    Post subject: Reply with quote

Code:
RUBY_TARGETS="ruby22 ruby23"
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18754
Location: here

PostPosted: Wed May 09, 2018 4:33 pm    Post subject: Reply with quote

No sono corretti pensavo che in una gentoo ~arch ci fossero valori differenti mentre cercando nei profili sono sempre settati quei valori.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
Guru
Guru


Joined: 28 Jan 2016
Posts: 426

PostPosted: Wed May 09, 2018 4:37 pm    Post subject: Reply with quote

quindi devo metterli a mano a mano uno per uno ?
Back to top
View user's profile Send private message
drudox
Guru
Guru


Joined: 28 Jan 2016
Posts: 426

PostPosted: Wed May 09, 2018 5:45 pm    Post subject: Reply with quote

Code:
sysresccd / # emerge -1 =dev-libs/openssl-1.0.2o net-analyzer/nmap dev-perl/Net-SSLeay net-misc/iputils app-text/mupdf www-client/w3m app-crypt/rhash net-misc/dhcp www-servers/apache app-admin/apache-tools net-misc/wget x11-base/xorg-server net-nds/openldap dev-vcs/git net-wireless/wpa_supplicant dev-python/cryptography app-arch/libarchive app-crypt/mit-krb5 net-misc/curl media-sound/pulseaudio net-libs/neon dev-python/m2crypto dev-lang/python net-dns/bind net-misc/openssh dev-lang/ruby --backtrack=30
Calculating dependencies... done!
[ebuild     UD ] dev-libs/openssl-1.0.2o [1.1.1_pre6] USE="sslv3%* tls-heartbeat* -gmp% -kerberos% -sslv2%"
[ebuild   R    ] dev-perl/Net-SSLeay-1.820.0
[ebuild   R    ] dev-python/m2crypto-0.27.0-r1
[ebuild   R    ] dev-python/cryptography-2.1.4-r1
[ebuild   R    ] net-misc/iputils-20171016_pre-r1
[ebuild  NS    ] dev-lang/ruby-2.5.1 [2.3.7] USE="berkdb gdbm ipv6 rdoc ssl -debug -doc -examples -jemalloc -libressl -rubytests -socks5 -static-libs -tk -xemacs"
[ebuild   R    ] dev-ruby/rubygems-2.7.6  RUBY_TARGETS="ruby25*"
[ebuild   R    ] virtual/rubygems-14  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/net-telnet-0.1.1-r1  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/power_assert-1.1.1  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/test-unit-3.2.7  RUBY_TARGETS="ruby25*"
[ebuild  NS    ] dev-ruby/did_you_mean-1.2.1 [1.0.2] USE="{-test}" RUBY_TARGETS="ruby25"
[ebuild   R    ] dev-ruby/minitest-5.11.3  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/rake-12.3.1  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/json-2.1.0  RUBY_TARGETS="ruby25*"
[ebuild  N     ] dev-ruby/xmlrpc-0.3.0  USE="-doc {-test}" RUBY_TARGETS="ruby23 ruby25 -ruby24"
[ebuild   R    ] dev-ruby/racc-1.4.14  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/kpeg-1.1.0  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/rdoc-6.0.1  RUBY_TARGETS="ruby25*"
[ebuild   R    ] www-client/w3m-0.5.3_p20180125
[ebuild   R    ] net-libs/neon-0.30.2
[ebuild   R    ] x11-base/xorg-server-1.19.5-r2
[ebuild   R    ] app-arch/libarchive-3.3.2
[ebuild   R    ] net-nds/openldap-2.4.45
[ebuild   R    ] net-misc/curl-7.59.0
[ebuild   R    ] net-misc/dhcp-4.4.1
[ebuild  N     ] net-dns/bind-9.12.1  USE="berkdb caps dlz ipv6 ldap ssl threads xml zlib -dnsrps -dnstap -doc -fixed-rrset -geoip -gost -gssapi -idn -json -libressl -lmdb -mysql -nslint -odbc -postgres -python -rpz (-seccomp) (-selinux) -static-libs -urandom" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6"
[ebuild   R    ] app-admin/apache-tools-2.4.33
[ebuild   R    ] www-servers/apache-2.4.33
[ebuild   R    ] app-text/mupdf-1.12.0-r2
[ebuild   R    ] net-wireless/wpa_supplicant-2.6-r6
[ebuild  NS    ] dev-lang/python-3.6.5-r1 [2.7.14-r2, 3.5.5-r1] USE="bluetooth gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -examples -hardened -libressl {-test} -tk -wininst"
[ebuild   R    ] net-misc/openssh-7.6_p1-r5
[ebuild   R    ] net-misc/wget-1.19.5
[ebuild   R    ] dev-vcs/git-2.17.0
[ebuild   R    ] app-crypt/mit-krb5-1.16-r2
[ebuild   R    ] app-crypt/rhash-1.3.6-r1
[ebuild   R    ] net-analyzer/nmap-7.70
[ebuild   R    ] media-sound/pulseaudio-11.1

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2o:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0/0= required by (dev-lang/ruby-2.3.7:2.3/2.3::gentoo, installed)
                    ^^^^^                                                                                                 
    =dev-libs/openssl-1.0.2o (Argument)

  (dev-libs/openssl-1.1.1_pre6:0/1.1::gentoo, installed) pulled in by
    >=dev-libs/openssl-1.0.2n:0/1.1=[-bindist] required by (net-libs/nodejs-8.11.1:0/0::gentoo, installed)
                             ^^^^^^^                                                                                                         
    (and 3 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


mettendo ruby_targets_ruby25 nelle use del make.conf ho ottenuto questo ... sapete come risolverlo ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18754
Location: here

PostPosted: Wed May 09, 2018 6:19 pm    Post subject: Reply with quote

Metti nel comando anche nodejs e gli altri 3 conflitti
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
Guru
Guru


Joined: 28 Jan 2016
Posts: 426

PostPosted: Thu May 10, 2018 10:06 am    Post subject: Reply with quote

Code:
Burrows /home/marco # emerge -1 =dev-libs/openssl-1.0.2o net-analyzer/nmap dev-perl/Net-SSLeay net-misc/iputils app-text/mupdf www-client/w3m app-crypt/rhash net-misc/dhcp www-servers/apache app-admin/apache-tools net-misc/wget x11-base/xorg-server net-nds/openldap dev-vcs/git net-wireless/wpa_supplicant dev-python/cryptography app-arch/libarchive app-crypt/mit-krb5 net-misc/curl media-sound/pulseaudio net-libs/neon dev-python/m2crypto dev-lang/python net-dns/bind net-misc/openssh dev-lang/ruby net-libs/nodejs dev-lang/python net-dns/bind-tools dev-lang/python  --backtrack=30 --verbose-conflicts
Calculating dependencies... done!
[ebuild     UD ] dev-libs/openssl-1.0.2o [1.1.1_pre6] USE="sslv3%* tls-heartbeat* -gmp% -kerberos% -sslv2%"
[ebuild   R    ] dev-perl/Net-SSLeay-1.820.0
[ebuild   R    ] dev-python/m2crypto-0.27.0-r1
[ebuild   R    ] net-libs/nodejs-8.11.1
[ebuild   R    ] dev-python/cryptography-2.1.4-r1
[ebuild   R    ] net-misc/iputils-20171016_pre-r1
[ebuild  NS    ] dev-lang/ruby-2.5.1 [2.3.7] USE="berkdb gdbm ipv6 rdoc ssl -debug -doc -examples -jemalloc -libressl -rubytests -socks5 -static-libs -tk -xemacs"
[ebuild   R    ] dev-ruby/rubygems-2.7.6  RUBY_TARGETS="ruby25*"
[ebuild   R    ] virtual/rubygems-14  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/rake-12.3.1  RUBY_TARGETS="ruby25*"
[ebuild  NS    ] dev-ruby/did_you_mean-1.2.1 [1.0.2] USE="{-test}" RUBY_TARGETS="ruby25"
[ebuild   R    ] dev-ruby/json-2.1.0  RUBY_TARGETS="ruby25*"
[ebuild  N     ] dev-ruby/xmlrpc-0.3.0  USE="-doc {-test}" RUBY_TARGETS="ruby23 ruby25 -ruby24"
[ebuild   R    ] dev-ruby/net-telnet-0.1.1-r1  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/minitest-5.11.3  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/power_assert-1.1.1  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/test-unit-3.2.7  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/kpeg-1.1.0  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/racc-1.4.14  RUBY_TARGETS="ruby25*"
[ebuild   R    ] dev-ruby/rdoc-6.0.1  RUBY_TARGETS="ruby25*"
[ebuild   R    ] www-client/w3m-0.5.3_p20180125
[ebuild   R    ] net-libs/neon-0.30.2
[ebuild   R    ] net-dns/bind-tools-9.12.1
[ebuild   R    ] x11-base/xorg-server-1.19.5-r2
[ebuild   R    ] app-arch/libarchive-3.3.2
[ebuild   R    ] net-nds/openldap-2.4.45
[ebuild   R    ] net-misc/curl-7.59.0
[ebuild   R    ] net-misc/dhcp-4.4.1
[ebuild  N     ] net-dns/bind-9.12.1  USE="berkdb caps dlz ipv6 ldap ssl threads xml zlib -dnsrps -dnstap -doc -fixed-rrset -geoip -gost -gssapi -idn -json -libressl -lmdb -mysql -nslint -odbc -postgres -python -rpz (-seccomp) (-selinux) -static-libs -urandom" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6"
[ebuild   R    ] app-admin/apache-tools-2.4.33
[ebuild   R    ] www-servers/apache-2.4.33
[ebuild   R    ] app-text/mupdf-1.12.0-r2
[ebuild   R    ] net-wireless/wpa_supplicant-2.6-r6
[ebuild  NS    ] dev-lang/python-3.6.5-r1 [2.7.14-r2, 3.5.5-r1] USE="bluetooth gdbm ipv6 ncurses readline sqlite ssl (threads) xml -build -examples -hardened -libressl {-test} -tk -wininst"
[ebuild   R    ] net-misc/openssh-7.6_p1-r5
[ebuild   R    ] net-misc/wget-1.19.5
[ebuild   R    ] dev-vcs/git-2.17.0
[ebuild     U  ] app-crypt/mit-krb5-1.16.1 [1.16-r2]
[ebuild   R    ] app-crypt/rhash-1.3.6-r1
[ebuild   R    ] net-analyzer/nmap-7.70
[ebuild   R    ] media-sound/pulseaudio-11.1

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2o:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0/0= required by (dev-lang/ruby-2.3.7:2.3/2.3::gentoo, installed)
                    ^^^^^                                                                                                 
    =dev-libs/openssl-1.0.2o (Argument)

  (dev-libs/openssl-1.1.1_pre6:0/1.1::gentoo, installed) pulled in by
    dev-libs/openssl:0/1.1= required by (dev-lang/python-2.7.14-r2:2.7/2.7::gentoo, installed)
                    ^^^^^^^                                                                                                       
    dev-libs/openssl:0/1.1= required by (dev-lang/python-3.5.5-r1:3.5/3.5m::gentoo, installed)
                    ^^^^^^^                                                                                                       


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


e qui ?? guarda il comando ..
emerge -1 =dev-libs/openssl-1.0.2o net-analyzer/nmap dev-perl/Net-SSLeay net-misc/iputils app-text/mupdf www-client/w3m app-crypt/rhash net-misc/dhcp www-servers/apache app-admin/apache-tools net-misc/wget x11-base/xorg-server net-nds/openldap dev-vcs/git net-wireless/wpa_supplicant dev-python/cryptography app-arch/libarchive app-crypt/mit-krb5 net-misc/curl media-sound/pulseaudio net-libs/neon dev-python/m2crypto dev-lang/python net-dns/bind net-misc/openssh dev-lang/ruby net-libs/nodejs dev-lang/python net-dns/bind-tools --backtrack=30 --verbose-conflicts
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18754
Location: here

PostPosted: Thu May 10, 2018 10:17 am    Post subject: Reply with quote

Devi mettere anche lo slot in questo caso, quindi al posto di dev-lang/python metti dev-lang/python:2.7 e dev-lang/python:3.5 e per ruby al posto di dev-lang/ruby metti dev-lang/ruby:2.3
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
Guru
Guru


Joined: 28 Jan 2016
Posts: 426

PostPosted: Thu May 10, 2018 10:33 am    Post subject: Reply with quote

ok grazie mille , dopo che faccio maschero openssl ? >=openssl-1.0.2o in package.mask ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18754
Location: here

PostPosted: Thu May 10, 2018 10:40 am    Post subject: Reply with quote

drudox wrote:
ok grazie mille , dopo che faccio maschero openssl ? >=openssl-1.0.2o in package.mask ?

E' gia macherato openssl-1.1 ma per un bug di portage in certe situazioni vuole smacherarlo.
La soluzione te l'ho indicata gia' qua
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum