Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problemi nell upgrade
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 8:09 am    Post subject: problemi nell upgrade Reply with quote

salve a tutti, sto cercando di sistemare la nuova installazione sul mio laptop

l'upgrade che ho sistemato .. nel messaggio da errori e` :
[url]https://paste.pound-python.org/show/wkh5X5TvXDcs3Bgu0jas/ [/url]

vedo (prima linea del file che ho postato ) che ci sono
Code:
Total: 151 packages (18 upgrades, 133 reinstalls)
perche` portage vuole reinstallarne 133 ? e` possibile evitare di reinstallare questi ?? grazie in anticipo
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21321
Location: here

PostPosted: Wed May 09, 2018 8:27 am    Post subject: Reply with quote

Per prima cosa hai ancora qualche problemino con dev-libs/openssl-1.1 puoi postare tutto l'output di emerge?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 8:31 am    Post subject: Reply with quote

sta compilando .. quale output intendi ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21321
Location: here

PostPosted: Wed May 09, 2018 8:32 am    Post subject: Reply with quote

Dei pacchetti che vuole installare, questo perche'
Code:
  (dev-libs/openssl-1.1.1_pre6:0/1.1::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (www-servers/apache-2.4.33:2/2::gentoo, ebuild scheduled for merge)
    (net-analyzer/nmap-7.70:0/0::gentoo, ebuild scheduled for merge)
    (dev-lang/ruby-2.3.7:2.3/2.3::gentoo, ebuild scheduled for merge)
    (net-wireless/wpa_supplicant-2.6-r6:0/0::gentoo, ebuild scheduled for merge)
    (net-nds/openldap-2.4.45:0/0::gentoo, ebuild scheduled for merge)
    (app-arch/libarchive-3.3.2:0/13::gentoo, ebuild scheduled for merge)
    (net-dns/bind-tools-9.12.1:0/0::gentoo, ebuild scheduled for merge)
    (app-crypt/mit-krb5-1.16-r2:0/0::gentoo, ebuild scheduled for merge)
    (app-admin/apache-tools-2.4.33:0/0::gentoo, ebuild scheduled for merge)
    (app-text/mupdf-1.12.0-r2:0/1.12.0::gentoo, ebuild scheduled for merge)
    (dev-python/cryptography-2.1.4-r1:0/0::gentoo, ebuild scheduled for merge)
    (x11-base/xorg-server-1.19.5-r2:0/1.19.5::gentoo, ebuild scheduled for merge)
    (dev-vcs/git-2.17.0:0/0::gentoo, ebuild scheduled for merge)
    (dev-perl/Net-SSLeay-1.820.0:0/0::gentoo, ebuild scheduled for merge)
    (media-sound/pulseaudio-11.1:0/0::gentoo, ebuild scheduled for merge)

sembra voglia installarti ancora openssl-1.1
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 8:37 am    Post subject: Reply with quote

eccolo :
https://paste.pound-python.org/show/GDDLarE0UQqmcGDaH4VJ/
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21321
Location: here

PostPosted: Wed May 09, 2018 8:52 am    Post subject: Reply with quote

Prova ad aggiungere anche l'opzione --autounmask n
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 9:10 am    Post subject: Reply with quote

eccolo qua :

https://paste.pound-python.org/show/qJl0niRcOfLu8WtzJtE6/

come al solito grazie 1000 per la disponibilita` ;)
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 9:50 am    Post subject: Reply with quote

ora la situazione e` questa non riesco a mandare avanti la compilzione :

Code:
emerge -uDNv --with-bdeps y --backtrack=300 --verbose-conflicts --autounmask-write --exclude ruby --exclude openssh @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The following update has been skipped due to unsatisfied dependencies:

gnome-base/gvfs:0

  selected: (gnome-base/gvfs-1.34.2.1-r1:0/0::dantrell-gnome-3-26, installed)
  skipped: (gnome-base/gvfs-1.34.2.1-r1:0/0::dantrell-gnome-3-26, ebuild scheduled for merge) (see unsatisfied dependency below)

!!! All ebuilds that could satisfy "net-misc/openssh" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-misc/openssh-7.7_p1-r3::gentoo (masked by: package.mask)
- net-misc/openssh-7.7_p1-r2::gentoo (masked by: package.mask)
- net-misc/openssh-7.7_p1-r1::gentoo (masked by: package.mask)
- net-misc/openssh-7.6_p1-r5::gentoo (masked by: exclude option)
- net-misc/openssh-7.6_p1-r4::gentoo (masked by: exclude option)
- net-misc/openssh-7.5_p1-r4::gentoo (masked by: exclude option)

(dependency required by "gnome-base/gvfs-1.34.2.1-r1::dantrell-gnome-3-26" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



!!! The following update has been skipped due to unsatisfied dependencies:

app-text/ronn:0

  selected: (app-text/ronn-0.7.3-r3:0/0::gentoo, installed)
  skipped: (app-text/ronn-0.7.3-r3:0/0::gentoo, ebuild scheduled for merge) (see unsatisfied dependency below)

!!! All ebuilds that could satisfy "dev-lang/ruby:2.3" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/ruby-2.3.7::gentoo (masked by: exclude option)
- dev-lang/ruby-2.3.6::gentoo (masked by: exclude option)

(dependency required by "app-text/ronn-0.7.3-r3::gentoo[ruby_targets_ruby23]" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

sci-geosciences/geocode-glib:0
gnome-base/gnome:2.0
gnome-base/gnome-settings-daemon:0

The following packages are causing rebuilds:

  (dev-libs/glib-2.56.1:2/56::dantrell-gnome, ebuild scheduled for merge) causes rebuilds for:
    (gnome-extra/nm-applet-1.8.10-r1:0/0::dantrell-gnome, ebuild scheduled for merge)
    (media-video/ffmpegthumbnailer-2.2.0:0/0::gentoo, ebuild scheduled for merge)
    (xfce-base/libxfce4util-4.13.1:0/7::gentoo, ebuild scheduled for merge)
    (dev-libs/totem-pl-parser-3.26.0:0/18::dantrell-gnome, ebuild scheduled for merge)
    (x11-libs/libxklavier-5.4:0/16::dantrell-gnome, ebuild scheduled for merge)
    (net-misc/networkmanager-1.10.6:0/0::dantrell-gnome, ebuild scheduled for merge)
    (sys-auth/consolekit-0.4.6:0/0::dantrell-gnome, ebuild scheduled for merge)
    (xfce-base/exo-0.12.0:0/0::gentoo, ebuild scheduled for merge)
    (gnome-base/gnome-shell-common-0.0.1-r1:0/0::dantrell-gnome, ebuild scheduled for merge)
    (xfce-base/libxfce4ui-4.13.4:0/0::gentoo, ebuild scheduled for merge)
    (xfce-base/xfconf-4.13.4:0/3::gentoo, ebuild scheduled for merge)

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by gnome-base/gnome-shell-3.26.2::dantrell-gnome-3-26
# required by gnome-extra/gnome-shell-extensions-3.26.2::dantrell-gnome-3-26
# required by gnome-base/gnome-shell-common-0.0.1-r1::dantrell-gnome
# required by @__auto_slot_operator_replace_installed__ (argument)
=gnome-base/gnome-settings-daemon-3.24.4

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Autounmask changes successfully written.

 * IMPORTANT: config file '/etc/portage/package.unmask' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! Problems have been detected with your world file
!!! Please run emaint --check world


!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
gnome-base/gnome gnome-base/gnome:2.0

!!! All ebuilds that could satisfy ">=gnome-base/gnome-settings-daemon-3.25.90[colord,policykit]" have been masked.
!!! One of the following masked packages is required to complete your request:
- gnome-base/gnome-settings-daemon-3.26.2::dantrell-gnome-3-26 (masked by: backtracking: missing dependency)

(dependency required by "gnome-base/gnome-control-center-3.26.2::dantrell-gnome-3-26" [installed])
(dependency required by "gnome-base/gnome-shell-3.26.2::dantrell-gnome-3-26" [installed])
(dependency required by "gnome-extra/gnome-shell-extensions-3.26.2::dantrell-gnome-3-26" [installed])
(dependency required by "gnome-base/gnome-shell-common-0.0.1-r1::dantrell-gnome" [ebuild])
(dependency required by "@__auto_slot_operator_replace_installed__" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21321
Location: here

PostPosted: Wed May 09, 2018 9:58 am    Post subject: Reply with quote

Prova con solo
Code:
# emerge -uUNv --with-bdeps y --verbose-conflicts --autounmask n @world

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 10:04 am    Post subject: Reply with quote

cosi sta andando senza problemi ...
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 10:28 am    Post subject: Reply with quote

se invece lancio
Code:
emerge -uDNv --with-bdeps y --backtrack=300 --verbose-conflicts @world


ruby fallisce la compilazione ecco il build log :
https://paste.pound-python.org/show/ciXaOzVUN6HlgO2cTRas/
e di cyrus-sasl
https://paste.pound-python.org/show/9wcd3ytCPNfHfW6PmGo6/

e openssh
https://paste.pound-python.org/show/wkDhksa2m4NlJP9AdOwj/
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21321
Location: here

PostPosted: Wed May 09, 2018 11:14 am    Post subject: Reply with quote

Si sono tutti errori relativi al fatto che ancora ti ha installato openssh-1.1.1 devi fare il downgrade.

EDIT: Per evitare questo potresti mettere in /etc//portage/make.conf
Code:
EMERGE_DEFAULT_OPTS="--autounmask n"

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 12:40 pm    Post subject: Reply with quote

a che versione ?
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 12:50 pm    Post subject: Reply with quote

io ho la versione 7.6_p1-r5 non e` che ti confondi con openssl ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21321
Location: here

PostPosted: Wed May 09, 2018 12:56 pm    Post subject: Reply with quote

drudox wrote:
io ho la versione 7.6_p1-r5 non e` che ti confondi con openssl ?

Si scusa intendevo openssl
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 1:13 pm    Post subject: Reply with quote

Code:
sysresccd / # emerge -u =dev-libs/openssl-1.0.2o
7Calculating dependencies... done!
[ebuild     UD ] dev-libs/openssl-1.0.2o [1.1.1_pre6] USE="sslv3%* tls-heartbeat* -gmp% -kerberos% -sslv2%"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2o:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.1:0/0=[-bindist] required by (net-misc/openssh-7.6_p1-r5:0/0::gentoo, installed)
                            ^^^^^                                                                                                             
    =dev-libs/openssl-1.0.2o (Argument)
    (and 2 more with the same problems)

  (dev-libs/openssl-1.1.1_pre6:0/1.1::gentoo, installed) pulled in by
    >=dev-libs/openssl-1.0.1h-r2:0/1.1=[abi_x86_32(-),abi_x86_64(-)] required by (app-crypt/mit-krb5-1.16-r2:0/0::gentoo, installed)
                                ^^^^^^^                                                                                                                                 
    (and 23 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


se non ci fossi tu ... :)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21321
Location: here

PostPosted: Wed May 09, 2018 1:42 pm    Post subject: Reply with quote

Aggiungi anche l'opzione --backtrack=30
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 1:46 pm    Post subject: Reply with quote

Code:
sysresccd / # emerge -u =dev-libs/openssl-1.0.2o --backtrack=30
Calculating dependencies... done!
[ebuild     UD ] dev-libs/openssl-1.0.2o [1.1.1_pre6] USE="sslv3%* tls-heartbeat* -gmp% -kerberos% -sslv2%"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2o:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0/0= required by (dev-lang/ruby-2.3.7:2.3/2.3::gentoo, installed)
                    ^^^^^                                                                                                 
    =dev-libs/openssl-1.0.2o (Argument)
    (and 2 more with the same problems)

  (dev-libs/openssl-1.1.1_pre6:0/1.1::gentoo, installed) pulled in by
    dev-libs/openssl:0/1.1= required by (net-analyzer/nmap-7.70:0/0::gentoo, installed)
                    ^^^^^^^                                                                                               
    (and 23 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


nulla :(
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21321
Location: here

PostPosted: Wed May 09, 2018 1:59 pm    Post subject: Reply with quote

Ok allora cerca di fare manualmente, ovvero aggiungi --verbose-conflicts e poi fai un emerge -1 di openssl seguito da tutti i pacchetti che conflittano.
Esempio:
Code:
  (dev-libs/openssl-1.1.1_pre6:0/1.1::gentoo, installed) pulled in by
    dev-libs/openssl:0/1.1= required by (net-analyzer/nmap-7.70:0/0::gentoo, installed)
                    ^^^^^^^                                                                                               
    (and 23 more with the same problem)

Code:
# emerge -1 =dev-libs/openssl-1.0.2o net-analyzer/nmap ...

e sostituisci i 3 punti con tutti i pacchetti che danno problemi
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 2:53 pm    Post subject: Reply with quote

Code:
sysresccd / # emerge -1 =dev-libs/openssl-1.0.2o net-analyzer/nmap dev-perl/Net-SSLeay net-misc/iputils app-text/mupdf www-client/w3m app-crypt/rhash net-misc/dhcp www-servers/apache app-admin/apache-tools net-misc/wget x11-base/xorg-server net-nds/openldap dev-vcs/git net-wireless/wpa_supplicant dev-python/cryptography app-arch/libarchive app-crypt/mit-krb5 net-misc/curl media-sound/pulseaudio net-libs/neon dev-python/m2crypto dev-lang/python net-dns/bind net-misc/openssh dev-lang/ruby
Calculating dependencies |

!!! Problem resolving dependencies for net-dns/bind
... done!

!!! The ebuild selected to satisfy "net-dns/bind" has unmet requirements.
- net-dns/bind-9.12.1::gentoo USE="berkdb caps ipv6 ldap ssl threads xml zlib -dlz -dnsrps -dnstap -doc -fixed-rrset -geoip -gost -gssapi -idn -json -libressl -lmdb -mysql -nslint -odbc -postgres -python -rpz (-seccomp) (-selinux) -static-libs -urandom" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6"

  The following REQUIRED_USE flag constraints are unsatisfied:
    berkdb? ( dlz ) ldap? ( dlz )

  The above constraints are a subset of the following complete expression:
    postgres? ( dlz ) berkdb? ( dlz ) mysql? ( dlz !threads ) odbc? ( dlz ) ldap? ( dlz ) gost? ( !libressl ssl ) threads? ( caps ) dnstap? ( threads ) python? ( any-of ( python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6 ) )


mamma mia .... ma perche` non va ? ho provato anche con backtrack=30
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21321
Location: here

PostPosted: Wed May 09, 2018 3:08 pm    Post subject: Reply with quote

Questo e' un'altro problema ma facilmente risolvibile.
Code:
  The following REQUIRED_USE flag constraints are unsatisfied:
    berkdb? ( dlz ) ldap? ( dlz )

Praticamente portage ti dice che se usi ldap o berkdb come use flag nel pacchetto net-dns/bind allora devi anche abilitare la use flag dlz,
quindi aggiungi in package.use la linea net-dns/bind dlz
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 3:35 pm    Post subject: Reply with quote

Code:
sysresccd / # emerge -1 =dev-libs/openssl-1.0.2o net-analyzer/nmap dev-perl/Net-SSLeay net-misc/iputils app-text/mupdf www-client/w3m app-crypt/rhash net-misc/dhcp www-servers/apache app-admin/apache-tools net-misc/wget x11-base/xorg-server net-nds/openldap dev-vcs/git net-wireless/wpa_supplicant dev-python/cryptography app-arch/libarchive app-crypt/mit-krb5 net-misc/curl media-sound/pulseaudio net-libs/neon dev-python/m2crypto dev-lang/python net-dns/bind net-misc/openssh dev-lang/ruby --backtrack=30
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-ruby/rdoc-5.1.0[ruby_targets_ruby25]".
!!! One of the following packages is required to complete your request:
- dev-ruby/rdoc-6.0.1::gentoo (Change USE: +ruby_targets_ruby25)
(dependency required by "dev-lang/ruby-2.5.1::gentoo[rdoc]" [ebuild])
(dependency required by "dev-lang/ruby" [argument])


altro problema ...
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 3:38 pm    Post subject: Reply with quote

ho aggiunto al package use

Code:
dev-ruby/rdoc ruby_targets_ruby25


ma ne spunta sempre uno nuovo ...
sempre di ruby/*
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 603

PostPosted: Wed May 09, 2018 3:40 pm    Post subject: Reply with quote

drudox wrote:
ho aggiunto al package use

Code:
dev-ruby/rdoc ruby_targets_ruby25


ma ne spunta sempre uno nuovo ...
sempre di ruby/*


non si possono conoscere tutti insieme ? lo ho gia fatto 6 volte ..
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21321
Location: here

PostPosted: Wed May 09, 2018 3:51 pm    Post subject: Reply with quote

drudox wrote:
non si possono conoscere tutti insieme ? lo ho gia fatto 6 volte ..

Che RUBY_TARGETS sono settati (emerge --info | grep RUBY_TARGETS)?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum