Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201805-04 ] rsync
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2114

PostPosted: Tue May 08, 2018 4:26 pm    Post subject: [ GLSA 201805-04 ] rsync Reply with quote

Gentoo Linux Security Advisory

Title: rsync: Arbitrary command execution (GLSA 201805-04)
Severity: normal
Exploitable: remote
Date: 2018-05-08
Bug(s): #646818
ID: 201805-04

Synopsis

A vulnerability in rsync might allow remote attackers to execute
arbitrary commands.


Background

File transfer program to keep remote files into sync.

Affected Packages

Package: net-misc/rsync
Vulnerable: < 3.1.3
Unaffected: >= 3.1.3
Architectures: All supported architectures


Description

A vulnerability was discovered in rsync’s parse_arguments function in
options.c.


Impact

Remote attackers could possibly execute arbitrary commands with the
privilege of the process.


Workaround

There is no known workaround at this time.

Resolution

All rsync users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-misc/rsync-3.1.3"
   


References

CVE-2018-5764
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum