Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] cups-2.2.7 generates authentication error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 496
Location: USA

PostPosted: Mon May 07, 2018 1:19 am    Post subject: [SOLVED] cups-2.2.7 generates authentication error Reply with quote

As a consequence of a recent emerge world, CUPS (localhost:631) produces an Unauthorized error message when I, for example, try to Set Default Options. In the past, a graphic window would pop up in which I could provide root authentication. I am still a member of the lp and lpadmin groups. My work-around is to boot a browser as root.

I suspect there is a permission error somewhere and would be grateful for any hints toward a correction.

[SOLVED] Installing the masked version, net-print/cups-2.3_beta4, restored the old, desired, behavior. [/SOLVED]
[UPDATE] I note that cups-2.3_beta4 works only with firefox-bin-60.0 and still not with chromium-67.0.3396.62 so my initial problem may have been with the browser and not with cups itself. So using Firefox becomes my new, somewhat better, workaround. [/UPDATE]


Last edited by cfgauss on Sat Jun 02, 2018 8:42 pm; edited 2 times in total
Back to top
View user's profile Send private message
figueroa
Guru
Guru


Joined: 14 Aug 2005
Posts: 336
Location: GA-USA

PostPosted: Fri May 11, 2018 4:14 pm    Post subject: Reply with quote

I updated cups on my Intel x86_64 system this morning. It was uneventful, though stopping cupsd is tricky. There was an elog about what to do:

Code:
killall cupsd
/etc/init.d/cupsd zap
/etc/init.d/cupsd start


The zap command argument was new to me.
_________________
Andy Figueroa
andy@andyfigueroa.net Working with Unix since 1983.
Back to top
View user's profile Send private message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 496
Location: USA

PostPosted: Fri May 11, 2018 7:41 pm    Post subject: Reply with quote

figueroa wrote:
I updated cups on my Intel x86_64 system this morning. It was uneventful, though stopping cupsd is tricky. There was an elog about what to do:
Code:
killall cupsd
/etc/init.d/cupsd zap
/etc/init.d/cupsd start

The zap command argument was new to me.

Thanks for the suggestion. I did this but still have the same error. Here's the exact error message when I Set Default Options:
Code:
Unauthorized
Enter your username and password or the root username and password to access this page. If you are using Kerberos authentication, make sure you have a valid Kerberos ticket.

The kerberos USE flag is not set on net-print/cups-2.2.7.
Back to top
View user's profile Send private message
Hammett
Apprentice
Apprentice


Joined: 26 Jan 2005
Posts: 153
Location: Barcelona, Catalonia

PostPosted: Fri Jun 01, 2018 4:13 pm    Post subject: Reply with quote

I have the same issue. Reverting to CUPS 2.2.6 solves the issue as it asks again for the root password.

Strangely enough, my user is in lpadmin, but I get asked the root password nonetheless.
_________________
I don't fear the people. I fear the demon inside them.
Back to top
View user's profile Send private message
cfgauss
Guru
Guru


Joined: 18 May 2005
Posts: 496
Location: USA

PostPosted: Fri Jun 01, 2018 9:45 pm    Post subject: Reply with quote

Hammett wrote:
...Reverting to CUPS 2.2.6 solves the issue as it asks again for the root password...

It's also possible to go forward: adding the line =net-print/cups-2.3_beta4 ** to /etc/portage/package.accept_keywords allowed that version of cups to install and it has the desired, "normal," behavior.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum