Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
System hängt beim Booten bei „Mounting network filesystems“
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2289
Location: Konradsreuth (Germany)

PostPosted: Mon Apr 30, 2018 6:38 pm    Post subject: System hängt beim Booten bei „Mounting network filesystems“ Reply with quote

Hallo allerseits!

Ich bin gerade dabei, ein altes Gentoo-Notebook mit lxqt als Mini-Desktop zu reaktivieren. Dabei ist scheinbar die Netzwerkkonfiguration verloren gegangen. Heißt: das Netzwerk ist gerade nicht verfügbar.

Der Rechner nutzt Portage per NFS. Und jetzt hängt das System eine gefühlte Ewigkeit bei „Mounting network filesystems“ beim Booten. Nach gefühlten 10 Minuten kommt eine Fehlermeldung, und dann geht es trotzdem weiter.

Jetzt soll ja mal sowas komplett Verrücktes passieren, wie z. B. dass man bei einem Notebook das Netzwerkkabel nicht eingesteckt hat. Hat man in dem Fall die Chance (ohne den NetworkManager zu nutzen), dem Service mitzuteilen, dass er doch bitte nur kurz schauen soll, ob's geht, und wenn nicht, nicht 10 Minuten warten soll, ob er nicht doch ein NFS-Share mounten kann? Die fstab-Optionen "soft" und "timeo=30" haben nichts geändert.

Vielen Dank für jede Aufklärung ;-)
Back to top
View user's profile Send private message
hafgan
n00b
n00b


Joined: 27 Sep 2012
Posts: 39

PostPosted: Wed May 02, 2018 6:03 pm    Post subject: Reply with quote

Versuchs doch mal mit der Option "nofail" oder "noauto" in der fstab:
https://wiki.ubuntuusers.de/mount/#Optionen

hafgan
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2289
Location: Konradsreuth (Germany)

PostPosted: Thu May 03, 2018 6:28 pm    Post subject: Reply with quote

"nofail" steht schon drin, "noauto" würde das automatische Mounten unterbinden, und nur festlegen, was eingehängt wird, wenn manuell der Mountpunkt gemountet wird (damit man nicht die Quelle angeben muss). Also beides leider nicht die Lösung …
Back to top
View user's profile Send private message
hafgan
n00b
n00b


Joined: 27 Sep 2012
Posts: 39

PostPosted: Fri May 04, 2018 2:43 pm    Post subject: Reply with quote

Naja, das wäre doch interessant zu sehen, ob es mit der "noauto" Option im Nachgang und manuell problemlos funktioniert. Vielleicht ist beim Boot zum Zeitpunkt des Mountens das Netzwerk noch gar nicht da und dann kann er gar keine NFS mounten und bleibt hängen...

Das erinnert mich ein bisschen an den Dienst ntpdate, der meistens beim Boot fehl schlägt, da das Netzwerk noch nicht bereit ist...

(Alles reine Spekulation...)

hafgan
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2289
Location: Konradsreuth (Germany)

PostPosted: Fri May 04, 2018 6:28 pm    Post subject: Reply with quote

Naja, wenn ich kein WLAN konfiguriert habe, und kein Netzwerkkabel angesteckt ist, dann liegt in der Tat zum einen der Verdacht nahe, dass beim Booten das Netzwerk nicht zur Verfügung steht, und zum anderen, dass auch ein manuelles Mounten der NFS-Shares zu einem späteren Zeitpunkt wenig Aussicht auf Erfolg hat ;-)

Last edited by l3u on Wed May 09, 2018 5:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
hafgan
n00b
n00b


Joined: 27 Sep 2012
Posts: 39

PostPosted: Sat May 05, 2018 8:35 am    Post subject: Reply with quote

Das stimmt natürlich.
Wer lesen kann ... Sorry!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum