Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved +/-] many KDE programs crashing.....
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 02 Nov 2004
Posts: 120

PostPosted: Fri Apr 27, 2018 3:54 pm    Post subject: [solved +/-] many KDE programs crashing..... Reply with quote

Hi everyone,
when I start kmail, kontact, konqueror, qupzilla, bibletime I obtained:

gdb kmail
[New Thread 0x7fffb738e700 (LWP 26024)]
[New Thread 0x7fffb6947700 (LWP 26025)]
[New Thread 0x7fffb6146700 (LWP 26028)]
[New Thread 0x7fffa7fff700 (LWP 26039)]
[New Thread 0x7fffa6c68700 (LWP 26042)]
[New Thread 0x7fffa6467700 (LWP 26047)]
[New Thread 0x7fffa5c66700 (LWP 26048)]
[New Thread 0x7fffa5465700 (LWP 26049)]
[New Thread 0x7fffa4c64700 (LWP 26050)]
[New Thread 0x7fff8bfff700 (LWP 26051)]
[New Thread 0x7fff8b7fe700 (LWP 26052)]
[New Thread 0x7fff8affd700 (LWP 26053)]
[New Thread 0x7fff8a7fc700 (LWP 26054)]
[New Thread 0x7fff89ffb700 (LWP 26055)]
[New Thread 0x7fff897fa700 (LWP 26056)]
[New Thread 0x7fff88ff9700 (LWP 26057)]
[New Thread 0x7fff6bfff700 (LWP 26058)]
[New Thread 0x7fff6b7fe700 (LWP 26059)]
[New Thread 0x7fff6affd700 (LWP 26060)]
[New Thread 0x7fff6a7fc700 (LWP 26061)]
[New Thread 0x7fff69ffb700 (LWP 26062)]
[New Thread 0x7fff697fa700 (LWP 26063)]
[New Thread 0x7fff68ff9700 (LWP 26064)]

Thread 24 "Chrome_InProcGp" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fff69ffb700 (LWP 26062)]
0x00007ffff50bea70 in free () from /lib64/
(gdb) bt
#0  0x00007ffff50bea70 in free () from /lib64/
#1  0x00007fffdf024db2 in ?? () from /usr/lib64/
#2  0x00007fffdf023a2e in ?? () from /usr/lib64/
#3  0x00007fffdf024a61 in ?? () from /usr/lib64/
#4  0x00007fffe26e5d48 in ?? () from /usr/lib64/
#5  0x00007fffdf8461ad in ?? () from /usr/lib64/
#6  0x00007fffdf8421b2 in ?? () from /usr/lib64/
#7  0x00007fffeabea907 in start_thread () from /lib64/
#8  0x00007ffff51345ef in clone () from /lib64/

for all these programs. This with kde-plasma-5.11 and 12, kde-frameworks 5.43,44 and 45, kde-apps 17.12 and 18.04.
with the kernel 4.9.76 and 95 and 4.14.35.

EDIT: I try to recompile glibc, xorg-server, nspr and nss. Some message disappared but segfault remain.


Portage 2.3.24 (python 3.4.8-final-0, default/linux/amd64/17.0/no-multilib, gcc-6.4.0, glibc-2.25-r11, 4.9.95-gentoo-r0 x86_64)
System uname: Linux-4.9.95-gentoo-r0-x86_64-Intel-R-_Core-TM-_i7_CPU_950_@_3.07GHz-with-gentoo-2.4.1
KiB Mem:    12297932 total,    421948 free
KiB Swap:    1228796 total,   1228784 free
Timestamp of repository gentoo: Thu, 26 Apr 2018 22:45:01 +0000
Head commit of repository gentoo: 6c051f0521a53f029bc266f8dfd02bd2030c3c2b
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.24.3-r1::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.4.8::gentoo, 3.5.5::gentoo, 3.6.5::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.14.1-r2::gentoo, 1.15.1-r2::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r11::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000
    sync-rsync-verify-metamanifest: no

    location: /usr/local/stefano
    masters: gentoo
    priority: 0

    location: /usr/local/portage/science
    sync-type: laymansync
    masters: gentoo
    priority: 50

    location: /usr/local/portage/stuff
    masters: gentoo
    priority: 50

    location: /usr/local/portage/tamiko
    masters: gentoo
    priority: 50

CFLAGS="-march=corei7 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe"
EMERGE_DEFAULT_OPTS="--jobs=4 --load-average=4 --keep-going=n --with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=" rsync://"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4 -l4"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="X Xaw3d aalib acl acpi alsa amd64 amr berkdb bluetooth bluray bzip2 cairo caps cdr chromaprint cli consolekit crypt cuda cups curl cxx dbus dirac djvu dri dvd egl eglfs exif expat faac faad fam fbcon ffmpeg fftw fontconfig fontforge fortran frei0r gdbm gnutls gpg gphoto2 graphicsmagick gstreamer gtk iconv icu ieee1394 introspection ipv6 java jbig jpeg jpeg2k latex lcms libcaca libinput libnotify lua lzma mng modules mp3 music mysql ncurses nls nptl nvenc ocaml odbc ogg opencl openexr opengl openh264 openmp openssl pam pch pcre pdf perl phonon png policykit postscript private-headers ps python qml qt5 readline reports scanner schroedinger sdl seccomp semantic-desktop slang smp snmp speex spell sqlite ssh ssl svg swig tcl tcpd theora thumbnail tiff tk truetype udev unicode usb v4l v4l2 vaapi vdpau vorbis wayland widgets wmf x264 xattr xcb xinerama xml xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon plan sheets stage words gemini" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 ssse3 sse4_1 sse4_2" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev libinput" KERNEL="linux" L10N="it" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console nlpsolver pdfimport scripting-beanshell scripting-javascript wiki-publisher" LLVM_TARGETS="X86 NVPTX BPF" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6" RUBY_TARGETS="ruby22 ruby24" SANE_BACKENDS="canon canon_dr canon630u epson epson2 hp hp3500 hp3900 hp4200 hp5400 hp5590 hpljm105 net pixma" USERLAND="GNU" VIDEO_CARDS="nvidia v4l fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

I try to upgrade qtlibs (now 5.9.5) but nothing change.
All the other apps in kde, included korganizer and kaddressbook, start and work as expected, in all the listed situation.

Please help me. Thanks.
stelinux on Ryzen 9 3900x on ROG Crosshair Hero VIII wifi 32GB G.Skill F4-3200C14D-16GFX CL16-16-16-39, 1.2 V
gentoo 17.1/no-multilib Sapphire Radeon RX 5700 XT 8G GDDR6 HDMI/TRIPLE DP OC W/ BP (UEFI)
openrc elogind kde

Last edited by stelinux on Fri Jun 08, 2018 10:48 pm; edited 3 times in total
Back to top
View user's profile Send private message

Joined: 30 Sep 2004
Posts: 219
Location: Cali - Colombia

PostPosted: Sun May 13, 2018 8:18 pm    Post subject: Reply with quote

Are you using the nouveau driver for your graphic card?
This driver crashes qtwebengine
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 02 Nov 2004
Posts: 120

PostPosted: Sun May 13, 2018 11:09 pm    Post subject: Reply with quote

Thanks Bec but I use only nvidia-drivers-390.42 with gentoo-sources-4.9.95

EDIT: I've try to compile qtwebengine with -fno-delete-null-pointer-checks but segfault still remain.
EDIT: I've try

gdb kmail
[New Thread 0x7fffb7379700 (LWP 5204)]
[New Thread 0x7fffb6932700 (LWP 5205)]
[New Thread 0x7fffb6131700 (LWP 5206)]
[New Thread 0x7fffa7fff700 (LWP 5216)]
Sandboxing disabled by user.
[New Thread 0x7fffa6c68700 (LWP 5221)]
[New Thread 0x7fffa6467700 (LWP 5223)]
[New Thread 0x7fffa5a5a700 (LWP 5224)]
[New Thread 0x7fffa5259700 (LWP 5225)]
[New Thread 0x7fffa4a58700 (LWP 5226)]
[New Thread 0x7fff8bfff700 (LWP 5227)]
[New Thread 0x7fff8b7fe700 (LWP 5228)]
[New Thread 0x7fff8affd700 (LWP 5229)]
[New Thread 0x7fff8a7fc700 (LWP 5230)]
[New Thread 0x7fff89ffb700 (LWP 5231)]
[New Thread 0x7fff897fa700 (LWP 5232)]
[New Thread 0x7fff88ff9700 (LWP 5233)]
[New Thread 0x7fff67fff700 (LWP 5234)]
[New Thread 0x7fff677fe700 (LWP 5235)]
[New Thread 0x7fff66ffd700 (LWP 5236)]
[New Thread 0x7fff667fc700 (LWP 5237)]
[New Thread 0x7fff65ffb700 (LWP 5238)]

Thread 21 "Chrome_InProcGp" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fff677fe700 (LWP 5235)]
0x00007ffff50bda70 in free () from /lib64/
(gdb) bt
#0  0x00007ffff50bda70 in free () from /lib64/
#1  0x00007fffdf01cdb2 in ?? () from /usr/lib64/
#2  0x00007fffdf01ba2e in ?? () from /usr/lib64/
#3  0x00007fffdf01ca61 in ?? () from /usr/lib64/
#4  0x00007fffe26e0fe8 in ?? () from /usr/lib64/
#5  0x00007fffdf83e1fd in ?? () from /usr/lib64/
#6  0x00007fffdf83a202 in ?? () from /usr/lib64/
#7  0x00007fffeabec907 in start_thread () from /lib64/
#8  0x00007ffff51335ef in clone () from /lib64/

but the result does not change :(

EDIT: falkon (qupzilla) start with --disable-gpu :)
EDIT: also tried with sys-devel/gcc-7.3.0-r3, sys-libs/glibc-2.26-r7 and binutils-libs-2.30-r2(64-bit-bfd...) but the result does not change :(
and not change with x11-drivers/nvidia-drivers-396.24(0/396) :(

EDIT: after set "export QTWEBENGINE_CHROMIUM_FLAGS="--disable-gpu"" on etc/env.d/12qtwebengine then everything start correctly. :)
stelinux on Ryzen 9 3900x on ROG Crosshair Hero VIII wifi 32GB G.Skill F4-3200C14D-16GFX CL16-16-16-39, 1.2 V
gentoo 17.1/no-multilib Sapphire Radeon RX 5700 XT 8G GDDR6 HDMI/TRIPLE DP OC W/ BP (UEFI)
openrc elogind kde
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum