Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Inconsistent CJK font display [solved]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 05 Jul 2002
Posts: 791

PostPosted: Fri Apr 27, 2018 1:02 pm    Post subject: Inconsistent CJK font display [solved] Reply with quote

I have a new installation of gentoo and everything seems to be coming together except for CJK support. This doesn't usually seem to be something I have to worry about as long as I have the appropriate fonts installed these days, so I'm at a loss with regards to what I'm missing. Non-latin characters seem to display fine in GTK (or at least Firefox) and mpv, but they do not show up properly in Qt (I'm using KDE) or rxvt-unicode.

Perhaps somewhat amusingly, I say Qt apps don't display CJK properly, but the titlebar seems to render non-latin characters properly, as illustrated by the mpv screenshot. Something that the mpv screenshot doesn't show properly is that the OSD (which displays the filename/title of the video being played) displays properly.

I initially just installed the noto-cjk fontset. When I was still having issues with non-latin characters, I eventually remembered the cjk USE flag, which didn't actually affect many packages. I also eventually installed/enabled IBus. I also installed the fonts referenced in the How to read and write in Japanese wiki page.Nothing seemed to resolve the display issues.

One other observation, I can use IBus-Anthy to write Japanese characters in Kate, but I can't write Japanese characters in rxvt-unicode (which has worked in the past, at least in different gentoo installations).

Here are some examples of how the same directory looks in different apps.

Some config files:

  • /etc/fonts/local.conf - only real fontconfig related change I've made. Makes default Sans and Serif font Cantarell and default Monospace font Hack. I know this isn't (directly) the issue since I've used it in multiple installs without this behavior. I also removed local.conf in my testing and didn't change the display behavior.
  • /etc/portage/make.conf
  • /etc/portage/package.use/*

Any help would be appreciated. I have a feeling based off past experience I'm going to feel real dumb when I find the resolution.


Not sure if it was actually what I did, but things seem to be working properly now. Turns out I never set my locale, so I set that to en_US.utf8.

I also ran an update earlier this afternoon which seemed to be the point after which things started working. If nothing else, harfbuzz had an update. I rebooted and now non-latin characters are displaying properly.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum