Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] xinit: connection to X server lost
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Semantika
n00b
n00b


Joined: 19 Feb 2018
Posts: 20

PostPosted: Tue Apr 24, 2018 4:26 am    Post subject: [SOLVED] xinit: connection to X server lost Reply with quote

Hello community,

I have been trying to install X and I can't startx. It seems it is a problem with the evdev INPUT_DEVICES, though I am not quite sure. I leave the log here in hope someone is able to tell me what is wrong:

Code:


[   153.376]
X.Org X Server 1.19.5
Release Date: 2017-10-12
[   153.380] X Protocol Version 11, Revision 0
[   153.381] Build Operating System: Linux 4.14.20-std521-amd64 x86_64 Gentoo
[   153.382] Current Operating System: Linux Sofinha 4.16.3-gentoo #3 SMP Mon Apr 23 20:47:26 CDT 2018 x86_64
[   153.382] Kernel command line: BOOT_IMAGE=/vmlinuz-4.16.3-gentoo root=/dev/sda4 ro
[   153.384] Build Date: 23 April 2018  05:21:48PM
[   153.385] 
[   153.386] Current version of pixman: 0.34.0
[   153.388]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   153.388] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   153.391] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Apr 23 22:47:31 2018
[   153.392] (==) Using config file: "/etc/X11/xorg.conf"
[   153.393] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   153.394] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   153.394] (==) ServerLayout "Layout0"
[   153.394] (**) |-->Screen "Screen0" (0)
[   153.394] (**) |   |-->Monitor "Monitor0"
[   153.394] (**) |   |-->Device "Device0"
[   153.394] (**) |   |-->GPUDevice "Device0"
[   153.394] (**) |-->Input Device "Keyboard0"
[   153.394] (**) |-->Input Device "Mouse0"
[   153.394] (==) Automatically adding devices
[   153.394] (==) Automatically enabling devices
[   153.394] (==) Automatically adding GPU devices
[   153.394] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   153.394] (==) FontPath set to:
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[   153.394] (**) ModulePath set to "/usr/lib64/xorg/modules"
[   153.394] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   153.394] (WW) Disabling Keyboard0
[   153.394] (WW) Disabling Mouse0
[   153.394] (II) Loader magic: 0x55618edc6c40
[   153.394] (II) Module ABI versions:
[   153.394]    X.Org ANSI C Emulation: 0.4
[   153.394]    X.Org Video Driver: 23.0
[   153.394]    X.Org XInput driver : 24.1
[   153.394]    X.Org Server Extension : 10.0
[   153.395] (II) xfree86: Adding drm device (/dev/dri/card1)
[   153.395] (II) xfree86: Adding drm device (/dev/dri/card0)
[   153.403] (--) PCI:*(0:0:2:0) 8086:0166:1043:1467 rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[   153.403] (--) PCI: (0:1:0:0) 10de:1140:1043:2132 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[   153.403] (II) LoadModule: "glx"
[   153.403] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   153.404] (II) Module glx: vendor="X.Org Foundation"
[   153.404]    compiled for 1.19.5, module version = 1.0.0
[   153.404]    ABI class: X.Org Server Extension, version 10.0
[   153.404] (II) LoadModule: "intel"
[   153.404] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[   153.404] (II) Module intel: vendor="X.Org Foundation"
[   153.404]    compiled for 1.19.5, module version = 2.99.917
[   153.404]    Module class: X.Org Video Driver
[   153.404]    ABI class: X.Org Video Driver, version 23.0
[   153.404] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[   153.404] (II) intel: Driver for Intel(R) HD Graphics
[   153.404] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[   153.404] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[   153.405] (--) using VT number 7

[   153.421] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20171222
[   153.433] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4000
[   153.433] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx; using a maximum of 2 threads
[   153.433] (**) intel(0): Depth 24, (--) framebuffer bpp 32
[   153.433] (==) intel(0): RGB weight 888
[   153.433] (==) intel(0): Default visual is TrueColor
[   153.434] (II) intel(0): Output LVDS1 using monitor section Monitor0
[   153.434] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output LVDS1
[   153.434] (II) intel(0): Enabled output LVDS1
[   153.434] (II) intel(0): Output VGA1 has no monitor section
[   153.434] (II) intel(0): Enabled output VGA1
[   153.434] (II) intel(0): Output HDMI1 has no monitor section
[   153.435] (II) intel(0): Enabled output HDMI1
[   153.435] (II) intel(0): Output DP1 has no monitor section
[   153.435] (II) intel(0): Enabled output DP1
[   153.435] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[   153.435] (II) intel(0): Output VIRTUAL1 has no monitor section
[   153.435] (II) intel(0): Enabled output VIRTUAL1
[   153.435] (--) intel(0): Output LVDS1 using initial mode 1366x768 on pipe 0
[   153.435] (==) intel(0): TearFree disabled
[   153.435] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[   153.435] (==) intel(0): DPI set to (96, 96)
[   153.435] (II) Loading sub module "dri3"
[   153.435] (II) LoadModule: "dri3"
[   153.435] (II) Module "dri3" already built-in
[   153.435] (II) Loading sub module "dri2"
[   153.435] (II) LoadModule: "dri2"
[   153.435] (II) Module "dri2" already built-in
[   153.435] (II) Loading sub module "present"
[   153.435] (II) LoadModule: "present"
[   153.435] (II) Module "present" already built-in
[   153.435] (==) Depth 24 pixmap format is 32 bpp
[   153.436] (II) intel(0): SNA initialized with Ivybridge (gen7, gt2) backend
[   153.436] (==) intel(0): Backing store enabled
[   153.436] (==) intel(0): Silken mouse enabled
[   153.436] (II) intel(0): HW Cursor enabled
[   153.436] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[   153.436] (**) intel(0): DPMS enabled
[   153.436] (==) intel(0): Display hotplug detection enabled
[   153.436] (II) intel(0): [DRI2] Setup complete
[   153.436] (II) intel(0): [DRI2]   DRI driver: i965
[   153.436] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[   153.436] (II) intel(0): direct rendering: DRI2 enabled
[   153.436] (II) intel(0): hardware support for Present enabled
[   153.436] (--) RandR disabled
[   153.446] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[   153.446] (II) AIGLX: enabled GLX_ARB_create_context
[   153.446] (II) AIGLX: enabled GLX_ARB_create_context_profile
[   153.446] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
[   153.446] (II) AIGLX: enabled GLX_INTEL_swap_event
[   153.446] (II) AIGLX: enabled GLX_SGI_swap_control
[   153.446] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[   153.446] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[   153.446] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
[   153.446] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[   153.446] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[   153.446] (II) AIGLX: Loaded and initialized i965
[   153.446] (II) GLX: Initialized DRI2 GL provider for screen 0
[   153.447] (II) intel(0): switch to mode 1366x768@60.0 on LVDS1 using pipe 0, position (0, 0), rotation normal, reflection none
[   153.451] (II) intel(0): Setting screen physical size to 361 x 203
[   153.516] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[   153.516] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   153.516] (II) LoadModule: "evdev"
[   153.516] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[   153.516] (II) Module evdev: vendor="X.Org Foundation"
[   153.516]    compiled for 1.19.5, module version = 2.10.5
[   153.516]    Module class: X.Org XInput Driver
[   153.516]    ABI class: X.Org XInput driver, version 24.1
[   153.516] (II) Using input driver 'evdev' for 'Power Button'
[   153.516] (**) Power Button: always reports core events
[   153.516] (**) evdev: Power Button: Device: "/dev/input/event2"
[   153.516] (--) evdev: Power Button: Vendor 0 Product 0x1
[   153.516] (--) evdev: Power Button: Found keys
[   153.516] (II) evdev: Power Button: Configuring as keyboard
[   153.516] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[   153.516] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[   153.516] (**) Option "xkb_rules" "evdev"
[   153.517] (II) config/udev: Adding input device Video Bus (/dev/input/event4)
[   153.517] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[   153.517] (II) Using input driver 'evdev' for 'Video Bus'
[   153.517] (**) Video Bus: always reports core events
[   153.517] (**) evdev: Video Bus: Device: "/dev/input/event4"
[   153.517] (--) evdev: Video Bus: Vendor 0 Product 0x6
[   153.517] (--) evdev: Video Bus: Found keys
[   153.517] (II) evdev: Video Bus: Configuring as keyboard
[   153.517] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:01/input/input4/event4"
[   153.517] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[   153.517] (**) Option "xkb_rules" "evdev"
[   153.518] (II) config/udev: Adding input device Video Bus (/dev/input/event3)
[   153.518] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[   153.518] (II) Using input driver 'evdev' for 'Video Bus'
[   153.518] (**) Video Bus: always reports core events
[   153.518] (**) evdev: Video Bus: Device: "/dev/input/event3"
[   153.518] (--) evdev: Video Bus: Vendor 0 Product 0x6
[   153.518] (--) evdev: Video Bus: Found keys
[   153.518] (II) evdev: Video Bus: Configuring as keyboard
[   153.518] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:02/LNXVIDEO:00/input/input3/event3"
[   153.518] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[   153.518] (**) Option "xkb_rules" "evdev"
[   153.518] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)
[   153.518] (II) No input driver specified, ignoring this device.
[   153.518] (II) This device may have been added with another device file.
[   153.519] (II) config/udev: Adding input device Sleep Button (/dev/input/event1)
[   153.519] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[   153.519] (II) Using input driver 'evdev' for 'Sleep Button'
[   153.519] (**) Sleep Button: always reports core events
[   153.519] (**) evdev: Sleep Button: Device: "/dev/input/event1"
[   153.519] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[   153.519] (--) evdev: Sleep Button: Found keys
[   153.519] (II) evdev: Sleep Button: Configuring as keyboard
[   153.519] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input1/event1"
[   153.519] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[   153.519] (**) Option "xkb_rules" "evdev"
[   153.520] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event7)
[   153.520] (II) No input driver specified, ignoring this device.
[   153.520] (II) This device may have been added with another device file.
[   153.520] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event8)
[   153.520] (II) No input driver specified, ignoring this device.
[   153.520] (II) This device may have been added with another device file.
[   153.520] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event9)
[   153.520] (II) No input driver specified, ignoring this device.
[   153.520] (II) This device may have been added with another device file.
[   153.521] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event5)
[   153.521] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[   153.521] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[   153.521] (**) AT Translated Set 2 keyboard: always reports core events
[   153.521] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event5"
[   153.521] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[   153.521] (--) evdev: AT Translated Set 2 keyboard: Found keys
[   153.521] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[   153.521] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input5/event5"
[   153.521] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 10)
[   153.521] (**) Option "xkb_rules" "evdev"
[   153.521] (II) config/udev: Adding input device PS/2 Generic Mouse (/dev/input/event10)
[   153.521] (**) PS/2 Generic Mouse: Applying InputClass "evdev pointer catchall"
[   153.521] (II) Using input driver 'evdev' for 'PS/2 Generic Mouse'
[   153.521] (**) PS/2 Generic Mouse: always reports core events
[   153.521] (**) evdev: PS/2 Generic Mouse: Device: "/dev/input/event10"
[   153.521] (--) evdev: PS/2 Generic Mouse: Vendor 0x2 Product 0x1
[   153.521] (--) evdev: PS/2 Generic Mouse: Found 3 mouse buttons
[   153.521] (--) evdev: PS/2 Generic Mouse: Found relative axes
[   153.521] (--) evdev: PS/2 Generic Mouse: Found x and y relative axes
[   153.521] (II) evdev: PS/2 Generic Mouse: Configuring as mouse
[   153.522] (**) evdev: PS/2 Generic Mouse: YAxisMapping: buttons 4 and 5
[   153.522] (**) evdev: PS/2 Generic Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   153.522] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input13/event10"
[   153.522] (II) XINPUT: Adding extended input device "PS/2 Generic Mouse" (type: MOUSE, id 11)
[   153.522] (II) evdev: PS/2 Generic Mouse: initialized for relative axes.
[   153.522] (**) PS/2 Generic Mouse: (accel) keeping acceleration scheme 1
[   153.522] (**) PS/2 Generic Mouse: (accel) acceleration profile 0
[   153.522] (**) PS/2 Generic Mouse: (accel) acceleration factor: 2.000
[   153.522] (**) PS/2 Generic Mouse: (accel) acceleration threshold: 4
[   153.634] (II) evdev: PS/2 Generic Mouse: Close
[   153.634] (II) UnloadModule: "evdev"
[   153.634] (II) evdev: AT Translated Set 2 keyboard: Close
[   153.634] (II) UnloadModule: "evdev"
[   153.634] (II) evdev: Sleep Button: Close
[   153.634] (II) UnloadModule: "evdev"
[   153.634] (II) evdev: Video Bus: Close
[   153.634] (II) UnloadModule: "evdev"
[   153.634] (II) evdev: Video Bus: Close
[   153.634] (II) UnloadModule: "evdev"
[   153.634] (II) evdev: Power Button: Close
[   153.635] (II) UnloadModule: "evdev"
[   153.723] (II) Server terminated successfully (0). Closing log file.



Why does it terminate before even starting? Thank you all for any information on the matter.


Last edited by Semantika on Tue Apr 24, 2018 2:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Tue Apr 24, 2018 10:53 am    Post subject: Reply with quote

Semantika ...

there are no "(EE) errors" there, so I suspect it has nothing to do with evdev or the xserver, do you have something providing a window manager or DE installed, and/or are you 'exec <wm>' in ~/.xinitrc?

If you've installed x11-base/xorg-server rather than x11-base/xorg-x11 then this won't provide a window manager, you'd need to install this seperately (ie, any of x11-wm/).

EDIT: I just read the threads subject line, you get this error from startx?

HTH & best ... khay
Back to top
View user's profile Send private message
Semantika
n00b
n00b


Joined: 19 Feb 2018
Posts: 20

PostPosted: Tue Apr 24, 2018 2:35 pm    Post subject: Reply with quote

Well, you were right, I was missing the wm invocation in xinitrc. I just wrote it down and everything went smoothly. Now I am choosing a desktop environment, I guess I'll choose fluxbox.

Thank you so much.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum