Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xmonad and Citrix Receiver
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
doc1623
Tux's lil' helper
Tux's lil' helper


Joined: 22 May 2017
Posts: 90

PostPosted: Sun Apr 22, 2018 2:45 pm    Post subject: Xmonad and Citrix Receiver Reply with quote

Hello,

I'm hoping I can get someone familiar with one or both of these. I use xmonad as my window manager and I have to have Citrix Receiver for work. I'm on Gentoo. I know I can tame this beast; I'm just not sure how.

What I want is to use the vdi in half the screen. So I can continue to switch between the vdi and my gentoo box. I have a wide monitor.

I use Xmonad but I'm no expert. I normally just leave things full screen and mod tab to go through my windows. When Citrix is conneced to my work vdi I can't do that. It seems to capture all keystrokes. I think the key is going to lie in creating a hook in my xmonad config but I don't know that well.

I've tried using Mod space and then Mod enter to move the vdi window to the main but it doesn't work. I know I can learn Xmonad inside out and then I could do it but I just don't have time. I'm back to work tomorrow. Let me know if you know how to deal with this or have a great tutorial link. In the meantime, I'll be trying to figure out Xmonad hooks!



Thanks for any help!
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13496

PostPosted: Sun Apr 22, 2018 3:59 pm    Post subject: Reply with quote

Based on your description, I think this is a Citrix problem, not an Xmonad problem. X11 permits applications to grab the keyboard and/or mouse, at which point all input from that device goes to the grabber. While the grab is active, your window manager will not get a chance to process the key first. As far as your window manager can see, you never pressed the key at all.

I found through Google some Citrix pages that suggest the Windows-hosted Citrix agent grabs the keyboard, so it seems likely that the Linux-hosted Citrix agent will also grab the keyboard. Unfortunately, Citrix IT still hasn't fixed their TLS configuration (despite having years to do so), so all connections fail with SSL_ERROR_UNSAFE_NEGOTIATION. Unless I reconfigure to allow unsafe negotiation, I can't get to their documentation to dig deeper.

If you want to see keyboard grabbing in action using only open tools:
  • Pick some Xmonad keybinding that definitely fails when Citrix Receiver is active.
  • With Citrix Receiver inactive, verify the binding works.
  • In an xterm, enable Secure Keyboard mode from the control+left-mouse-button pop-up.
  • Try your binding again. It should fail, because the xterm grabbed the keyboard.
  • Use control+LMB pop-up to end Secure Keyboard mode.
As for researching your problem, I would try keywords such as "Citrix receiver Linux keyboard grab".
Back to top
View user's profile Send private message
doc1623
Tux's lil' helper
Tux's lil' helper


Joined: 22 May 2017
Posts: 90

PostPosted: Sun Apr 22, 2018 9:04 pm    Post subject: Reply with quote

Hu wrote:
Based on your description, I think this is a Citrix problem, not an Xmonad problem. X11 permits applications to grab the keyboard and/or mouse, at which point all input from that device goes to the grabber. While the grab is active, your window manager will not get a chance to process the key first. As far as your window manager can see, you never pressed the key at all.

I found through Google some Citrix pages that suggest the Windows-hosted Citrix agent grabs the keyboard, so it seems likely that the Linux-hosted Citrix agent will also grab the keyboard. Unfortunately, Citrix IT still hasn't fixed their TLS configuration (despite having years to do so), so all connections fail with SSL_ERROR_UNSAFE_NEGOTIATION. Unless I reconfigure to allow unsafe negotiation, I can't get to their documentation to dig deeper.

If you want to see keyboard grabbing in action using only open tools:
  • Pick some Xmonad keybinding that definitely fails when Citrix Receiver is active.
  • With Citrix Receiver inactive, verify the binding works.
  • In an xterm, enable Secure Keyboard mode from the control+left-mouse-button pop-up.
  • Try your binding again. It should fail, because the xterm grabbed the keyboard.
  • Use control+LMB pop-up to end Secure Keyboard mode.
As for researching your problem, I would try keywords such as "Citrix receiver Linux keyboard grab".


Wow thank you for your efforts! I'll work on it!

I think there is a way just to have certain apps open to a specific size. Like I said I use Xmonad but I've never really worked/learned to configure it. I got stuck today in trying to install some ports. The latest Haskell-platform failed with

Code:

/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/../../../../x86_64-pc-linux-gnu/bin/ld: -r and -pie may not be used together
collect2: error: ld returned 1 exit status


but this was a bit down the rabbit hole because compiling the sample config failed

Code:

/usr/lib/gcc/x86_64-pc-linux-gnu/6.4.0/../../../../x86_64-pc-linux-gnu/bin/ld: final link failed: Nonrepresentable section on output
collect2: error: ld returned 1 exit status
`x86_64-pc-linux-gnu-gcc' failed in phase `Linker'. (Exit code: 1)

Please check the file for errors.

xmonad: xmessage: executeFile: resource exhausted (Argument list too long)


Code:

%xmonad --version                                                                                                                                                                                                                                                                                                         4780
xmonad 0.13


sample config from

/usr/share/xmonad-0.13/ghc-8.0.2/man/xmonad.hs

I thought maybe the sample failed because I was missing some dependencies
Back to top
View user's profile Send private message
doc1623
Tux's lil' helper
Tux's lil' helper


Joined: 22 May 2017
Posts: 90

PostPosted: Mon Apr 23, 2018 1:12 pm    Post subject: Reply with quote

FOUND IT

Thank YOU HU!

https://askubuntu.com/questions/744672/switch-to-host-desktop-from-citrix-session

Press ctrl+F2 in the citrix session. This enables keyboard shortcuts from the host system (Ubuntu).
Now you can use alt+tab to switch the focus to the application you used before opening citrix (or the desktop).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum