Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] dependency conflict: phonon-vlc[qt4,qt5] and phonon
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
m27315
Apprentice
Apprentice


Joined: 10 Dec 2004
Posts: 253
Location: 2 workstations down

PostPosted: Mon Apr 16, 2018 6:47 pm    Post subject: [SOLVED] dependency conflict: phonon-vlc[qt4,qt5] and phonon Reply with quote

After much googling and experimenting with USE flags, I neither understand nor can resolve the following emerge conflict message:

Code:
$ emerge -uDN @system @world
...
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:                                               
                                                                                                                                     
media-libs/phonon-vlc:0                                                                                                             
                                                                                                                                     
  (media-libs/phonon-vlc-0.10.1:0/0::gentoo, ebuild scheduled for merge) conflicts with                                             
    >=media-libs/phonon-vlc-0.9.0[qt4,qt5] required by (media-libs/phonon-4.9.1-r1:0/0::gentoo, installed)                           
                                  ^^^ ^^^                                                                                           
                                                                                                                                     
media-libs/phonon:0                                                                                                                 
                                                                                                                                     
  (media-libs/phonon-4.10.0:0/0::gentoo, ebuild scheduled for merge) conflicts with                                                 
    media-libs/phonon[qt4] required by (kde-frameworks/kdelibs-4.14.37:4/4.14::gentoo, installed)                                   
                      ^^^                                                                                                           
    >=media-libs/phonon-4.9.0[qt4,qt5] required by (media-libs/phonon-vlc-0.9.1-r1:0/0::gentoo, installed)                           
                              ^^^ ^^^                                                                                               


1) What does this mean?
2) How do I resolve the conflict?

Thanks!


Last edited by m27315 on Mon Apr 16, 2018 9:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6384
Location: Austria

PostPosted: Mon Apr 16, 2018 6:59 pm    Post subject: Reply with quote

It is not a problem that you immediately have to fix, they are just updates skipped.

A package on your system depends on phonon[qt4]. It likely is kdelibs. Find out why it is still on your system, you can probable remove it.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
m27315
Apprentice
Apprentice


Joined: 10 Dec 2004
Posts: 253
Location: 2 workstations down

PostPosted: Mon Apr 16, 2018 7:04 pm    Post subject: Reply with quote

I have been living with it for a month or more, so I agree it is not urgent, but I am mostly concerned the meaning of the message. Why are those packages incompatible? ... I understand version conflicts, but I'm baffled by the USE flags. What about their USE flags is incompatible? How could I change their USE flags to be compatible and resolve the conflict, or is that even possible? ... Thanks!
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6384
Location: Austria

PostPosted: Mon Apr 16, 2018 7:07 pm    Post subject: Reply with quote

Get rid of kdelibs that depends on phonon[qt4].
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
m27315
Apprentice
Apprentice


Joined: 10 Dec 2004
Posts: 253
Location: 2 workstations down

PostPosted: Mon Apr 16, 2018 7:38 pm    Post subject: Reply with quote

I was only able to eliminate the requirement by adding "-qt4" to my make.conf USE flags and unemerging libreoffice/libreoffice-bin.

After updating world and depcleaning, the conflict was resolved. ... However, I am unable to use libreoffice now, because it wants qt4 and kdelibs-4, or at least, some of its dependencies do:

Code:
$ emerge -pvt libreoffice

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild  N     ] app-office/libreoffice-5.4.5.1::gentoo  USE="bluetooth branding cups dbus gtk kde (-coinmp) -collada -debug -eds (-firebird) -gltf -googledrive -gstreamer -gtk3 -java -jemalloc -libressl -mysql -odk -pdfimport -postgres -quickstarter {-test} -vlc" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python3_5 -python2_7 -python3_4 -python3_6" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 191,740 KiB
[ebuild  N     ]  kde-frameworks/kdelibs-4.14.37:4/4.14::gentoo  USE="acl bzip2 handbook nls plasma (policykit) qt3support spell ssl udev udisks upower (-altivec) -debug -doc (-fam) -jpeg2k -kerberos -libressl -lzma -openexr {-test} -zeroconf" CPU_FLAGS_X86="mmx sse sse2 -3dnow" 0 KiB
[nomerge       ] kde-apps/kdecore-meta-17.12.3:5::gentoo  USE="handbook"
[nomerge       ]  kde-apps/dolphin-17.12.3:5::gentoo  USE="handbook semantic-desktop -debug {-test} -thumbnail"
[nomerge       ]   kde-apps/kio-extras-17.12.3:5::gentoo  USE="activities handbook man phonon sftp -debug -htmlthumbs -mtp -openexr -samba -slp -taglib {-test}"
[nomerge       ]    kde-frameworks/khtml-5.43.0:5/5.43::gentoo  USE="X -debug -libressl {-test}"
[nomerge       ]     media-libs/phonon-4.9.1-r1::gentoo [4.10.0::gentoo] USE="designer pulseaudio qt4%* qt5%* vlc -debug -gstreamer" ABI_X86="32%* (64%*) (-x32)"
[ebuild     UD ]      media-libs/phonon-vlc-0.9.1-r1::gentoo [0.10.1::gentoo] USE="qt4%* qt5%* -debug" 0 KiB
[ebuild     UD ]       media-libs/phonon-4.9.1-r1::gentoo [4.10.0::gentoo] USE="designer pulseaudio qt4%* qt5%* vlc -debug -gstreamer" ABI_X86="32%* (64%*) (-x32)" 0 KiB
[nomerge       ] kde-plasma/plasma-meta-5.11.5:5::gentoo  USE="bluetooth crypt display-manager gtk handbook pam pulseaudio sddm wallpapers -grub -networkmanager -plymouth -sdk"
[nomerge       ]  kde-plasma/polkit-kde-agent-5.11.5:5::gentoo  USE="-debug"
[ebuild   R    ]   sys-auth/polkit-qt-0.112.0_p20160416-r1::gentoo  USE="qt4* -debug -examples" 0 KiB
...
The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by kde-frameworks/kdelibs-4.14.37::gentoo[plasma]
# required by app-office/libreoffice-5.4.5.1::gentoo[kde]
# required by libreoffice (argument)
>=app-crypt/qca-2.1.3-r1 qt4
# required by kde-frameworks/kdelibs-4.14.37::gentoo
# required by app-office/libreoffice-5.4.5.1::gentoo[kde]
# required by libreoffice (argument)
>=dev-libs/libdbusmenu-qt-0.9.3_pre20160218-r1 qt4
# required by kde-frameworks/kdelibs-4.14.37::gentoo
# required by app-office/libreoffice-5.4.5.1::gentoo[kde]
# required by libreoffice (argument)
>=sys-auth/polkit-qt-0.112.0_p20160416-r1 qt4
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19239
Location: here

PostPosted: Mon Apr 16, 2018 7:39 pm    Post subject: Reply with quote

Remove kde use flag to libreoffice-bin
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6384
Location: Austria

PostPosted: Mon Apr 16, 2018 7:44 pm    Post subject: Reply with quote

libreoffice-bin is made for stable. Your system seems to be stable. So why did you unmask unstable phonon* versions?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
m27315
Apprentice
Apprentice


Joined: 10 Dec 2004
Posts: 253
Location: 2 workstations down

PostPosted: Mon Apr 16, 2018 9:03 pm    Post subject: Reply with quote

Removing the kde USE flag solved the requirement for libreoffice upon qt4 and kdelibs.

I marked phonon, phonon-vlc, and pulseaudio as unstable a long time ago. I removed the keywords for those packages, returned to stable for them, and rebuilt the outdated packages, which will surely help avoid future issues with these packages.

Thanks for all of the help! :)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6384
Location: Austria

PostPosted: Tue Apr 17, 2018 7:39 am    Post subject: Reply with quote

m27315 wrote:
Removing the kde USE flag solved the requirement for libreoffice upon qt4 and kdelibs.

For a full arch system, USE=kde is fine. (it requires qt4)
For a full ~arch system, USE=kde is fine. ;) (it requires qt5)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
davydm
n00b
n00b


Joined: 06 Jan 2017
Posts: 13

PostPosted: Sat Jun 02, 2018 7:45 pm    Post subject: Reply with quote

Just wanted to say thanks for the help here -- sorted out my same problem (remove kdelibs, upon which nothing depended, but it was still hanging about)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6384
Location: Austria

PostPosted: Sat Jun 02, 2018 8:03 pm    Post subject: Reply with quote

At this point by the way, kdelibs is masked, and no more phonon* versions with qt4 support present.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum