Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Various problems with lumina
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Windmill
Tux's lil' helper
Tux's lil' helper


Joined: 21 Feb 2014
Posts: 105

PostPosted: Sat Apr 14, 2018 6:32 pm    Post subject: Various problems with lumina Reply with quote

Hi, I have various problems with lumina and I hope you can help me solve these:
-when the desktop pause so I have to login again inserting the password, it doesn't let me to. There isn't a space to insert the password and after every mouse or keyboard action it gives me an "invalid password" error
-I can't reboot or poweroff from the DE, it just closes the session
-I can't open any .exe using wine from the file manager no problem from terminal, but nothing happens if I try from GUI
Back to top
View user's profile Send private message
Marcih
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2018
Posts: 147

PostPosted: Sun Apr 22, 2018 9:48 am    Post subject: Reply with quote

Bumparoo, I'm having the same problem with shutdown. Lumina's website lists "Shutdown options" for Gentoo Linux as "Detect/Allow", but I haven't been able to find what exactly that means. What is it detecting? What is the allowing based on? Why are the power options "clickable" but they all just close the session? I think it's useful to add that I am using startx to execute start-lumina-session, but I haven't seen anything about having to use a DM in order to be able to use the power options.

As for your other problem; are you using Insight? Check your MIME type associations, Desktop Settings -> Applications -> Advanced tab -> expand Applications and see what "x-ms-dos-executable" has set as the default application.
_________________
Bones McCracker wrote:
It wouldn't be so bad, if it didn't suck.

===
I refuse to move on from GTK+2.
Back to top
View user's profile Send private message
Windmill
Tux's lil' helper
Tux's lil' helper


Joined: 21 Feb 2014
Posts: 105

PostPosted: Sun Apr 22, 2018 12:51 pm    Post subject: Reply with quote

I solved shutdown and reboot problems adding "ck-launch-session dbus-launch" to .xinitrc. I though that dbus and consolekit weren't required as it says that lumina doesn't require any external package to work. As for Insight, it seems that starting cconsolekit solves the problem of starting a .exe from GUI too, I don't know why. I can start any file, just starting with wine doesn't work. I also have another problems, the archiver just doesn't work, it doesn't open any archive (I have the archiving tools installed, so that's not the cause).
Back to top
View user's profile Send private message
Marcih
Tux's lil' helper
Tux's lil' helper


Joined: 19 Feb 2018
Posts: 147

PostPosted: Mon Apr 23, 2018 4:09 pm    Post subject: Reply with quote

Windmill wrote:
I solved shutdown and reboot problems adding "ck-launch-session dbus-launch" to .xinitrc. I though that dbus and consolekit weren't required as it says that lumina doesn't require any external package to work. As for Insight, it seems that starting cconsolekit solves the problem of starting a .exe from GUI too, I don't know why. I can start any file, just starting with wine doesn't work.
That's mildly disappointing, I've moved to Lumina because it didn't require the *kits. In theory, XFCE, my last DE, doesn't either but it works better with it (shutdown from the DE for instance). I'm essentially back to square 1 then, except with a less functional, more buggy DE... :cry:
Windmill wrote:
I also have another problems, the archiver just doesn't work, it doesn't open any archive (I have the archiving tools installed, so that's not the cause).

Same here, I'm not sure what's happening, whether it requires some external archiving packages (I'd expect to have those pulled in as deps), it only works with some archive types (haven't found any that it works with yet) or it's simply not functional yet, which would not be the first thing that exhibits this behaviour in Lumina. :lol:
_________________
Bones McCracker wrote:
It wouldn't be so bad, if it didn't suck.

===
I refuse to move on from GTK+2.
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2883
Location: Illinois, USA

PostPosted: Mon Apr 23, 2018 8:31 pm    Post subject: Reply with quote

Marcih, If you are using startx instead of a session-manager there is no session to close.
I think it's as simple as that.

EDIT:
See the /etc/X11/Sessions/Xsession file provided by x11-apps/xinit
http://dpaste.com/2RN7KAP
At the very end the session is exec'd to the program being started so that when it ends the session manager i.e. xdm/gdm/kdm goes back to the login prompt. If you just start with startx, ending the program just brings you back to your terminal.

I'd have to look at the code to see what the power optons do, but Lumina is aligned more and more to TrueOS, not Linux.
Are you running OpenRC or systemd?

EDIT2:
When I try restart, it just logs out as you say (I'm using xdm) and /var/log/auth.log contains this line:
Code:
pam_unix(su:session): session closed for user nobody
I suspect there may be a permission problem, but it's just a guest.

Hmmm! tried logging in as root then restarting. Got this in auth.log
Code:
Apr 23 16:02:51 gentoo su[29321]: Successful su for nobody by root
Apr 23 16:02:51 gentoo su[29321]: + ??? root:nobody
Apr 23 16:02:51 gentoo su[29321]: pam_unix(su:session): session opened for user nobody by (uid=0)
Apr 23 16:02:51 gentoo su[29321]: pam_unix(su:session): session closed for user nobody
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum