Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Invisible output on konsole application (Mathematica)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fpt
n00b
n00b


Joined: 10 Apr 2018
Posts: 2

PostPosted: Tue Apr 10, 2018 9:42 am    Post subject: Invisible output on konsole application (Mathematica) Reply with quote

Hi,
I am using Mathematica on a KDE Konsole, and strangely, the printed characters are invisible. An example clarify the problem. Usually, if I open Mathematica and type "1+1" + Enter I get the following output

Code:

$ math
Mathematica 11.3.0 Kernel for Linux x86 (64-bit)
Copyright 1988-2018 Wolfram Research, Inc.

In[1]:= 1+1

Out[1]= 2



Instead what I see is:

Code:

$ math
Mathematica 11.3.0 Kernel for Linux x86 (64-bit)
Copyright 1988-2018 Wolfram Research, Inc.

 1
   +
     1
       





2




That is, every keystroke prints the character and goes to new line without carraige return. The output also is weird, in that I only see the result "2" with a lot of new lines and without the usual "Out[1]=" before.

This problem appears when I use Konsole on the affected machine, but strangely, also if I open a KDE konsole on another machine, do a ssh on the affected machine and then launch mathematica. However, on the machine affected by the problem, if I login from a terminal (one of those accessible by Ctrl-Alt-FnX), the mathematica output works perfectly. So I am posting it here because, presumably, it's a KDE problem.
I use UTF-8 encoding on the konsole. I tried changing the encoding, with no solution.

Any clue where I should look for?
Back to top
View user's profile Send private message
mike155
l33t
l33t


Joined: 17 Sep 2010
Posts: 994
Location: Frankfurt, Germany

PostPosted: Wed Apr 11, 2018 12:51 am    Post subject: Reply with quote

The problem you reported doesn't look like an encoding problem. For that reason, it doesn't help to change the character encoding in konsole. It looks like a terminal emulation mismatch.

1) Does it help to start Mathematica with option '-rawterm'?

2) Please post the output of 'export | grep TERM' after you logged in using ssh (where output is garbled) and after you logged in using one of the Ctrl-Alt-FnX terminals (where output is fine).
Back to top
View user's profile Send private message
fpt
n00b
n00b


Joined: 10 Apr 2018
Posts: 2

PostPosted: Wed Apr 11, 2018 12:24 pm    Post subject: Reply with quote

mike155 wrote:

1) Does it help to start Mathematica with option '-rawterm'?


Thanks a lot! That indeed makes the output fine.

mike155 wrote:

2) Please post the output of 'export | grep TERM' after you logged in using ssh (where output is garbled) and after you logged in using one of the Ctrl-Alt-FnX terminals (where output is fine).


Loggin via ssh where the output is garbled I get

Code:

$ export|grep TERM
declare -x TERM="xterm-256color"


On the termnals where the output is OK i get

Code:

$ export|grep TERM
declare -x TERM="linux"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum