Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plasma - black screen with cursor
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
klz-0
n00b
n00b


Joined: 17 Mar 2018
Posts: 8

PostPosted: Sat Apr 07, 2018 12:50 pm    Post subject: Plasma - black screen with cursor Reply with quote

Hi everybody,

I'll keep it simple.. I was trying to install KDE plasma but the result is only a cursor on a black screen, I am not sure if I missed something or what can cause this I've searched for a lot of threads on different forums but none of them worked, I have no other Ideas..

when I startx as a regular user I get the following output:
https://pastebin.com/iTMQtuqd

Does anybody have an idea?

The desktop seems like it contains the widgets. When I move the mouse I sometimes see it transform to a grab or resize cursor
Back to top
View user's profile Send private message
Tatsh
Apprentice
Apprentice


Joined: 22 Jul 2007
Posts: 178

PostPosted: Sat Apr 07, 2018 12:56 pm    Post subject: Reply with quote

You could be having issues with your video driver. Try pressing Alt+Shift+F2 and see if anything else draws on the screen.

I'd suggest you update and rebuild everything related:

Code:
emerge --sync
emerge -ev kde-plasma/plasma-meta
emerge @module-rebuild @x11-module-rebuild
emerge @preserved-rebuild


Solve any conflicts that arise from the above commands and make sure every package builds successfully. Then reboot and try again.
Back to top
View user's profile Send private message
klz-0
n00b
n00b


Joined: 17 Mar 2018
Posts: 8

PostPosted: Sat Apr 07, 2018 1:08 pm    Post subject: Reply with quote

Thanks for a quick reply

Tatsh wrote:
You could be having issues with your video driver. Try pressing Alt+Shift+F2 and see if anything else draws on the screen.


I tried, it didn't.

Tatsh wrote:
I'd suggest you update and rebuild everything related:

Code:
emerge --sync
emerge -ev kde-plasma/plasma-meta
emerge @module-rebuild @x11-module-rebuild
emerge @preserved-rebuild


Solve any conflicts that arise from the above commands and make sure every package builds successfully. Then reboot and try again.


This is a fresh plasma installation.. anyways I will try it

Somebody other suggestions?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Sat Apr 07, 2018 2:01 pm    Post subject: Reply with quote

Are you using sddm as display manager, if yes, what version?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
klz-0
n00b
n00b


Joined: 17 Mar 2018
Posts: 8

PostPosted: Sat Apr 07, 2018 2:48 pm    Post subject: Reply with quote

asturm wrote:
Are you using sddm as display manager, if yes, what version?


Yes, version 0.17.0-r1
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Sat Apr 07, 2018 3:01 pm    Post subject: Reply with quote

Do you use systemd, elogind or consolekit for session management?

Please try with -r2.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
klz-0
n00b
n00b


Joined: 17 Mar 2018
Posts: 8

PostPosted: Sat Apr 07, 2018 3:54 pm    Post subject: Reply with quote

asturm wrote:
Do you use systemd, elogind or consolekit for session management?

Please try with -r2.


I am using consolekit and the init system is OpenRC
-r2 didn't help

btw, X server with twm works just fine
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Sat Apr 07, 2018 4:14 pm    Post subject: Reply with quote

Please show emerge --info.

Try to remove ~/.cache/mesa* and ~/.cache/qtshadercache
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
klz-0
n00b
n00b


Joined: 17 Mar 2018
Posts: 8

PostPosted: Sat Apr 07, 2018 4:25 pm    Post subject: Reply with quote

asturm wrote:
Try to remove ~/.cache/mesa* and ~/.cache/qtshadercache

These files doesn't exist..

Code:
Portage 2.3.24 (python 2.7.14-final-0, default/linux/amd64/17.0/desktop/plasma, gcc-6.4.0, glibc-2.26-r6, 4.9.0-gentoo x86_64)
=================================================================
System uname: Linux-4.9.0-gentoo-x86_64-AMD_Sempron-tm-_Processor_3000+-with-gentoo-2.4.1
KiB Mem:     1498380 total,    237984 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Tue, 03 Apr 2018 00:45:01 +0000
Head commit of repository gentoo: 5558078abf664d63fead55f6fde1d4b95d18e426
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
distcc 3.2rc1 x86_64-pc-linux-gnu [enabled]
app-shells/bash:          4.4_p12::gentoo
dev-lang/perl:            5.24.3-r1::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.4.5-r1::gentoo, 3.5.4-r1::gentoo, 3.6.3-r1::gentoo
dev-util/cmake:           3.9.6::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15.1-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo, 2.29.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo, 5.4.0::gentoo, 6.4.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.26-r6::gentoo
Repositories:

gentoo
    location: /mnt/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: no
    sync-rsync-extra-opts:

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=k8"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.0/ext-active/ /etc/php/apache2-php7.1/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=k8"
DISTDIR="/mnt/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://tux.rainside.sk/gentoo/ http://ftp.fi.muni.cz/pub/linux/gentoo/ http://gentoo.mirror.web4u.cz/"
LANG="en_US.utf8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j10 -l1"
PKGDIR="/mnt/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/mnt/temp/"
USE="X a52 aac acl acpi activities alsa amd64 audiofile berkdb branding bzip2 cairo cdda cdr cli consolekit crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam flac fortran gdbm gif glamor gpm gtk iconv jpeg kde kerberos kipi kwallet lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp openssl pam pango pcre pdf phonon plasma png policykit ppds qml qt3support qt5 readline sdl seccomp semantic-desktop spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis widgets wxwidgets x264 xattr xcb xcomposite xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby22 ruby23" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


edit:

If I do startx or /etc/init.d/xwm start the effect is the same >> black screen with a cursor, except that with startx, the cursor is kde-themed
also .xinitrc is as follows:
Code:
exec ck-launch-session dbus-launch --sh-syntax --exit-with-session startkde


Output of lspci -vvv
Code:
00:05.0 VGA compatible controller: NVIDIA Corporation C51PV [GeForce 6150] (rev a2) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. A8N-VM CSM
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at fb000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at e0000000 (64-bit, prefetchable) [size=256M]
        Region 3: Memory at fc000000 (64-bit, non-prefetchable) [size=16M]
        [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: [48] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
                Address: 0000000000000000  Data: 0000
        Kernel driver in use: nvidiafb
        Kernel modules: nvidiafb, nouveau
Back to top
View user's profile Send private message
pietinger
n00b
n00b


Joined: 17 Oct 2006
Posts: 46

PostPosted: Sun Apr 08, 2018 11:19 am    Post subject: Reply with quote

Some days ago I had the same problem with a black screen after a qt update. This helped me:

export QML_DISABLE_DISK_CACHE=1
Back to top
View user's profile Send private message
phd
n00b
n00b


Joined: 12 Oct 2005
Posts: 65
Location: Warszawa (Poland)

PostPosted: Wed Apr 11, 2018 10:36 am    Post subject: Reply with quote

Yesterday, I had the same problem with black screen in plasma. In my case, before the black screen, I noted that plasma worked incorrectly. There were problems with panels, the panel disappeared, next I had two panels one at the bottom and the new one at the top, and finally black screen. I use plasma profile 17.0, amd64 and .xinitrc
Quote:
exec ck-launch-session dbus-launch --sh-syntax --exit-with-session startkde

On the console,
Code:
$ startx &
resulted some warnings on r300 ERRORS, qml, and plasmoids. In my case the downgrade of mesa helped
Code:
emerge -1 =mesa-17.2.8
emerge @module-rebuild @x11-module-rebuild

This allowed me at least to restore plasma desktop, remove next the panel, and set up a new default one. I have a very old buildin Radeon card RS690 [Radeon X1200].
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum