Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]binutils Warnung trotz aktuellem System---
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 24 Mar 2005
Posts: 134

PostPosted: Fri Apr 20, 2018 10:06 pm    Post subject: [SOLVED]binutils Warnung trotz aktuellem System--- Reply with quote


ich betreibe einige XEN-virtualisierte Maschinen. Alle sind mit dem gleichen Kernel ausgestattet.
Bei einigen Maschinen habe ich allerdings dass ich noch immer folgende Meldung, binutils betreffend bekomme:
  emerge --update --newuse --deep  --with-bdeps=y @world -av && revdep-rebuild

 * IMPORTANT: 37 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

!!! The following installed packages are masked:
- sys-devel/binutils-2.28.1::gentoo (masked by: package.mask)
# Michał Górny <>, Andreas K. Hüttel <>,
# Matthias Maier <> (21 May 2017)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.
# (updated 27 Dec 2017 with gcc < 5.4)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

Was ich allerdings nicht verstehe ist, dass ich das .28er binutils "nicht los werde:
binutils-config -l
 [1] x86_64-pc-linux-gnu-2.28.1
 [2] x86_64-pc-linux-gnu-2.29.1 *

Selbst ein emerge --eva world hat nix geholfen.

Hier noch ein --info des Systems:
 emerge --info
Portage 2.3.24 (python 2.7.14-final-0, default/linux/amd64/17.0, gcc-6.4.0, glibc-2.25-r11, 4.9.76-gentoo-r1 x86_64)
System uname: Linux-4.9.76-gentoo-r1-x86_64-Intel-R-_Core-TM-_i5-2300_CPU_@_2.80GHz-with-gentoo-2.4.1
KiB Mem:     2044272 total,    496044 free
KiB Swap:    2047996 total,   2030080 free
Timestamp of repository gentoo: Fri, 20 Apr 2018 04:00:01 +0000
Head commit of repository gentoo: 10b3011a4085229faa82e2a1512a233d86bc5e80
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-lang/perl:            5.24.3-r1::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.5::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.69-r4::gentoo
sys-devel/automake:       1.15.1-r2::gentoo
sys-devel/binutils:       2.28.1::gentoo, 2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r11::gentoo

    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://
    priority: -1000
    sync-rsync-verify-metamanifest: no

CFLAGS="-O2 -pipe -fomit-frame-pointer -march=native -mtune=native"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -fomit-frame-pointer -march=native -mtune=native"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
USE="acl amd64 berkdb bzip2 cli crypt cxx dri fortran gdbm gnome iconv mmx modules multilib ncurses nls nptl ntplonly openmp pae pam pcre readline seccomp snmp sse sse2 ssl symlink tcpd unicode xattr zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby22 ruby23" USERLAND="GNU" VIDEO_CARDS="amdgpu fbdev intel nouveau radeon radeonsi vesa dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Ich wäre um einen Hinweis sehr dankbar, das Problem zu lösen...

Danke im Voraus,


Last edited by 2bbionic on Mon Apr 23, 2018 8:27 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 03 Sep 2007
Posts: 3891
Location: Germany

PostPosted: Sat Apr 21, 2018 1:57 am    Post subject: binutils Warnung trotz aktuellem System--- Reply with quote

dann hast du den binutils Slot womöglich mal in @world mit aufgenommen. Das passiert zb wenn man beim rebuild mal die --oneshot Option vergessen hat mitzugeben.
Schau mal bitte via
emerge -a --verbose --depclean binutils:2.28.1
Mit der Kombination "emerge --verbose --depclean package" werden dann auch die reverse Dependencies mit aufgelistet, sofern denn welche vorhanden sind.
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 24 Mar 2005
Posts: 134

PostPosted: Mon Apr 23, 2018 8:23 pm    Post subject: Reply with quote

perfekt, hat geklappt.
Vielen Dank!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum