Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nvidia kernel configuration is invalid
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Windmill
Tux's lil' helper
Tux's lil' helper


Joined: 21 Feb 2014
Posts: 105

PostPosted: Fri Apr 06, 2018 2:30 pm    Post subject: nvidia kernel configuration is invalid Reply with quote

I have this error when trying to install nvidia driver
Code:
echo >&2 "  ERROR: Kernel configuration is invalid.";      \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";   \

The compilation continues after this, but I opened a thread because I do't know if it's a real problem or not. I found a thread talking about the same error, but it was from 2017 so I find it strange that it hasn't been fixed in a year
Back to top
View user's profile Send private message
Tony0945
Advocate
Advocate


Joined: 25 Jul 2006
Posts: 2884
Location: Illinois, USA

PostPosted: Fri Apr 06, 2018 2:54 pm    Post subject: Reply with quote

Try doing what the error suggests?

"make oldconfig" is a tip off that some config item is completely missing from your config file, not just turned off.
ALWAYS run make oldconfig when upgrading versions other than minor revisions. i.e. 4.8 to 4.9, minor revisions being 4.8.10 to 4.8.20

I have a script that always runs make oldconfig. it takes a few seconds and never finds anything on the minor revisions. But I don't mind waiting ten seconds or so, the build is going to take much longer.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21335
Location: here

PostPosted: Fri Apr 06, 2018 2:57 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-p-6457443.html#6457443
cach0rr0 wrote:
Code:
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (      \
   echo;                        \
   echo "  ERROR: Kernel configuration is invalid.";      \
   echo "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
   echo "         Run 'make oldconfig && make prepare' on kernel src to fix it.";   \
   echo;     



That's just saying it will echo that if those files are missing

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
gerard27
Advocate
Advocate


Joined: 04 Jan 2004
Posts: 2377
Location: Netherlands

PostPosted: Fri Apr 06, 2018 3:19 pm    Post subject: Reply with quote

My experience is that this error message will be printed ALWAYS.
I think the nvidia source has an "if/then" missing.
I have installed nvidia-drivers many times,always this message even though X works fine.
Gerard.
_________________
To install Gentoo I use sysrescuecd.Based on Gentoo,has firefox to browse Gentoo docs and mc to browse (and edit) files.
The same disk can be used for 32 and 64 bit installs.
You can follow the Handbook verbatim.
http://www.sysresccd.org/Download
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21335
Location: here

PostPosted: Fri Apr 06, 2018 3:28 pm    Post subject: Reply with quote

gerard27 wrote:
My experience is that this error message will be printed ALWAYS.
I think the nvidia source has an "if/then" missing.
I have installed nvidia-drivers many times,always this message even though X works fine.
Gerard.

No the error message isn't printed, but all test command is printed.
If error occur (when include/generated/autoconf.h or include/config/auto.conf are missing) you see error message without echo
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Windmill
Tux's lil' helper
Tux's lil' helper


Joined: 21 Feb 2014
Posts: 105

PostPosted: Sat Apr 07, 2018 7:25 am    Post subject: Reply with quote

It seems that the driver is working correctly.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum