Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[resolu] Layman et openssl
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
nenoro
n00b
n00b


Joined: 07 Jan 2018
Posts: 8

PostPosted: Fri Mar 30, 2018 4:26 pm    Post subject: [resolu] Layman et openssl Reply with quote

Hiya

Bon ca fait un petit moment que je remarque l'entetement de layman ou emerge a forcer l'upgrade de openssl.

Quote:

The following keyword changes are necessary to proceed:
(see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-libs/libevent-2.1.8::gentoo[ssl,-libressl]
# required by net-misc/ntp-4.2.8_p11::gentoo
# required by @selected
# required by @world (argument)
=dev-libs/openssl-1.1.0h ~amd64

The following mask changes are necessary to proceed:
(see "package.unmask" in the portage(5) man page for more details)
# required by dev-libs/libevent-2.1.8::gentoo[ssl,-libressl]
# required by net-misc/ntp-4.2.8_p11::gentoo
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/openssl:
=dev-libs/openssl-1.1.0h


J'ai beau faire
Quote:
nano /etc/portage/package.mask/openssl

Quote:

=dev-libs/openssl-1.1.0g-r3
=dev-libs/openssl-1.1.0h


Rien n'y fait, sachant que la version 1.1.0x provoque beaucoup de failure avec d'autres packages.

Sous Funtoo bizarrement j'ai pas ce probleme surtout que Layman ne propose pas beaucoup de packages a installer...

Alors que sous Gentoo c'est le festival il inclut aussi les packages xorg (si j'ai pas encore installe le cottage)... je suis oblige d'installer xorg avant d'installer layman mais bien sur layman me proposera de recompiler un ou deux packages et surtout la stupide upgrade d'openssl...

Donc ma remarque dans mon ancien post tient toujours

Pouvez vous retirer les versions inutiles en rouge de openssl pour ne garder qu'une version stable qui est 1.0.2n ?

J'ai aussi vu une version 1.0.2o je vais tester mais si celui ci provoque des fails jvais pas etre gentil...


Last edited by nenoro on Fri Mar 30, 2018 6:04 pm; edited 2 times in total
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 721
Location: S.O. France

PostPosted: Fri Mar 30, 2018 4:50 pm    Post subject: Reply with quote

dev-libs/libevent-2.1.8 à besoin de >openssl-1.0.1h-r2
Code:
DEPEND="
   ssl? (
      !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] )


Quote:
Rien n'y fait, sachant que la version 1.1.0x provoque beaucoup de failure avec d'autres packages.

C'est de ce coté qu'il faut chercher.Sans précisions on va pas pouvoir t'aider.

Tu peux aussi consulter
https://bugs.gentoo.org/592438
Back to top
View user's profile Send private message
nenoro
n00b
n00b


Joined: 07 Jan 2018
Posts: 8

PostPosted: Fri Mar 30, 2018 5:47 pm    Post subject: Reply with quote

Alors la liste vu par le terminal: (jpouvais pas avoir la liste en allant sur zugaina malheureusement)

Quote:
[ebuild U #] dev-libs/openssl-1.1.0h [1.0.2n] USE="-bindist* -tls-heartbeat*"
[ebuild N ] dev-perl/Net-SSLeay-1.820.0 USE="-examples -libressl -minimal {-test}"
[ebuild N ] dev-perl/IO-Socket-SSL-2.48.0 USE="-examples -idn


J'affiche seulement les packages qui pourraient fail si j'upgrade openssl

openssl en 1.0.2n > Net-SSLeay et IO-Socket-SSL pas de fail
openssl en 1.1.0x > les deux packages y'a failed

j'ai pas besoin de montrer le log puisque c'est deja dit partout sur le forum

Edit > j'ai resolu mon probleme, la version 1.0.2o fonctionne bien j'ai installe les deux avant d'installer layman et layman ne me propose plus d'upgrader.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum