Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
how to install version 5.3+ of the lua package?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
berardel
n00b
n00b


Joined: 03 Mar 2018
Posts: 19
Location: United States

PostPosted: Wed Mar 28, 2018 11:55 pm    Post subject: how to install version 5.3+ of the lua package? Reply with quote

https://packages.gentoo.org/packages/dev-lang/lua
so im needing to install some version of this higher than version 5.3. can someone help me to install this from the repos with portage?
Back to top
View user's profile Send private message
shadow255
Guru
Guru


Joined: 04 Apr 2003
Posts: 412

PostPosted: Thu Mar 29, 2018 12:59 am    Post subject: Reply with quote

Portage is actually pretty good at telling you what you'll need to do in order to emerge a masked or keyword-protected version of a given package. Did you try anything like the following in getting started with this?
Code:
$ emerge -pv =dev-lang/lua-5.3.3-r1

The output on my system (amd64 with very few unstable packages) indicated I would need to make keyword changes and mask changes in order to install the packages, along with some good hints as to why the version is masked and keyword-protected. Good luck!
_________________
Vogon poetry is of course the third worst in the Universe. -- Douglas Adams, The Hitchhiker's Guide to the Galaxy
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum