Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Qt update von 5.7.1 auf 5.9.4
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 185
Location: Wien

PostPosted: Mon Mar 26, 2018 10:42 am    Post subject: [gelöst] Qt update von 5.7.1 auf 5.9.4 Reply with quote

Hallo, ich habe Probleme beim System-Update betreffend QT
die letzte installierte Version ist bei mir 5.7.1
die neueste verfügbare Version ist 5.9.4
automatisch läuft das Update nicht.
bekomme da Meldungen wie zb:
Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:5

  (dev-qt/qtgui-5.9.4-r3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.9.4 required by (dev-qt/qtsvg-5.9.4-r2:5/5.9::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                     
    (and 5 more with the same problem)

  (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.7.1 required by (dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                           
    dev-qt/qtgui:5/5.7= required by (media-video/smplayer-17.11.2:0/0::gentoo, installed)
                ^^^^^^^                                                                                                     
    (and 16 more with the same problems)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.9.4:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.9.4 required by (dev-qt/qtgui-5.9.4-r3:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     

  (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qdbus-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    (and 2 more with the same problem)

und so geht es noch weiter.
wie sollte ich dieses Problem angehen?


Last edited by oliver2104 on Wed Mar 28, 2018 8:44 am; edited 1 time in total
Back to top
View user's profile Send private message
mike155
Guru
Guru


Joined: 17 Sep 2010
Posts: 566
Location: Frankfurt, Germany

PostPosted: Mon Mar 26, 2018 11:55 am    Post subject: Reply with quote

Hallo oliver2104,

es gibt etliche Threads in den Foren zu diesem Thema - in diesen sind auch Lösungen beschrieben.

Das Problem ist folgendes: es gibt ein Update auf Qt 5.9, aber auf Deinem Rechner sind noch einzelne Pakete, die Qt 5.7 benötigen. Deshalb gibt es die von Dir gezeigten Fehlermeldungen...

Es gibt zwei Möglichkeiten:

1) Du suchst die Pakete, die noch Qt 5.7 benötigen und schaust, warum sie Qt 5.7 benötigen und löst dieses Problem.

2) Du zeigst uns die Ausgaben von "emerge --info", "emerge --update --deep --newuse -av @world" und von "emerge --update --deep --newuse --tree -av @world" - dann können wir gemeinsam suchen.

Mike
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3208
Location: de

PostPosted: Tue Mar 27, 2018 5:51 am    Post subject: Reply with quote

Du kannst auch erst mal versuchen, über den Backtrack-Parameter die Abhängigkeiten aufzulösen:

Code:
emerge -1uDN world --backtrack=1000
Back to top
View user's profile Send private message
oliver2104
Apprentice
Apprentice


Joined: 27 Jul 2004
Posts: 185
Location: Wien

PostPosted: Wed Mar 28, 2018 8:44 am    Post subject: Reply with quote

Danke Euch beiden für die Antwort.
Ich habs zuerst probiert mit:
Code:
emerge -1uDN world --backtrack=1000

Das hat etwas gedauert, ist aber anstandslos durchgelaufen.
Jetzt ist wieder alles UptoDate. Kannte den Parameter --backtrack gar nicht.
Bin begeistert, selten war ein Problem so schnell beseitigt.
Back to top
View user's profile Send private message
mike155
Guru
Guru


Joined: 17 Sep 2010
Posts: 566
Location: Frankfurt, Germany

PostPosted: Thu Mar 29, 2018 2:08 pm    Post subject: Reply with quote

Code:
emerge -1uDN world --backtrack=1000

Ich bin weniger begeistert. Der mysteriöse Backtrack-Parameter wird viel zu häufig benötigt - und leider auch in Standard-Situationen, wie in diesem Fall.

Vielleicht (hoffentlich) schaffen Michał Górny und seine Mitstreiter es ja wirklich, einen besseren Solver für Portage zu implementieren.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum