Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Desktop Managers do not respect xorg.conf keymap
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jssilva
Tux's lil' helper
Tux's lil' helper


Joined: 27 Sep 2017
Posts: 106

PostPosted: Sun Mar 25, 2018 6:35 pm    Post subject: [SOLVED] Desktop Managers do not respect xorg.conf keymap Reply with quote

Hello, this problem is driving me mad, I've been chasing it for hours, so, help!!!

My consoles obey my /etc/conf.d/keymaps and I can log on perfectly, no problem here.
Code:
keymap="pt-latin1-mymac"

mymac is a slight variation that I had to make for my keymap. It is irrelevant though, because it is working.

But not my DM. Doesn't matter if it is slim, sddm, lxdm, I've tried almost all, refuse to accept the passw. Writing this passwd on the username field, I see that, for instance, the "-" gets changed to a "/" which indiciates the DM is acting with perhaps an en_US keymap, or an equivalent.

By logging in with startx, I checked that my keymap is indeed set to "pc105-pt" and not "pc105-us".

Furthermore, my xorg.conf is:
Code:
Section "InputClass"
        Identifier "system-keyboard"
        Driver "evdev"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Option "XkbLayout" "pt"
        Option "XkbModel" "pc105"
        Option "XkbVariant" "mac"
EndSection

and it has been so for a long time before.

I think this started to happen after an emerge but I'm not sure because I had been fiddling with some settings.

[EDIT] I already checked ~/.xinitrc, ~/.xprofile, and the like. Nothing there.

Can someone please help?
TIA
jss


Last edited by jssilva on Sun Mar 25, 2018 8:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Sun Mar 25, 2018 6:38 pm    Post subject: Reply with quote

try Option "xkb_layout" "pt"
Back to top
View user's profile Send private message
jssilva
Tux's lil' helper
Tux's lil' helper


Joined: 27 Sep 2017
Posts: 106

PostPosted: Sun Mar 25, 2018 6:51 pm    Post subject: Reply with quote

Ant P. wrote:
try Option "xkb_layout" "pt"

If you mean:
Code:
Section "InputClass"
        Identifier "system-keyboard"
        Driver "evdev"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Option "xkb_layout" "pt"
#       Option "XkbLayout" "pt"
        Option "XkbModel" "pc105"
        Option "XkbVariant" "mac"
EndSection

It doesn't work. Thank you anyway for jumping in.
Rgds
jss
Back to top
View user's profile Send private message
kajzer
Guru
Guru


Joined: 27 Nov 2014
Posts: 370

PostPosted: Sun Mar 25, 2018 7:13 pm    Post subject: Reply with quote

I believe you have to put that in this file
Code:
/etc/X11/xorg.conf.d/00-keyboard.conf
Back to top
View user's profile Send private message
jssilva
Tux's lil' helper
Tux's lil' helper


Joined: 27 Sep 2017
Posts: 106

PostPosted: Sun Mar 25, 2018 7:23 pm    Post subject: Reply with quote

kajzer wrote:
I believe you have to put that in this file
Code:
/etc/X11/xorg.conf.d/00-keyboard.conf

I'm sorry to have wasted your time and my whole afternoon with a very simple and stupid human mistake.

As I said, I had been fiddling with some xorg setting, chasing a problem that is disturbing me for a long time: an unexplained X crash.

So, in the course of tests, I renamed the directory to /etc/X11/xorg.conf instead of xorg.conf.d; so the system didn't have any settings and was taking the defaults. Very stupid of me.

Apologies,
jss
Back to top
View user's profile Send private message
kajzer
Guru
Guru


Joined: 27 Nov 2014
Posts: 370

PostPosted: Sun Mar 25, 2018 7:52 pm    Post subject: Reply with quote

ok, well try then with this, emerge
Code:
setxkbmap


then in terminal type this :
Code:
setxkbmap pt mac -model pc105


if it works then you can put that command in your DE autostart script or something.
Back to top
View user's profile Send private message
jssilva
Tux's lil' helper
Tux's lil' helper


Joined: 27 Sep 2017
Posts: 106

PostPosted: Sun Mar 25, 2018 8:10 pm    Post subject: Reply with quote

kajzer wrote:
ok, well try then with this, emerge
Code:
setxkbmap


then in terminal type this :
Code:
setxkbmap pt mac -model pc105


if it works then you can put that command in your DE autostart script or something.


It's solved :oops: , as I said before. Thank you.
Rgds
jss
Back to top
View user's profile Send private message
kajzer
Guru
Guru


Joined: 27 Nov 2014
Posts: 370

PostPosted: Sun Mar 25, 2018 8:43 pm    Post subject: Reply with quote

You're welcome, glad it worked.

It should be working with xorg config file though, it looks good, looking closer now at it maybe the problem is in these two lines :

Code:
       Driver "evdev"
       MatchDevicePath "/dev/input/event*"


but it's very possible that doesn't matter, I'm not sure, I don't have those lines and it works fine.
You can try it when you have the time, or you can just use setxkbmap since it does the job.
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5592

PostPosted: Sun Mar 25, 2018 9:46 pm    Post subject: Reply with quote

I was about to ask which option line worked for you in the end, because I remember seeing conflicting docs when I tried to get this working long ago, but upon re-reading xorg.conf(5) I see the names are both case-insensitive and underscores are ignored. Sorry for the useless suggestion, I guess!
Back to top
View user's profile Send private message
jssilva
Tux's lil' helper
Tux's lil' helper


Joined: 27 Sep 2017
Posts: 106

PostPosted: Mon Mar 26, 2018 1:04 am    Post subject: Reply with quote

Quote:
It should be working with xorg config file though, it looks good, looking closer now at it maybe the problem is in these two lines :

Ant P. wrote:
I was about to ask which option line worked for you in the end, because I remember seeing conflicting docs when I tried to get this working long ago, but upon re-reading xorg.conf(5) I see the names are both case-insensitive and underscores are ignored. Sorry for the useless suggestion, I guess!


I see I couldn't explain myself, surely because English is not my birth language.

My /etc/X11/xorg.conf.d/00-keyboard.conf works perfectly now and in the past; there's nothing wrong with it.

The problem was that I renamed by mistake the directory /etc/X11/xorg.conf.d to /etc/X11/xorg.conf, that is, I suppressed the .d of the name.

Of course the system woudn't see it and I could be tweaking the files inside it forever that the result wouldn't change.

I hope it's clear now, it's just my stupid fault, sorry for your wasted time.

Rgds,
jss
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum