Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Missing filters in Shotcut
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
BruceG
n00b
n00b


Joined: 21 Jul 2003
Posts: 16
Location: Saskatoon, SK, Canada

PostPosted: Fri Mar 23, 2018 3:50 am    Post subject: Missing filters in Shotcut Reply with quote

I am trying to use Shotcut (version 18.03) on Gentoo, using the stock ebuild in portage. The program mostly runs fine but is missing the "3D Text" and "HTML Overlay" video filters.

When I run the program from the console, I see the "webvfx" and "webvfx_threejs_text" filters are being read in, but not added to the list:

Code:
...many lines of debug messages...
[Debug  ] <FilterController::loadFilterMetadata> reading filter metadata "vignette" "meta_oldfilm.qml"
[Debug  ] <FilterController::loadFilterMetadata> added filter "Vignette"
[Debug  ] <FilterController::loadFilterMetadata> reading filter metadata "wave" "meta.qml"
[Debug  ] <FilterController::loadFilterMetadata> reading filter metadata "webvfx" "meta.qml"
[Debug  ] <FilterController::loadFilterMetadata> reading filter metadata "webvfx_circular_frame" "meta.qml"
[Debug  ] <FilterController::loadFilterMetadata> reading filter metadata "webvfx_ruttetraizer" "meta.qml"
[Debug  ] <FilterController::loadFilterMetadata> reading filter metadata "webvfx_threejs_text" "meta.qml"
[Debug  ] <FilterController::loadFilterMetadata> reading filter metadata "white" "meta_frei0r.qml"
[Debug  ] <FilterController::loadFilterMetadata> added filter "White Balance"


Does anybody have any idea why these aren't working? Is there anything else I could check?
Back to top
View user's profile Send private message
michalg
n00b
n00b


Joined: 31 Jan 2019
Posts: 2

PostPosted: Thu Jan 31, 2019 3:01 pm    Post subject: Reply with quote

According to this

mlt library on gentoo has no WebVfx module.

Build it from sources and install solved 3DText and HTMLOverlay problem for me.

But... I do not have ordinary Text filter available... any ideas?

MichalG
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13493

PostPosted: Fri Feb 01, 2019 2:43 am    Post subject: Reply with quote

michalg wrote:
mlt library on gentoo has no WebVfx module.

Build it from sources and install solved 3DText and HTMLOverlay problem for me.

But... I do not have ordinary Text filter available... any ideas?
How exactly did you build WebVfx? Could you post the ebuild you wrote for this?
Back to top
View user's profile Send private message
michalg
n00b
n00b


Joined: 31 Jan 2019
Posts: 2

PostPosted: Fri Feb 01, 2019 9:25 am    Post subject: Reply with quote

I have got no ebuild. I just downloaded WebVfx sources from git repository and make install into /usr/lib64/mlt.
Back to top
View user's profile Send private message
PhobosK
n00b
n00b


Joined: 07 Apr 2007
Posts: 13

PostPosted: Tue Feb 19, 2019 8:23 pm    Post subject: Reply with quote

Hi all,
For my own usage I've created a very basic, quick and "dirty" live ebuild for webvfx.
It doesn't have any use flags and may be a bit over-dependent on some QT packages, but since this is used with Shotcut, these deps are already pulled there.
I have put the ebuild in my local repo in media-libs/webvfx

Here is the link to the gist: webvfx-9999.ebuild

After the emerge the 3D Text filters and the export work as expected.
The ebuild installs these files (but it is a live ebuild, so in time these can change):
Code:

~ # equery f media-libs/webvfx
 * Searching for webvfx in media-libs ...
 * Contents of media-libs/webvfx-9999:
/usr
/usr/bin
/usr/bin/qmelt
/usr/bin/webvfx_browser
/usr/bin/webvfx_render
/usr/bin/webvfx_viewer
/usr/lib
/usr/lib/libwebvfx.so -> libwebvfx.so.1.0.0
/usr/lib/libwebvfx.so.1 -> libwebvfx.so.1.0.0
/usr/lib/libwebvfx.so.1.0 -> libwebvfx.so.1.0.0
/usr/lib/libwebvfx.so.1.0.0
/usr/lib64
/usr/lib64/mlt
/usr/lib64/mlt/libmltwebvfx.so
/usr/share
/usr/share/doc
/usr/share/doc/webvfx-9999
/usr/share/doc/webvfx-9999/README.md.bz2


BTW there is a bug report connected to some extent to this post about missing filters: media-video/shotcut-18.03: export not work with "qmelt not found" but I have not proposed there any ebuild 'cause this one needs some extra work/polish.

I hope this info and the ebuild to be useful to those of you that use Shotcut :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum