Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
New Install on new hardware > X runs terrible slow and laggy
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
risq
Tux's lil' helper
Tux's lil' helper


Joined: 03 Dec 2004
Posts: 75

PostPosted: Sun Mar 18, 2018 9:49 am    Post subject: New Install on new hardware > X runs terrible slow and la Reply with quote

Hi gentoo-folks,

after quite some time i found myself back to gentoo. I installed successfully on my latest X1 carbon 2018er Edition, but i have a serious problem with the X-Server/GUI. everything feels slow and laggy, seems like no 2d Acceleration is active.


emerge --info Ouput
Code:


Portage 2.3.24 (python 3.5.4-final-0, default/linux/amd64/17.0/desktop, gcc-6.4.0, glibc-2.25-r10, 4.9.76-gentoo-r1 x86_64)
=================================================================
System uname: Linux-4.9.76-gentoo-r1-x86_64-Intel-R-_Core-TM-_i5-8250U_CPU_@_1.60GHz-with-gentoo-2.4.1
KiB Mem:     7931988 total,   7190172 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of repository gentoo: Wed, 14 Mar 2018 18:00:01 +0000
Head commit of repository gentoo: 04417076a13a10d172b6e00d22f04ffa128eae38
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.4-r1::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.12::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.15.1-r2::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r10::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: no
    sync-rsync-extra-opts:

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en de"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"




Xorg log
Code:

  2704.585]
X.Org X Server 1.19.5
Release Date: 2017-10-12
[  2704.588] X Protocol Version 11, Revision 0
[  2704.589] Build Operating System: Linux 4.9.76-gentoo-r1 x86_64 Gentoo
[  2704.590] Current Operating System: Linux localhost 4.9.76-gentoo-r1 #12 SMP Thu Mar 15 16:13:09 CET 2018 x86_64
[  2704.591] Kernel command line: BOOT_IMAGE=/vmlinuz-4 root=/dev/mapper/vg0-root ro dolvm crypt_root=UUID=1adf3d28-4917-4875-bbd0-14d5b9beba6e root=/dev/mapper/vg0-root
[  2704.593] Build Date: 11 March 2018  09:54:54PM
[  2704.595] 
[  2704.596] Current version of pixman: 0.34.0
[  2704.600]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[  2704.600] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  2704.607] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Mar 18 11:39:39 2018
[  2704.609] (==) Using config directory: "/etc/X11/xorg.conf.d"
[  2704.611] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  2704.611] (==) No Layout section.  Using the first Screen section.
[  2704.612] (==) No screen section available. Using defaults.
[  2704.612] (**) |-->Screen "Default Screen Section" (0)
[  2704.612] (**) |   |-->Monitor "<default monitor>"
[  2704.612] (==) No device specified for screen "Default Screen Section".
   Using the first device section listed.
[  2704.612] (**) |   |-->Device "Intel Graphics"
[  2704.612] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[  2704.612] (==) Automatically adding devices
[  2704.612] (==) Automatically enabling devices
[  2704.612] (==) Automatically adding GPU devices
[  2704.612] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  2704.612] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  2704.612]    Entry deleted from font path.
[  2704.612] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  2704.612]    Entry deleted from font path.
[  2704.612] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  2704.612]    Entry deleted from font path.
[  2704.612] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  2704.612]    Entry deleted from font path.
[  2704.612]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[  2704.612] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  2704.612]    Entry deleted from font path.
[  2704.612]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[  2704.612] (==) FontPath set to:
   /usr/share/fonts/misc/
[  2704.612] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  2704.612] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  2704.612] (II) Loader magic: 0x55e449207c60
[  2704.612] (II) Module ABI versions:
[  2704.612]    X.Org ANSI C Emulation: 0.4
[  2704.612]    X.Org Video Driver: 23.0
[  2704.612]    X.Org XInput driver : 24.1
[  2704.612]    X.Org Server Extension : 10.0
[  2704.613] (II) xfree86: Adding drm device (/dev/dri/card0)
[  2704.629] (--) PCI:*(0:0:2:0) 8086:5917:17aa:225c rev 7, Mem @ 0x2ffa000000/16777216, 0x2fa0000000/268435456, I/O @ 0x0000e000/64, BIOS @ 0x????????/131072
[  2704.629] (II) LoadModule: "glx"
[  2704.629] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[  2704.631] (II) Module glx: vendor="X.Org Foundation"
[  2704.631]    compiled for 1.19.5, module version = 1.0.0
[  2704.631]    ABI class: X.Org Server Extension, version 10.0
[  2704.632] (II) LoadModule: "intel"
[  2704.632] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[  2704.632] (II) Module intel: vendor="X.Org Foundation"
[  2704.632]    compiled for 1.19.5, module version = 2.99.917
[  2704.632]    Module class: X.Org Video Driver
[  2704.632]    ABI class: X.Org Video Driver, version 23.0
[  2704.632] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[  2704.633] (II) intel: Driver for Intel(R) HD Graphics
[  2704.633] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[  2704.633] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[  2704.633] (--) using VT number 7

[  2704.662] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20160919
[  2704.663] (--) intel(0): gen9 engineering sample
[  2704.663] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2; using a maximum of 4 threads
[  2704.663] (II) intel(0): Creating default Display subsection in Screen section
   "Default Screen Section" for depth/fbbpp 24/32
[  2704.663] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[  2704.663] (==) intel(0): RGB weight 888
[  2704.663] (==) intel(0): Default visual is TrueColor
[  2704.663] (**) intel(0): Option "AccelMethod" "glamor"
[  2704.664] (II) intel(0): Output eDP1 has no monitor section
[  2704.665] (**) intel(0): Found backlight control interface intel_backlight (type 'raw') for output eDP1
[  2704.665] (II) intel(0): Enabled output eDP1
[  2704.665] (II) intel(0): Output DP1 has no monitor section
[  2704.665] (II) intel(0): Enabled output DP1
[  2704.665] (II) intel(0): Output HDMI1 has no monitor section
[  2704.665] (II) intel(0): Enabled output HDMI1
[  2704.665] (II) intel(0): Output DP2 has no monitor section
[  2704.666] (II) intel(0): Enabled output DP2
[  2704.666] (II) intel(0): Output HDMI2 has no monitor section
[  2704.666] (II) intel(0): Enabled output HDMI2
[  2704.666] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[  2704.666] (II) intel(0): Output VIRTUAL1 has no monitor section
[  2704.666] (II) intel(0): Enabled output VIRTUAL1
[  2704.666] (--) intel(0): Output eDP1 using initial mode 2560x1440 on pipe 0
[  2704.666] (==) intel(0): TearFree disabled
[  2704.667] (==) intel(0): Using gamma correction (1.0, 1.0, 1.0)
[  2704.667] (==) intel(0): DPI set to (96, 96)
[  2704.667] (II) Loading sub module "dri3"
[  2704.667] (II) LoadModule: "dri3"
[  2704.667] (II) Module "dri3" already built-in
[  2704.667] (II) Loading sub module "dri2"
[  2704.667] (II) LoadModule: "dri2"
[  2704.667] (II) Module "dri2" already built-in
[  2704.667] (II) Loading sub module "present"
[  2704.667] (II) LoadModule: "present"
[  2704.667] (II) Module "present" already built-in
[  2704.667] (==) Depth 24 pixmap format is 32 bpp
[  2704.667] (II) intel(0): SNA initialized with Kabylake (gen9) backend
[  2704.667] (==) intel(0): Backing store enabled
[  2704.667] (==) intel(0): Silken mouse enabled
[  2704.667] (II) intel(0): HW Cursor enabled
[  2704.667] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[  2704.668] (==) intel(0): DPMS enabled
[  2704.668] (==) intel(0): Display hotplug detection enabled
[  2704.668] (II) intel(0): [DRI2] Setup complete
[  2704.668] (II) intel(0): [DRI2]   DRI driver: i965
[  2704.668] (II) intel(0): [DRI2]   VDPAU driver: va_gl
[  2704.668] (II) intel(0): direct rendering: DRI2 DRI3 enabled
[  2704.668] (II) intel(0): hardware support for Present enabled
[  2704.668] (--) RandR disabled
[  2704.686] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[  2704.686] (II) AIGLX: enabled GLX_ARB_create_context
[  2704.686] (II) AIGLX: enabled GLX_ARB_create_context_profile
[  2704.686] (II) AIGLX: enabled GLX_EXT_create_context_es{,2}_profile
[  2704.687] (II) AIGLX: enabled GLX_INTEL_swap_event
[  2704.687] (II) AIGLX: enabled GLX_SGI_swap_control
[  2704.687] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[  2704.687] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[  2704.687] (II) AIGLX: enabled GLX_EXT_fbconfig_packed_float
[  2704.687] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[  2704.687] (II) AIGLX: enabled GLX_ARB_create_context_robustness
[  2704.687] (II) AIGLX: Loaded and initialized i965
[  2704.687] (II) GLX: Initialized DRI2 GL provider for screen 0
[  2704.696] (II) intel(0): switch to mode 2560x1440@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[  2704.708] (II) intel(0): Setting screen physical size to 677 x 381
[  2704.767] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[  2704.767] (**) Power Button: Applying InputClass "libinput keyboard catchall"
[  2704.767] (II) LoadModule: "libinput"
[  2704.767] (II) Loading /usr/lib64/xorg/modules/input/libinput_drv.so
[  2704.768] (II) Module libinput: vendor="X.Org Foundation"
[  2704.768]    compiled for 1.19.5, module version = 0.25.1
[  2704.768]    Module class: X.Org XInput Driver
[  2704.768]    ABI class: X.Org XInput driver, version 24.1
[  2704.768] (II) Using input driver 'libinput' for 'Power Button'
[  2704.768] (**) Power Button: always reports core events
[  2704.768] (**) Option "Device" "/dev/input/event2"
[  2704.768] (**) Option "_source" "server/udev"
[  2704.769] (II) event2  - (II) Power Button: (II) is tagged by udev as: Keyboard
[  2704.769] (II) event2  - (II) Power Button: (II) device is a keyboard
[  2704.769] (II) event2  - (II) Power Button: (II) device removed
[  2704.780] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[  2704.780] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[  2704.781] (II) event2  - (II) Power Button: (II) is tagged by udev as: Keyboard
[  2704.781] (II) event2  - (II) Power Button: (II) device is a keyboard
[  2704.782] (II) config/udev: Adding input device Video Bus (/dev/input/event3)
[  2704.782] (**) Video Bus: Applying InputClass "libinput keyboard catchall"
[  2704.782] (II) Using input driver 'libinput' for 'Video Bus'
[  2704.782] (**) Video Bus: always reports core events
[  2704.782] (**) Option "Device" "/dev/input/event3"
[  2704.782] (**) Option "_source" "server/udev"
[  2704.782] (II) event3  - (II) Video Bus: (II) is tagged by udev as: Keyboard
[  2704.782] (II) event3  - (II) Video Bus: (II) device is a keyboard
[  2704.782] (II) event3  - (II) Video Bus: (II) device removed
[  2704.800] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input3/event3"
[  2704.800] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[  2704.801] (II) event3  - (II) Video Bus: (II) is tagged by udev as: Keyboard
[  2704.801] (II) event3  - (II) Video Bus: (II) device is a keyboard
[  2704.801] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
[  2704.801] (II) No input driver specified, ignoring this device.
[  2704.801] (II) This device may have been added with another device file.
[  2704.802] (II) config/udev: Adding input device Sleep Button (/dev/input/event0)
[  2704.802] (**) Sleep Button: Applying InputClass "libinput keyboard catchall"
[  2704.802] (II) Using input driver 'libinput' for 'Sleep Button'
[  2704.802] (**) Sleep Button: always reports core events
[  2704.802] (**) Option "Device" "/dev/input/event0"
[  2704.802] (**) Option "_source" "server/udev"
[  2704.802] (II) event0  - (II) Sleep Button: (II) is tagged by udev as: Keyboard
[  2704.802] (II) event0  - (II) Sleep Button: (II) device is a keyboard
[  2704.802] (II) event0  - (II) Sleep Button: (II) device removed
[  2704.812] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0E:00/input/input0/event0"
[  2704.812] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 8)
[  2704.813] (II) event0  - (II) Sleep Button: (II) is tagged by udev as: Keyboard
[  2704.813] (II) event0  - (II) Sleep Button: (II) device is a keyboard
[  2704.814] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event4)
[  2704.814] (**) AT Translated Set 2 keyboard: Applying InputClass "libinput keyboard catchall"
[  2704.814] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[  2704.814] (**) AT Translated Set 2 keyboard: always reports core events
[  2704.814] (**) Option "Device" "/dev/input/event4"
[  2704.814] (**) Option "_source" "server/udev"
[  2704.814] (II) event4  - (II) AT Translated Set 2 keyboard: (II) is tagged by udev as: Keyboard
[  2704.814] (II) event4  - (II) AT Translated Set 2 keyboard: (II) device is a keyboard
[  2704.814] (II) event4  - (II) AT Translated Set 2 keyboard: (II) device removed
[  2704.824] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input4/event4"
[  2704.824] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[  2704.825] (II) event4  - (II) AT Translated Set 2 keyboard: (II) is tagged by udev as: Keyboard
[  2704.825] (II) event4  - (II) AT Translated Set 2 keyboard: (II) device is a keyboard
[  2704.825] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event5)
[  2704.825] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "libinput touchpad catchall"
[  2704.825] (II) Using input driver 'libinput' for 'SynPS/2 Synaptics TouchPad'
[  2704.825] (**) SynPS/2 Synaptics TouchPad: always reports core events
[  2704.825] (**) Option "Device" "/dev/input/event5"
[  2704.825] (**) Option "_source" "server/udev"
[  2704.826] (II) event5  - (II) SynPS/2 Synaptics TouchPad: (II) is tagged by udev as: Touchpad
[  2704.826] (II) event5  - (II) SynPS/2 Synaptics TouchPad: (II) device is a touchpad
[  2704.826] (II) event5  - (II) SynPS/2 Synaptics TouchPad: (II) device removed
[  2704.844] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input6/event5"
[  2704.844] (II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD, id 10)
[  2704.844] (**) Option "AccelerationScheme" "none"
[  2704.845] (**) SynPS/2 Synaptics TouchPad: (accel) selected scheme none/0
[  2704.845] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration factor: 2.000
[  2704.845] (**) SynPS/2 Synaptics TouchPad: (accel) acceleration threshold: 4
[  2704.845] (II) event5  - (II) SynPS/2 Synaptics TouchPad: (II) is tagged by udev as: Touchpad
[  2704.845] (II) event5  - (II) SynPS/2 Synaptics TouchPad: (II) device is a touchpad
[  2704.846] (II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/mouse0)
[  2704.846] (II) No input driver specified, ignoring this device.
[  2704.846] (II) This device may have been added with another device file.
[  2704.846] (II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/event6)
[  2704.846] (**) TPPS/2 IBM TrackPoint: Applying InputClass "libinput pointer catchall"
[  2704.846] (II) Using input driver 'libinput' for 'TPPS/2 IBM TrackPoint'
[  2704.846] (**) TPPS/2 IBM TrackPoint: always reports core events
[  2704.846] (**) Option "Device" "/dev/input/event6"
[  2704.846] (**) Option "_source" "server/udev"
[  2704.847] (II) event6  - (II) TPPS/2 IBM TrackPoint: (II) is tagged by udev as: Mouse Pointingstick
[  2704.847] (II) event6  - (II) TPPS/2 IBM TrackPoint: (II) trackpoint device set to range 20
[  2704.847] (II) event6  - (II) TPPS/2 IBM TrackPoint: (II) device is a pointer
[  2704.847] (II) event6  - (II) TPPS/2 IBM TrackPoint: (II) device removed
[  2704.864] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/serio2/input/input7/event6"
[  2704.864] (II) XINPUT: Adding extended input device "TPPS/2 IBM TrackPoint" (type: MOUSE, id 11)
[  2704.864] (**) Option "AccelerationScheme" "none"
[  2704.864] (**) TPPS/2 IBM TrackPoint: (accel) selected scheme none/0
[  2704.864] (**) TPPS/2 IBM TrackPoint: (accel) acceleration factor: 2.000
[  2704.864] (**) TPPS/2 IBM TrackPoint: (accel) acceleration threshold: 4
[  2704.865] (II) event6  - (II) TPPS/2 IBM TrackPoint: (II) is tagged by udev as: Mouse Pointingstick
[  2704.865] (II) event6  - (II) TPPS/2 IBM TrackPoint: (II) trackpoint device set to range 20
[  2704.865] (II) event6  - (II) TPPS/2 IBM TrackPoint: (II) device is a pointer
[  2704.866] (II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/mouse1)
[  2704.866] (II) No input driver specified, ignoring this device.
[  2704.866] (II) This device may have been added with another device file.
[  2706.667] (II) intel(0): EDID vendor "AUO", prod id 9014
[  2706.667] (II) intel(0): Printing DDC gathered Modelines:
[  2706.667] (II) intel(0): Modeline "2560x1440"x0.0  245.50  2560 2608 2640 2720  1440 1443 1448 1504 -hsync -vsync (90.3 kHz eP)


I appreciate any help with this, thank u in advance

risq
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6308
Location: /usr/lib64/lv2

PostPosted: Mon Mar 19, 2018 1:39 pm    Post subject: Reply with quote

I was puzzling over this since I saw your post yesterday. From the log, it looks like everything should be working.

How did you compile your kernel? If you compiled manually, try genkernel and see if it sorts out the drivers automatically.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Zucca
Veteran
Veteran


Joined: 14 Jun 2007
Posts: 1460
Location: KUUSANKOSKI, Finland

PostPosted: Mon Mar 19, 2018 4:35 pm    Post subject: Reply with quote

Code:
[  2704.665] (II) intel(0): Enabled output eDP1
[  2704.665] (II) intel(0): Output DP1 has no monitor section
[  2704.665] (II) intel(0): Enabled output DP1
[  2704.665] (II) intel(0): Output HDMI1 has no monitor section
[  2704.665] (II) intel(0): Enabled output HDMI1
[  2704.665] (II) intel(0): Output DP2 has no monitor section
[  2704.666] (II) intel(0): Enabled output DP2
[  2704.666] (II) intel(0): Output HDMI2 has no monitor section
[  2704.666] (II) intel(0): Enabled output HDMI2
[  2704.666] (--) intel(0): Using a maximum size of 256x256 for hardware cursors
[  2704.666] (II) intel(0): Output VIRTUAL1 has no monitor section
[  2704.666] (II) intel(0): Enabled output VIRTUAL1
[  2704.666] (--) intel(0): Output eDP1 using initial mode 2560x1440 on pipe 0
My eye was caught by this.
You may need to create a config file to /etc/X11/xorg.conf.d/.
It's still strange... Also since your hardware is quite new, you may need to install development version of the graphics driver for xorg.
_________________
..: Zucca :..

Code:
ERROR: '--failure' is not an option. Aborting...
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7692
Location: Pelotas, BR

PostPosted: Mon Mar 19, 2018 6:54 pm    Post subject: Reply with quote

Moved from Installing Gentoo to Desktop Environments.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
hhfeuer
Apprentice
Apprentice


Joined: 28 Jul 2005
Posts: 156

PostPosted: Mon Mar 19, 2018 8:53 pm    Post subject: Reply with quote

You forgot to set
VIDEO_CARDS="intel i965"
in make.conf. Also make sure you installed the firmware for the intel gpu.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum