Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Firefox] INADEQUATE_SECURITY error on visiting many sites
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
alogim
Tux's lil' helper
Tux's lil' helper


Joined: 21 Aug 2015
Posts: 112

PostPosted: Tue Mar 13, 2018 6:00 pm    Post subject: [Firefox] INADEQUATE_SECURITY error on visiting many sites Reply with quote

I just opened Firefox today (which is my default one) and the most well-known web sites failed to load.

The following error is shown:
Code:
The website tried to negotiate an inadequate level of security.

duckduckgo.com uses security technology that is outdated and vulnerable to attack. An attacker could easily reveal information which you thought to be safe. The website administrator will need to fix the server first before you can visit the site.

Error code: NS_ERROR_NET_INADEQUATE_SECURITY


Both Chromium and Tor load the same web pages that Firefox fails to load. I already tried re-emerging app-misc/ca-certificates and dev-libs/openssl. The only way to fix it is by disabling HTTP/2, as explained here.

Is it completely safe to do that? I suppose it forces to use HTTP/1.1 instead of 2.

Oh, by the way my Firefox is currently version 52.6.0, emerged on January 28, 2018.
_________________
Desktop: i5-3570k - 2x4 GB - Sapphire HD 7950 Dual-X - 500 GB WD Caviar Black - Dell SE2717H 27"
Laptop: HP EliteBook 850 G5 - i7-8550U - 1x16GB - Intel UHD 620 - 512 GB Samsung NVMe SSD
Phone: OnePlus 5T - SD835 - 8 GB - Adreno 540 - 128 GB
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6308
Location: /usr/lib64/lv2

PostPosted: Sat Mar 17, 2018 2:09 pm    Post subject: Reply with quote

There's a big difference between stable and ~arch for Firefox. Try putting www-client/firefox ~amd64 (or your ~arch keyword) in package.accept_keywords and updating Firefox to the latest Mozilla-official release. There are known security vulns for older versions of FF.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13512

PostPosted: Sat Mar 17, 2018 3:22 pm    Post subject: Reply with quote

audiodef wrote:
There are known security vulns for older versions of FF.
The point of the ESR line is to let people use an older line of Firefox and still receive security support. The original poster is on the current ESR line (although there is one newer release in that line, 52.7). Do you mean that he needs to update to 52.7 or that you want him to update to non-ESR? If the latter, could you provide a citation for what security issues are fixed in non-ESR and not fixed in ESR?
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6308
Location: /usr/lib64/lv2

PostPosted: Sat Mar 17, 2018 7:14 pm    Post subject: Reply with quote

Oops, I was thinking of this: https://forums.gentoo.org/viewtopic-t-1077346.html

alogim has 52.6, which is not affected. My bad. :cry:
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13512

PostPosted: Sat Mar 17, 2018 8:34 pm    Post subject: Reply with quote

Mistakes happen. That's why I wanted a citation. :)
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6308
Location: /usr/lib64/lv2

PostPosted: Sat Mar 17, 2018 9:41 pm    Post subject: Reply with quote

I think you meant to say that I deserve a citation. :lol:
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum