Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] xorg and mouse not working after world update
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
mikefot
Guru
Guru


Joined: 19 Nov 2014
Posts: 491

PostPosted: Fri Mar 09, 2018 12:49 pm    Post subject: Reply with quote

Many thanks for the advice here.

I ran

Code:
emerge -D @{x11-,}module-rebuild


and I can now run startx as root and xfce runs OK and the mouse now WORKS!

This is a big advance for me here.

Thanks a lot.

I need to get the package mask thing working to stop
Code:
xorg-server-9999
being installed on any world updates or rebuilds relative
to the 19-901-r1 latest xorg package.......

I will fix this problem and then run

Code:
emerge -D @{x11-,}module-rebuild


again and see if I end up with a further improvement in the x environment and mouse function - maybe sddm will start working and kde will come back to
life as well.

But life as xfce as root with a working mouse is a big plus at present.

Cheers

MF

PS I used the package mask file to exclude the xorg 9999 package.

I ran the module rebuild command again.

There is no change. Xfce still works OK as root only.

It's not so bad for the time being.

PPS After a recent world update for some reason portage downgraded to the previous version of xorg-server......

It also installed several new video card packages and other xorg related packages.

And there has been an improvement!

Now I can run startx as a user and xfce works.

So does the xfce terminal now aswell.

But sddm is still not working and neither is kde etc.

When you boot up you go the command line login prompt.

No sddm window manager etc.

And yet, it is an advance over where I was recently.

Cheers

MF

PPPS

I ran another world update and have some dependency problems:


Code:
djt /usr/portage/profiles # emerge --update --newuse --deep @world
Calculating dependencies... done!

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

media-libs/phonon-vlc:0

  (media-libs/phonon-vlc-0.10.1:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=media-libs/phonon-vlc-0.9.0[qt4,qt5] required by (media-libs/phonon-4.9.1-r1:0/0::gentoo, installed)
                                  ^^^ ^^^

media-libs/phonon-gstreamer:0

  (media-libs/phonon-gstreamer-4.9.0-r2:0/0::gentoo, ebuild scheduled for merge) conflicts with
    >=media-libs/phonon-gstreamer-4.9.0[qt4,qt5] required by (media-libs/phonon-4.9.1-r1:0/0::gentoo, installed)
                                        ^^^ ^^^

media-libs/phonon:0

  (media-libs/phonon-4.10.0:0/0::gentoo, ebuild scheduled for merge) conflicts with
    media-libs/phonon[qt4] required by (kde-frameworks/kdelibs-4.14.37:4/4.14::gentoo, installed)
                      ^^^
    >=media-libs/phonon-4.9.0[qt4,qt5] required by (media-libs/phonon-gstreamer-4.9.0-r1:0/0::gentoo, installed)
                              ^^^ ^^^
    >=media-libs/phonon-4.9.0[qt4,qt5] required by (media-libs/phonon-vlc-0.9.1-r1:0/0::gentoo, installed)
                              ^^^ ^^^

>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
djt /usr/portage/profiles #


Comments on this appreciated.

Cheers

MF

PPPS I have fixed the problem with sddm and kde is now working again.

MF
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum