Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
startx failes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ygnmhdtt
n00b
n00b


Joined: 27 Dec 2017
Posts: 6

PostPosted: Sun Feb 25, 2018 11:41 pm    Post subject: startx failes Reply with quote

Hi
I want to create desktop environment on my gentoo,
So I did like https://wiki.gentoo.org/wiki/Systemd/Installing_Gnome3_from_scratch, but it failes at `Check startx` .
My x does not start.
This is STDOUT:

Code:

$ startx
xauth:  file /home/ygnmhdtt/.serverauth.7569 does not exist


X.Org X Server 1.19.5
Release Date: 2017-10-12
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.14.8-gentoo-r1 x86_64 Gentoo
Current Operating System: Linux localhost 4.14.8-gentoo-r1 #1 SMP Sun Dec 31 09:57:03 JST 2017 x86_64
Kernel command line: BOOT_IMAGE=/kernel-genkernel-x86_64-4.14.8-gentoo-r1 root=UUID=f72d19d7-f3a0-4cfe-bdda-1ccdc5354ebd ro init=/usr/lib/systemd/systemd
Build Date: 26 February 2018  08:05:16AM

Current version of pixman: 0.34.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb 26 17:27:19 2018
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.

Couldn't get a file descriptor referring to the console


This is my /var/log/Xorg.0.log: https://pastebin.com/u2Pbt5QQ

Please order me any other necessary config file or logs.
Thanks.

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Mon Feb 26, 2018 1:31 am    Post subject: Reply with quote

What do you have your $XSESSION environment variable set to? If it's unset, try setting it to "gnome-session"?

I suspect the guide probably wants you to set up gdm which will do this automatically.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
ygnmhdtt
n00b
n00b


Joined: 27 Dec 2017
Posts: 6

PostPosted: Mon Feb 26, 2018 2:59 am    Post subject: Reply with quote

Quote:

What do you have your $XSESSION environment variable set to? If it's unset, try setting it to "gnome-session"?

I suspect the guide probably wants you to set up gdm which will do this automatically.


Thanks for replying!
$XSESSION was unset, and I tried export `XSESSION="gnome-session"` and tried startx,
But it doesn't work. (Logs haven't chenged at all.)
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Mon Feb 26, 2018 3:21 am    Post subject: Reply with quote

Make sure you don't have a ~/.xinitrc or a ~/.xsession

At least doing this:
Code:
$ XSESSION=gnome-session startx

seems to work on my machine where if I omit XSESSION=xxx it will fail.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum