Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
printer queue stalls after recent sync update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mikefot
Guru
Guru


Joined: 19 Nov 2014
Posts: 394

PostPosted: Mon Feb 12, 2018 9:58 am    Post subject: printer queue stalls after recent sync update Reply with quote

Dear All,

My Brother DCP 7030 printer was running fine with a brlaser manually compiled driver·

Something has done funny perhaps with cups since a recent eix-sync and world update.

I have tried deleting the printer and adding it again in the kde plasma printer utility I use but it has not fixed the problem.

When I tried running the manage printer utility I get the following message:

Code:
localhost:socket operation timed out


The cups localhost page shows the following:

https://screenshots.firefox.com/mbbSnB4AFvbjpqH4/localhost

The printer jobs say they are completed but the printer is not triggered to start printing them etc.

https://screenshots.firefox.com/zzZUUtEYW5oLB8Lk/localhost

Comments appreciated.



PS I tried installing cups 2.2.4 instead of 2.2.6 but this did not help.

Here is some output from printer queue:

Code:
djt /home/mikef # tail /var/log/cups/error_log
W [14/Feb/2018:17:13:10 +0000] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [14/Feb/2018:17:13:10 +0000] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
E [14/Feb/2018:17:13:13 +0000] Unknown directive JobPrivateAccess on line 121 of /etc/cups/cupsd.conf.
E [14/Feb/2018:17:13:13 +0000] Unknown directive JobPrivateValues on line 122 of /etc/cups/cupsd.conf.
E [14/Feb/2018:17:13:13 +0000] Unknown directive SubscriptionPrivateAccess on line 124 of /etc/cups/cupsd.conf.
E [14/Feb/2018:17:13:13 +0000] Unknown directive SubscriptionPrivateValues on line 125 of /etc/cups/cupsd.conf.
W [14/Feb/2018:17:13:13 +0000] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
W [14/Feb/2018:17:13:13 +0000] CreateDevice failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files
E [14/Feb/2018:17:33:05 +0000] [CGI] Unable to execute ippfind utility: No such file or directory
E [14/Feb/2018:17:33:26 +0000] [CGI] Unable to execute ippfind utility: No such file or directory
djt /home/mikef #


What this Color Manager thing is I am not certain.......

The output of ifconfig is:

Code:
djt /home/mikef # ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.123  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::52ac:a865:9b0a:d691  prefixlen 64  scopeid 0x20<link>
        ether 74:d4:35:b2:0d:2c  txqueuelen 1000  (Ethernet)
        RX packets 775946  bytes 949748586 (905.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 509659  bytes 67734845 (64.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 731  bytes 128300 (125.2 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 731  bytes 128300 (125.2 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

djt /home/mikef #


Would it help if I use the IP address
Code:
inet 192.168.1.123


as a address for the printer for an isolated PC like mine or is that not needed?

Cheers

MF

PS

It does seem that the printer has been detected:

Code:
djt /home/mikef # lsusb
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 04f9:01ea Brother Industries, Ltd DCP-7030
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 14cd:125c Super Top SD card reader
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 003: ID 04d9:a061 Holtek Semiconductor, Inc.
Bus 003 Device 002: ID 1bcf:0005 Sunplus Innovation Technology Inc. Optical Mouse
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


It is the Brother DCP-7030 device 002

I tried another command recommended to check if the printer is detected:

Code:
djt /home/mikef # dmesg | grep -i print
[25331.351533] usblp 4-4:1.0: usblp0: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04F9 pid 0x01EA


The output is not very specific here.

The output of

lpinfo -v and lpinfo -m is found here:

https://paste.debian.net/1010285/

The manually compiled and installed brlaser driver is present
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum