Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Chrome + Bluetooth audio
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
dgulotta
n00b
n00b


Joined: 09 Jan 2006
Posts: 74
Location: New York, NY

PostPosted: Mon Feb 12, 2018 3:18 am    Post subject: Chrome + Bluetooth audio Reply with quote

I am trying to get Bluetooth audio to work with Chrome. I can play audio on my laptop speakers in Chrome, and I can play Bluetooth audio in mplayer using the command
Code:
mplayer -ao alsa:device=bluealsa

I tried running
Code:
google-chrome-stable --alsa-output-device=bluealsa

If I then try to play an ogg file in Chrome, the timer gets stuck at 0:00 for a while. Eventually Chrome logs the message
Code:
[95:111:0211/214331.369055:ERROR:render_media_log.cc(30)] MediaEvent: MEDIA_ERROR_LOG_ENTRY {"error":"Output device error, falling back to null sink"}

to the console and the timer starts moving. If I specify a nonexistent device, then the timer starts moving right away and I get a different error message, so it appears that Chrome is at least finding the bluealsa device.

I tried using Pulseaudio to see if that would fix the problem. However, Pulseaudio does not seem to be able to find the Bluetooth device. I also tried Jack; Chrome won't even play audio on the laptop speakers when jackd is running (again the timer gets stuck at zero).
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 395
Location: Brazil

PostPosted: Mon Feb 12, 2018 4:17 am    Post subject: Reply with quote

Did you compile pulseaudio with Bluetooth support?
Back to top
View user's profile Send private message
dgulotta
n00b
n00b


Joined: 09 Jan 2006
Posts: 74
Location: New York, NY

PostPosted: Mon Feb 12, 2018 5:34 am    Post subject: Reply with quote

I did forget to do that, thanks. The headphones work with pulseaudio now. I would still be interested in getting them to work in Chrome with just ALSA.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum